Message ID | m3hb33dett.fsf@trasno.mitica |
---|---|
State | New |
Headers | show |
On 10/20/2011 07:31 AM, Juan Quintela wrote: > > Anthony, > > Here are the pending patches of my migration series: > - subsections detection fix > - migration cleanup > - migration errors > > Please consider pulling O:-) > > Thanks, Juan. > > The following changes since commit cfce6d8934243871c4dc6d0c5248b0b27a1b8d80: > > i8259: Move to hw library (2011-10-16 11:11:56 +0000) Pulled. Thanks. Regards, Anthony Liguori > > are available in the git repository at: > git://repo.or.cz/qemu/quintela.git migration-pull > > Juan Quintela (41): > savevm: teach qemu_fill_buffer to do partial refills > savevm: some coding style cleanups > savevm: define qemu_get_byte() using qemu_peek_byte() > savevm: improve subsections detection on load > Revert "savevm: fix corruption in vmstate_subsection_load()." > ds1225y: Use stdio instead of QEMUFile > migration: simplify state assignmente > migration: Check that migration is active before cancel it > migration: If there is one error, it makes no sense to continue > buffered_file: Use right "opaque" > buffered_file: reuse QEMUFile has_error field > migration: don't "write" when migration is not active > migration: set error if select return one error > migration: change has_error to contain errno values > migration: return real error code > migration: rename qemu_file_has_error to qemu_file_get_error > savevm: Rename has_error to last_error field > migration: use qemu_file_get_error() return value when possible > migration: make *save_live return errors > migration: Make *start_outgoing_migration return FdMigrationState > migration: Use FdMigrationState instead of MigrationState when possible > migration: Fold MigrationState into FdMigrationState > migration: Rename FdMigrationState MigrationState > migration: Refactor MigrationState creation > migration: Make all posible migration functions static > migration: move migrate_new to do_migrate > migration: Introduce MIG_STATE_SETUP > migration: Refactor and simplify error checking in migrate_fd_put_ready > migration: Introduce migrate_fd_completed() for consistency > migration: Our release callback was just free > migration: Remove get_status() accessor > migration: Remove migration cancel() callback > migration: Move exported functions to the end of the file > migration: create accessor for current_migration > migration: Use bandwidth_limit directly > migration: Pass MigrationState in migration notifiers > migration: Export a function that tells if the migration has finished correctly > migration: Make state definitions local > migration: Don't use callback on file defining it > migration: propagate error correctly > migration: make migration-{tcp,unix} consistent > > Yoshiaki Tamura (1): > migration: add error handling to migrate_fd_put_notify(). > > arch_init.c | 17 ++- > block-migration.c | 35 +++-- > buffered_file.c | 44 ++++-- > hw/ds1225y.c | 28 ++-- > hw/hw.h | 4 +- > migration-exec.c | 39 +---- > migration-fd.c | 42 +---- > migration-tcp.c | 76 ++++------ > migration-unix.c | 113 ++++++--------- > migration.c | 439 +++++++++++++++++++++++++++-------------------------- > migration.h | 85 ++--------- > savevm.c | 222 +++++++++++++++++---------- > ui/spice-core.c | 4 +- > 13 files changed, 550 insertions(+), 598 deletions(-) > >