Message ID | b9605839090fd145b067db34b2bdce45548c0631.1715555763.git.balaton@eik.bme.hu |
---|---|
State | New |
Headers | show |
Series | Misc PPC exception and BookE MMU clean ups | expand |
On Mon May 13, 2024 at 9:28 AM AEST, BALATON Zoltan wrote: > The mmask local variable is a less descriptive local name for a > constant. Drop it and use the constant directly in the two places it > is needed. Wow, lots more. I might take up to patch 34ish for first PR. Thanks, Nick > > Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu> > --- > target/ppc/mmu_common.c | 5 ++--- > 1 file changed, 2 insertions(+), 3 deletions(-) > > diff --git a/target/ppc/mmu_common.c b/target/ppc/mmu_common.c > index 9e0bfbda67..5d0090014a 100644 > --- a/target/ppc/mmu_common.c > +++ b/target/ppc/mmu_common.c > @@ -98,7 +98,7 @@ static int ppc6xx_tlb_pte_check(mmu_ctx_t *ctx, target_ulong pte0, > target_ulong pte1, int h, > MMUAccessType access_type) > { > - target_ulong ptem, mmask; > + target_ulong ptem; > int ret, pteh, ptev, pp; > > ret = -1; > @@ -108,12 +108,11 @@ static int ppc6xx_tlb_pte_check(mmu_ctx_t *ctx, target_ulong pte0, > if (ptev && h == pteh) { > /* Check vsid & api */ > ptem = pte0 & PTE_PTEM_MASK; > - mmask = PTE_CHECK_MASK; > pp = pte1 & 0x00000003; > if (ptem == ctx->ptem) { > if (ctx->raddr != (hwaddr)-1ULL) { > /* all matches should have equal RPN, WIMG & PP */ > - if ((ctx->raddr & mmask) != (pte1 & mmask)) { > + if ((ctx->raddr & PTE_CHECK_MASK) != (pte1 & PTE_CHECK_MASK)) { > qemu_log_mask(CPU_LOG_MMU, "Bad RPN/WIMG/PP\n"); > return -3; > }
On Fri, 17 May 2024, Nicholas Piggin wrote: > On Mon May 13, 2024 at 9:28 AM AEST, BALATON Zoltan wrote: >> The mmask local variable is a less descriptive local name for a >> constant. Drop it and use the constant directly in the two places it >> is needed. > > Wow, lots more. I might take up to patch 34ish for first PR. Yes I think that might be a good idea, just what I said in previous reply, as I have some more already even compared to this version. There's a lot to clean up in this series and I did not even attempt to fix the 6xx cases that I won't do because I don't know it so just tried to separate these and do some trivial clean up/improvement. Regards, BALATON Zoltan > Thanks, > Nick > >> >> Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu> >> --- >> target/ppc/mmu_common.c | 5 ++--- >> 1 file changed, 2 insertions(+), 3 deletions(-) >> >> diff --git a/target/ppc/mmu_common.c b/target/ppc/mmu_common.c >> index 9e0bfbda67..5d0090014a 100644 >> --- a/target/ppc/mmu_common.c >> +++ b/target/ppc/mmu_common.c >> @@ -98,7 +98,7 @@ static int ppc6xx_tlb_pte_check(mmu_ctx_t *ctx, target_ulong pte0, >> target_ulong pte1, int h, >> MMUAccessType access_type) >> { >> - target_ulong ptem, mmask; >> + target_ulong ptem; >> int ret, pteh, ptev, pp; >> >> ret = -1; >> @@ -108,12 +108,11 @@ static int ppc6xx_tlb_pte_check(mmu_ctx_t *ctx, target_ulong pte0, >> if (ptev && h == pteh) { >> /* Check vsid & api */ >> ptem = pte0 & PTE_PTEM_MASK; >> - mmask = PTE_CHECK_MASK; >> pp = pte1 & 0x00000003; >> if (ptem == ctx->ptem) { >> if (ctx->raddr != (hwaddr)-1ULL) { >> /* all matches should have equal RPN, WIMG & PP */ >> - if ((ctx->raddr & mmask) != (pte1 & mmask)) { >> + if ((ctx->raddr & PTE_CHECK_MASK) != (pte1 & PTE_CHECK_MASK)) { >> qemu_log_mask(CPU_LOG_MMU, "Bad RPN/WIMG/PP\n"); >> return -3; >> } > > >
diff --git a/target/ppc/mmu_common.c b/target/ppc/mmu_common.c index 9e0bfbda67..5d0090014a 100644 --- a/target/ppc/mmu_common.c +++ b/target/ppc/mmu_common.c @@ -98,7 +98,7 @@ static int ppc6xx_tlb_pte_check(mmu_ctx_t *ctx, target_ulong pte0, target_ulong pte1, int h, MMUAccessType access_type) { - target_ulong ptem, mmask; + target_ulong ptem; int ret, pteh, ptev, pp; ret = -1; @@ -108,12 +108,11 @@ static int ppc6xx_tlb_pte_check(mmu_ctx_t *ctx, target_ulong pte0, if (ptev && h == pteh) { /* Check vsid & api */ ptem = pte0 & PTE_PTEM_MASK; - mmask = PTE_CHECK_MASK; pp = pte1 & 0x00000003; if (ptem == ctx->ptem) { if (ctx->raddr != (hwaddr)-1ULL) { /* all matches should have equal RPN, WIMG & PP */ - if ((ctx->raddr & mmask) != (pte1 & mmask)) { + if ((ctx->raddr & PTE_CHECK_MASK) != (pte1 & PTE_CHECK_MASK)) { qemu_log_mask(CPU_LOG_MMU, "Bad RPN/WIMG/PP\n"); return -3; }
The mmask local variable is a less descriptive local name for a constant. Drop it and use the constant directly in the two places it is needed. Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu> --- target/ppc/mmu_common.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-)