Message ID | 20230929083143.234553-1-clg@kaod.org |
---|---|
State | New |
Headers | show |
Series | [v2] target/ppc: Rename variables to avoid local variable shadowing in VUPKPX | expand |
29.09.2023 11:31, Cédric Le Goater пишет: > and fix such warnings : > > ../target/ppc/int_helper.c: In function ‘helper_vupklpx’: > ../target/ppc/int_helper.c:2025:21: warning: declaration of ‘r’ shadows a parameter [-Wshadow=local] > 2025 | uint8_t r = (e >> 10) & 0x1f; \ > | ^ > ../target/ppc/int_helper.c:2033:1: note: in expansion of macro ‘VUPKPX’ > 2033 | VUPKPX(lpx, UPKLO) > | ^~~~~~ > ../target/ppc/int_helper.c:2017:41: note: shadowed declaration is here > 2017 | void helper_vupk##suffix(ppc_avr_t *r, ppc_avr_t *b) \ > | ~~~~~~~~~~~^ > ../target/ppc/int_helper.c:2033:1: note: in expansion of macro ‘VUPKPX’ > 2033 | VUPKPX(lpx, UPKLO) > | ^~~~~~ > > Signed-off-by: Cédric Le Goater <clg@kaod.org> > --- > > v2: changed all locals to start with '_' (Michael) > > target/ppc/int_helper.c | 12 ++++++------ > 1 file changed, 6 insertions(+), 6 deletions(-) > > diff --git a/target/ppc/int_helper.c b/target/ppc/int_helper.c > index 6fd00684a5b9..0a5c3e78a413 100644 > --- a/target/ppc/int_helper.c > +++ b/target/ppc/int_helper.c > @@ -2020,13 +2020,13 @@ void helper_vsum4ubs(CPUPPCState *env, ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b) > ppc_avr_t result; \ > \ > for (i = 0; i < ARRAY_SIZE(r->u32); i++) { \ > - uint16_t e = b->u16[hi ? i : i + 4]; \ > - uint8_t a = (e >> 15) ? 0xff : 0; \ > - uint8_t r = (e >> 10) & 0x1f; \ > - uint8_t g = (e >> 5) & 0x1f; \ > - uint8_t b = e & 0x1f; \ > + uint16_t _e = b->u16[hi ? i : i + 4]; \ > + uint8_t _a = (_e >> 15) ? 0xff : 0; \ > + uint8_t _r = (_e >> 10) & 0x1f; \ > + uint8_t _g = (_e >> 5) & 0x1f; \ > + uint8_t _b = _e & 0x1f; \ > \ > - result.u32[i] = (a << 24) | (r << 16) | (g << 8) | b; \ > + result.u32[i] = (_a << 24) | (_r << 16) | (_g << 8) | _b; \ > } \ > *r = result; \ > } Reviewed-by: Michael Tokarev <mjt@tls.msk.ru> /mjt
Cédric Le Goater <clg@kaod.org> writes: > and fix such warnings : > > ../target/ppc/int_helper.c: In function ‘helper_vupklpx’: > ../target/ppc/int_helper.c:2025:21: warning: declaration of ‘r’ shadows a parameter [-Wshadow=local] > 2025 | uint8_t r = (e >> 10) & 0x1f; \ > | ^ > ../target/ppc/int_helper.c:2033:1: note: in expansion of macro ‘VUPKPX’ > 2033 | VUPKPX(lpx, UPKLO) > | ^~~~~~ > ../target/ppc/int_helper.c:2017:41: note: shadowed declaration is here > 2017 | void helper_vupk##suffix(ppc_avr_t *r, ppc_avr_t *b) \ > | ~~~~~~~~~~~^ > ../target/ppc/int_helper.c:2033:1: note: in expansion of macro ‘VUPKPX’ > 2033 | VUPKPX(lpx, UPKLO) > | ^~~~~~ > > Signed-off-by: Cédric Le Goater <clg@kaod.org> Queued. Thanks!
diff --git a/target/ppc/int_helper.c b/target/ppc/int_helper.c index 6fd00684a5b9..0a5c3e78a413 100644 --- a/target/ppc/int_helper.c +++ b/target/ppc/int_helper.c @@ -2020,13 +2020,13 @@ void helper_vsum4ubs(CPUPPCState *env, ppc_avr_t *r, ppc_avr_t *a, ppc_avr_t *b) ppc_avr_t result; \ \ for (i = 0; i < ARRAY_SIZE(r->u32); i++) { \ - uint16_t e = b->u16[hi ? i : i + 4]; \ - uint8_t a = (e >> 15) ? 0xff : 0; \ - uint8_t r = (e >> 10) & 0x1f; \ - uint8_t g = (e >> 5) & 0x1f; \ - uint8_t b = e & 0x1f; \ + uint16_t _e = b->u16[hi ? i : i + 4]; \ + uint8_t _a = (_e >> 15) ? 0xff : 0; \ + uint8_t _r = (_e >> 10) & 0x1f; \ + uint8_t _g = (_e >> 5) & 0x1f; \ + uint8_t _b = _e & 0x1f; \ \ - result.u32[i] = (a << 24) | (r << 16) | (g << 8) | b; \ + result.u32[i] = (_a << 24) | (_r << 16) | (_g << 8) | _b; \ } \ *r = result; \ }
and fix such warnings : ../target/ppc/int_helper.c: In function ‘helper_vupklpx’: ../target/ppc/int_helper.c:2025:21: warning: declaration of ‘r’ shadows a parameter [-Wshadow=local] 2025 | uint8_t r = (e >> 10) & 0x1f; \ | ^ ../target/ppc/int_helper.c:2033:1: note: in expansion of macro ‘VUPKPX’ 2033 | VUPKPX(lpx, UPKLO) | ^~~~~~ ../target/ppc/int_helper.c:2017:41: note: shadowed declaration is here 2017 | void helper_vupk##suffix(ppc_avr_t *r, ppc_avr_t *b) \ | ~~~~~~~~~~~^ ../target/ppc/int_helper.c:2033:1: note: in expansion of macro ‘VUPKPX’ 2033 | VUPKPX(lpx, UPKLO) | ^~~~~~ Signed-off-by: Cédric Le Goater <clg@kaod.org> --- v2: changed all locals to start with '_' (Michael) target/ppc/int_helper.c | 12 ++++++------ 1 file changed, 6 insertions(+), 6 deletions(-)