diff mbox

[04/12] qga: rename 'path' to 'device_path'

Message ID 1435751267-26378-5-git-send-email-marcandre.lureau@gmail.com
State New
Headers show

Commit Message

Marc-André Lureau July 1, 2015, 11:47 a.m. UTC
'path' is already a global function, rename the variable since it's
going to be in global scope in a later patch.

Signed-off-by: Marc-André Lureau <marcandre.lureau@gmail.com>
---
 qga/main.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

Comments

Michael Roth Aug. 25, 2015, 3:55 p.m. UTC | #1
Quoting Marc-André Lureau (2015-07-01 06:47:39)
> 'path' is already a global function, rename the variable since it's
> going to be in global scope in a later patch.
> 
> Signed-off-by: Marc-André Lureau <marcandre.lureau@gmail.com>

I think I'd prefer something like 'channel_path' since we support
sockets as well. Looks good otherwise.

> ---
>  qga/main.c | 9 +++++----
>  1 file changed, 5 insertions(+), 4 deletions(-)
> 
> diff --git a/qga/main.c b/qga/main.c
> index 0c455f8..1c81575 100644
> --- a/qga/main.c
> +++ b/qga/main.c
> @@ -944,7 +944,7 @@ static GList *split_list(gchar *str, const gchar separator)
>  int main(int argc, char **argv)
>  {
>      const char *sopt = "hVvdm:p:l:f:F::b:s:t:";
> -    const char *method = NULL, *path = NULL;
> +    const char *method = NULL, *device_path = NULL;
>      const char *log_filepath = NULL;
>      const char *pid_filepath;
>  #ifdef CONFIG_FSFREEZE
> @@ -990,7 +990,7 @@ int main(int argc, char **argv)
>              method = optarg;
>              break;
>          case 'p':
> -            path = optarg;
> +            device_path = optarg;
>              break;
>          case 'l':
>              log_filepath = optarg;
> @@ -1040,7 +1040,8 @@ int main(int argc, char **argv)
>                  if (ga_install_vss_provider()) {
>                      exit(EXIT_FAILURE);
>                  }
> -                if (ga_install_service(path, log_filepath, fixed_state_dir)) {
> +                if (ga_install_service(device_path, log_filepath,
> +                                       fixed_state_dir)) {
>                      exit(EXIT_FAILURE);
>                  }
>                  exit(EXIT_SUCCESS);
> @@ -1185,7 +1186,7 @@ int main(int argc, char **argv)
>  #endif
> 
>      s->main_loop = g_main_loop_new(NULL, false);
> -    if (!channel_init(ga_state, method, path)) {
> +    if (!channel_init(ga_state, method, device_path)) {
>          g_critical("failed to initialize guest agent channel");
>          goto out_bad;
>      }
> -- 
> 2.4.3
>
Marc-André Lureau Aug. 25, 2015, 10 p.m. UTC | #2
hi

On Tue, Aug 25, 2015 at 5:55 PM, Michael Roth <mdroth@linux.vnet.ibm.com> wrote:
> Quoting Marc-André Lureau (2015-07-01 06:47:39)
>> 'path' is already a global function, rename the variable since it's
>> going to be in global scope in a later patch.
>>
>> Signed-off-by: Marc-André Lureau <marcandre.lureau@gmail.com>
>
> I think I'd prefer something like 'channel_path' since we support
> sockets as well. Looks good otherwise.


ok, done
diff mbox

Patch

diff --git a/qga/main.c b/qga/main.c
index 0c455f8..1c81575 100644
--- a/qga/main.c
+++ b/qga/main.c
@@ -944,7 +944,7 @@  static GList *split_list(gchar *str, const gchar separator)
 int main(int argc, char **argv)
 {
     const char *sopt = "hVvdm:p:l:f:F::b:s:t:";
-    const char *method = NULL, *path = NULL;
+    const char *method = NULL, *device_path = NULL;
     const char *log_filepath = NULL;
     const char *pid_filepath;
 #ifdef CONFIG_FSFREEZE
@@ -990,7 +990,7 @@  int main(int argc, char **argv)
             method = optarg;
             break;
         case 'p':
-            path = optarg;
+            device_path = optarg;
             break;
         case 'l':
             log_filepath = optarg;
@@ -1040,7 +1040,8 @@  int main(int argc, char **argv)
                 if (ga_install_vss_provider()) {
                     exit(EXIT_FAILURE);
                 }
-                if (ga_install_service(path, log_filepath, fixed_state_dir)) {
+                if (ga_install_service(device_path, log_filepath,
+                                       fixed_state_dir)) {
                     exit(EXIT_FAILURE);
                 }
                 exit(EXIT_SUCCESS);
@@ -1185,7 +1186,7 @@  int main(int argc, char **argv)
 #endif
 
     s->main_loop = g_main_loop_new(NULL, false);
-    if (!channel_init(ga_state, method, path)) {
+    if (!channel_init(ga_state, method, device_path)) {
         g_critical("failed to initialize guest agent channel");
         goto out_bad;
     }