Message ID | 1331845217-21705-10-git-send-email-mjt@msgid.tls.msk.ru |
---|---|
State | New |
Headers | show |
On 03/15/2012 04:00 PM, Michael Tokarev wrote: > Rename do_sendv_recvv() to iov_send_recv(), change its last arg > (do_send) from int to bool, export it in iov.h, and made the two > callers of it (iov_send() and iov_recv()) to be trivial #defines > just adding 5th arg. > > iov_send_recv() will be used later. > > Signed-off-by: Michael Tokarev<mjt@tls.msk.ru> > --- > cutils.c | 17 +++-------------- > iov.h | 10 +++++++--- > 2 files changed, 10 insertions(+), 17 deletions(-) > > diff --git a/cutils.c b/cutils.c > index 2ad5fa3..cb6f638 100644 > --- a/cutils.c > +++ b/cutils.c > @@ -376,9 +376,9 @@ int qemu_parse_fd(const char *param) > return fd; > } > > -static ssize_t do_sendv_recvv(int sockfd, struct iovec *iov, > - size_t offset, size_t bytes, > - int do_sendv) > +ssize_t iov_send_recv(int sockfd, struct iovec *iov, > + size_t offset, size_t bytes, > + bool do_sendv) > { > int iovlen; > ssize_t ret; > @@ -458,14 +458,3 @@ static ssize_t do_sendv_recvv(int sockfd, struct iovec *iov, > last_iov->iov_len += diff; > return ret; > } > - > -ssize_t iov_recv(int sockfd, struct iovec *iov, size_t offset, size_t bytes) > -{ > - return do_sendv_recvv(sockfd, iov, offset, bytes, 0); > -} > - > -ssize_t iov_send(int sockfd, struct iovec *iov, size_t offset, size_t bytes) > -{ > - return do_sendv_recvv(sockfd, iov, offset, bytes, 1); > -} > - > diff --git a/iov.h b/iov.h > index 5aa2f45..9b6a883 100644 > --- a/iov.h > +++ b/iov.h > @@ -60,7 +60,7 @@ size_t iov_memset(const struct iovec *iov, const unsigned int iov_cnt, > * `offset' bytes in the beginning of iovec buffer are skipped and > * next `bytes' bytes are used, which must be within data of iovec. > * > - * r = iov_send(sockfd, iov, offset, bytes); > + * r = iov_send_recv(sockfd, iov, offset, bytes, true); > * > * is logically equivalent to > * > @@ -69,8 +69,12 @@ size_t iov_memset(const struct iovec *iov, const unsigned int iov_cnt, > * r = send(sockfd, buf, bytes, 0); > * free(buf); > */ > -ssize_t iov_recv(int sockfd, struct iovec *iov, size_t offset, size_t bytes); > -ssize_t iov_send(int sockfd, struct iovec *iov, size_t offset, size_t bytes); > +ssize_t iov_send_recv(int sockfd, struct iovec *iov, > + size_t offset, size_t bytes, bool do_send); > +#define iov_recv(sockfd, iov, offset, bytes) \ > + iov_send_recv(sockfd, iov, offset, bytes, false) > +#define iov_send(sockfd, iov, offset, bytes) \ > + iov_send_recv(sockfd, iov, offset, bytes, true) Please use a static inline instead of a macro. Macros make compiler errors/warnings confusing. Regards, Anthony Liguori > > /** > * Produce a text hexdump of iovec `iov' with `iov_cnt' number of elements
On 16.03.2012 20:21, Anthony Liguori wrote: > On 03/15/2012 04:00 PM, Michael Tokarev wrote: [] >> +ssize_t iov_send_recv(int sockfd, struct iovec *iov, >> + size_t offset, size_t bytes, bool do_send); >> +#define iov_recv(sockfd, iov, offset, bytes) \ >> + iov_send_recv(sockfd, iov, offset, bytes, false) >> +#define iov_send(sockfd, iov, offset, bytes) \ >> + iov_send_recv(sockfd, iov, offset, bytes, true) > > Please use a static inline instead of a macro. Macros make compiler errors/warnings confusing. Macros are good when used properly, and this is one of examples of good usage: no confusion in this case. An example of really confusing macro which were accepted recently is qemu_recv, which not only makes errors/warning confusing, but also makes type checking impossible. I can change these into inline functions, but that just takes much more lines of "code" and more difficult to see what it does. Thanks, /mjt
diff --git a/cutils.c b/cutils.c index 2ad5fa3..cb6f638 100644 --- a/cutils.c +++ b/cutils.c @@ -376,9 +376,9 @@ int qemu_parse_fd(const char *param) return fd; } -static ssize_t do_sendv_recvv(int sockfd, struct iovec *iov, - size_t offset, size_t bytes, - int do_sendv) +ssize_t iov_send_recv(int sockfd, struct iovec *iov, + size_t offset, size_t bytes, + bool do_sendv) { int iovlen; ssize_t ret; @@ -458,14 +458,3 @@ static ssize_t do_sendv_recvv(int sockfd, struct iovec *iov, last_iov->iov_len += diff; return ret; } - -ssize_t iov_recv(int sockfd, struct iovec *iov, size_t offset, size_t bytes) -{ - return do_sendv_recvv(sockfd, iov, offset, bytes, 0); -} - -ssize_t iov_send(int sockfd, struct iovec *iov, size_t offset, size_t bytes) -{ - return do_sendv_recvv(sockfd, iov, offset, bytes, 1); -} - diff --git a/iov.h b/iov.h index 5aa2f45..9b6a883 100644 --- a/iov.h +++ b/iov.h @@ -60,7 +60,7 @@ size_t iov_memset(const struct iovec *iov, const unsigned int iov_cnt, * `offset' bytes in the beginning of iovec buffer are skipped and * next `bytes' bytes are used, which must be within data of iovec. * - * r = iov_send(sockfd, iov, offset, bytes); + * r = iov_send_recv(sockfd, iov, offset, bytes, true); * * is logically equivalent to * @@ -69,8 +69,12 @@ size_t iov_memset(const struct iovec *iov, const unsigned int iov_cnt, * r = send(sockfd, buf, bytes, 0); * free(buf); */ -ssize_t iov_recv(int sockfd, struct iovec *iov, size_t offset, size_t bytes); -ssize_t iov_send(int sockfd, struct iovec *iov, size_t offset, size_t bytes); +ssize_t iov_send_recv(int sockfd, struct iovec *iov, + size_t offset, size_t bytes, bool do_send); +#define iov_recv(sockfd, iov, offset, bytes) \ + iov_send_recv(sockfd, iov, offset, bytes, false) +#define iov_send(sockfd, iov, offset, bytes) \ + iov_send_recv(sockfd, iov, offset, bytes, true) /** * Produce a text hexdump of iovec `iov' with `iov_cnt' number of elements
Rename do_sendv_recvv() to iov_send_recv(), change its last arg (do_send) from int to bool, export it in iov.h, and made the two callers of it (iov_send() and iov_recv()) to be trivial #defines just adding 5th arg. iov_send_recv() will be used later. Signed-off-by: Michael Tokarev <mjt@tls.msk.ru> --- cutils.c | 17 +++-------------- iov.h | 10 +++++++--- 2 files changed, 10 insertions(+), 17 deletions(-)