@@ -635,22 +635,22 @@ static void nic_reset(void *opaque)
}
#if defined(DEBUG_EEPRO100)
-static const char * const reg[PCI_IO_SIZE / 4] = {
+static const char * const e100_reg[PCI_IO_SIZE / 4] = {
"Command/Status",
"General Pointer",
"Port",
"EEPROM/Flash Control",
"MDI Control",
"Receive DMA Byte Count",
- "Flow control",
+ "Flow Control",
"General Status/Control"
};
static char *regname(uint32_t addr)
{
- static char buf[16];
+ static char buf[32];
if (addr < PCI_IO_SIZE) {
- const char *r = reg[addr / 4];
+ const char *r = e100_reg[addr / 4];
if (r != 0) {
snprintf(buf, sizeof(buf), "%s+%u", r, addr % 4);
} else {
* buf was too small for longer register names. * Use consistent upper case for nouns in register names. * Use better name for array with e100 register names. Signed-off-by: Stefan Weil <weil@mail.berlios.de> --- hw/eepro100.c | 8 ++++---- 1 files changed, 4 insertions(+), 4 deletions(-)