mbox series

[v2,0/2] hw/mips/jazz: Rework the NIC init code

Message ID 20230913160922.355640-1-thuth@redhat.com
Headers show
Series hw/mips/jazz: Rework the NIC init code | expand

Message

Thomas Huth Sept. 13, 2023, 4:09 p.m. UTC
The NIC init code of the jazz machines is rather cumbersome, with
a for-loop around it that is always left after the first iteration.
This patch series reworks this a little bit to make the code more
readable and shorter.

v2:
- Dropped the first patch from v1 since it has been solved
  differently by the patch "trivial: Simplify the spots that
  use TARGET_BIG_ENDIAN as a numeric value" recently
- Rebased the code on top of that RARGET_BIG_ENDIAN change

Thomas Huth (2):
  hw/mips/jazz: Move the NIC init code into a separate function
  hw/mips/jazz: Simplify the NIC setup code

 hw/mips/jazz.c | 81 ++++++++++++++++++++++++--------------------------
 1 file changed, 39 insertions(+), 42 deletions(-)

Comments

Philippe Mathieu-Daudé Sept. 14, 2023, 5:51 a.m. UTC | #1
On 13/9/23 18:09, Thomas Huth wrote:

> Thomas Huth (2):
>    hw/mips/jazz: Move the NIC init code into a separate function
>    hw/mips/jazz: Simplify the NIC setup code

Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>