mbox series

[0/2] target/ppc: Drop PowerPCCPUClass::interrupts_big_endian()

Message ID 20210622140926.677618-1-groug@kaod.org
Headers show
Series target/ppc: Drop PowerPCCPUClass::interrupts_big_endian() | expand

Message

Greg Kurz June 22, 2021, 2:09 p.m. UTC
Class method is overkill and cause code duplication in CPU setup functions.
Switch to a more lightweight solution with a unique inline helper.

Greg Kurz (2):
  target/ppc: Introduce ppc_interrupts_little_endian()
  target/ppc: Drop PowerPCCPUClass::interrupts_big_endian()

 target/ppc/cpu-qom.h     |  1 -
 target/ppc/cpu.h         | 15 +++++++++++++++
 target/ppc/arch_dump.c   |  8 +++-----
 target/ppc/cpu_init.c    | 17 -----------------
 target/ppc/excp_helper.c |  3 +--
 5 files changed, 19 insertions(+), 25 deletions(-)

Comments

David Gibson June 24, 2021, 1:25 a.m. UTC | #1
On Tue, Jun 22, 2021 at 04:09:24PM +0200, Greg Kurz wrote:
> Class method is overkill and cause code duplication in CPU setup functions.
> Switch to a more lightweight solution with a unique inline helper.

LGTM, applied to ppc-for-6.1, thanks.

> 
> Greg Kurz (2):
>   target/ppc: Introduce ppc_interrupts_little_endian()
>   target/ppc: Drop PowerPCCPUClass::interrupts_big_endian()
> 
>  target/ppc/cpu-qom.h     |  1 -
>  target/ppc/cpu.h         | 15 +++++++++++++++
>  target/ppc/arch_dump.c   |  8 +++-----
>  target/ppc/cpu_init.c    | 17 -----------------
>  target/ppc/excp_helper.c |  3 +--
>  5 files changed, 19 insertions(+), 25 deletions(-)
>