diff mbox series

[2/2] mpc85xx: add HP 560 AP support.

Message ID mailman.8791.1733052087.1089.openwrt-devel@lists.openwrt.org
State New
Headers show
Series [1/2] mpc85xx: refactor msm460 dts | expand

Commit Message

Evan Jobling Dec. 1, 2024, 11:21 a.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
The HP 560 Access Point features the
same baseboard as the MSM430, MSM460, MSM466.

Hardware
--------
CPU:  Freescale P1020 2xe500 PPC
RAM:  256M DDR3 (Micron MT41J64M16JT-15E:G "D9MNJ")
NAND: 128M (Micron 2CA1)
BTN:  1x Reset
LED:  Power - ETH - Radio1 - Radio2
UART: RJ-45 Cisco Pinout - 115200 8N1
PCIe1: ath10k 3x3:3 card
PCIe2: ath9k 3x3:3 card
PoE: 802.3at

Installation instructions are identical for msm460
and you can use the msm460 bootloader discussed in:
af329ec
"mpc85xx: add support for Hewlett Packard MSM460"

Known issues:
Tested on J9846A WW model.
Untested on J9845A, J9847A, J9848A.

Factory behaviour is 2.4ghz radio should
go to 2x2:2 to maintain 802.3af compliance.
This is untested.

Signed-off-by: Evan Jobling <evan.jobling@mslsc.com.au>
---
 .../files/arch/powerpc/boot/dts/hpe_560.dts   |  7 +++++++
 target/linux/mpc85xx/image/p1020.mk           | 20 +++++++++++++++++++
 2 files changed, 27 insertions(+)
 create mode 100644 target/linux/mpc85xx/files/arch/powerpc/boot/dts/hpe_560.dts
diff mbox series

Patch

diff --git a/target/linux/mpc85xx/files/arch/powerpc/boot/dts/hpe_560.dts b/target/linux/mpc85xx/files/arch/powerpc/boot/dts/hpe_560.dts
new file mode 100644
index 0000000000..500dfc9bf0
--- /dev/null
+++ b/target/linux/mpc85xx/files/arch/powerpc/boot/dts/hpe_560.dts
@@ -0,0 +1,7 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later or MIT
+
+#include "hp-5185-8967.dtsi"
+/ {
+	model = "Hewlett-Packard 560";
+	compatible = "hpe,560","hpe,msm460";
+};
diff --git a/target/linux/mpc85xx/image/p1020.mk b/target/linux/mpc85xx/image/p1020.mk
index c310b26c87..0c4c8f9fb6 100644
--- a/target/linux/mpc85xx/image/p1020.mk
+++ b/target/linux/mpc85xx/image/p1020.mk
@@ -109,6 +109,26 @@  define Device/hpe_msm460
 endef
 TARGET_DEVICES += hpe_msm460
 
+define Device/hpe_560
+  DEVICE_VENDOR := Hewlett-Packard
+  DEVICE_MODEL := 560
+  DEVICE_DTS := hpe_560
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-board-qca9888 ath10k-firmware-qca988x-ct
+  KERNEL = kernel-bin | fit none $(KDIR)/image-$$(DEVICE_DTS).dtb
+  KERNEL_NAME := zImage.la3000000
+  KERNEL_ENTRY := 0x3000000
+  KERNEL_LOADADDR := 0x3000000
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  SUBPAGESIZE := 2048
+  KERNEL_IN_UBI := 1
+  UBINIZE_OPTS := -E 5
+  IMAGES := factory.bin sysupgrade.bin
+  IMAGE/factory.bin := append-ubi
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += hpe_560
+
 define Device/ocedo_panda
   DEVICE_VENDOR := OCEDO
   DEVICE_MODEL := Panda