diff mbox series

kirkwood: Make the Marvell DSA switch a module

Message ID 20241117-kirkwood-mv88e6xxx-module-v1-1-f5d688e6dba8@linaro.org
State Accepted, archived
Delegated to: Linus Walleij
Headers show
Series kirkwood: Make the Marvell DSA switch a module | expand

Commit Message

Linus Walleij Nov. 17, 2024, 10:12 p.m. UTC
Not all Kirkwood systems have the Marvell MV88E6XXX switches.
Drop those from the generic config and add them as modules
in the systems that have it.

This was inferred by inspecting the upstream DTS files for any
mv88e* strings and adding the mv88e6xxx kmod package to those
that have an upstream device tree with an MV88E6xxx switch
and an OpenWrt image target.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 target/linux/kirkwood/config-6.6     | 4 ----
 target/linux/kirkwood/image/Makefile | 8 +++++---
 2 files changed, 5 insertions(+), 7 deletions(-)


---
base-commit: efc0c4666b5aa0cf0067d794964f12d9a45190c6
change-id: 20241117-kirkwood-mv88e6xxx-module-3769b825e3f3

Best regards,
diff mbox series

Patch

diff --git a/target/linux/kirkwood/config-6.6 b/target/linux/kirkwood/config-6.6
index 751d3e6a1b4608c2a38a7d1c7f96fb0adfab16b1..e3341523802f043cc56024c06580423299f8a112 100644
--- a/target/linux/kirkwood/config-6.6
+++ b/target/linux/kirkwood/config-6.6
@@ -192,10 +192,6 @@  CONFIG_NEED_KUSER_HELPERS=y
 CONFIG_NEED_PER_CPU_KM=y
 CONFIG_NET_DEVLINK=y
 CONFIG_NET_DSA=y
-CONFIG_NET_DSA_MV88E6XXX=y
-CONFIG_NET_DSA_TAG_DSA=y
-CONFIG_NET_DSA_TAG_DSA_COMMON=y
-CONFIG_NET_DSA_TAG_EDSA=y
 CONFIG_NET_EGRESS=y
 CONFIG_NET_INGRESS=y
 CONFIG_NET_SELFTESTS=y
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index eaced9265776307e507a7f991ca8ef4cb123e42d..cd9390b62a58d0ae1fbec1a0ce7148b235bad350 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -132,7 +132,8 @@  define Device/checkpoint_l-50
   DEVICE_VENDOR := Check Point
   DEVICE_MODEL := L-50
   DEVICE_PACKAGES := kmod-ath9k kmod-gpio-button-hotplug kmod-mvsdio \
-	kmod-rtc-s35390a kmod-usb-ledtrig-usbport wpad-basic-mbedtls
+	kmod-rtc-s35390a kmod-usb-ledtrig-usbport wpad-basic-mbedtls \
+	kmod-dsa-mv88e6xxx
   IMAGES := sysupgrade.bin
 endef
 TARGET_DEVICES += checkpoint_l-50
@@ -193,7 +194,8 @@  define Device/endian_4i-edge-200
   DEVICE_MODEL := 4i Edge 200
   DEVICE_ALT0_VENDOR := Endian
   DEVICE_ALT0_MODEL := UTM Mini Firewall
-  DEVICE_PACKAGES := kmod-ath9k kmod-mvsdio wpad-basic-mbedtls kmod-rtc-mv
+  DEVICE_PACKAGES := kmod-ath9k kmod-mvsdio wpad-basic-mbedtls kmod-rtc-mv \
+	kmod-dsa-mv88e6xxx
   KERNEL_SIZE := 4096k
   IMAGES := sysupgrade.bin
 endef
@@ -273,7 +275,7 @@  define Device/linksys
   $(Device/kernel-size-migration-linksys)
   DEVICE_VENDOR := Linksys
   DEVICE_PACKAGES := kmod-mwl8k wpad-basic-mbedtls kmod-gpio-button-hotplug \
-	kmod-rtc-mv
+	kmod-rtc-mv kmod-dsa-mv88e6xxx
   KERNEL_IN_UBI :=
   KERNEL_SIZE := 4096k
   UBINIZE_OPTS := -E 5