Message ID | 20170223225357.9572-9-benh@kernel.crashing.org (mailing list archive) |
---|---|
State | Not Applicable |
Headers | show |
On Fri, Feb 24, 2017 at 9:23 AM, Benjamin Herrenschmidt <benh@kernel.crashing.org> wrote: > The function does more than initializing the DRAM and in turns > calls other functions to do the actual init. This will keeping > things more consistent with the upcoming AST2500 POST code. > > Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org> Acked-by: Joel Stanley <joel@jms.id.au> > --- > drivers/gpu/drm/ast/ast_post.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-)
Tested-by: Y.C. Chen <yc_chen@aspeedtech.com> -----Original Message----- From: Benjamin Herrenschmidt [mailto:benh@kernel.crashing.org] Sent: Friday, February 24, 2017 6:54 AM To: dri-devel@lists.freedesktop.org Cc: YC Chen <yc_chen@aspeedtech.com>; airlied@redhat.com; eich@suse.come; linuxppc-dev@ozlabs.org Subject: [PATCH 09/12] drm/ast: Rename ast_init_dram_2300 to ast_post_chip_2300 The function does more than initializing the DRAM and in turns calls other functions to do the actual init. This will keeping things more consistent with the upcoming AST2500 POST code. Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
diff --git a/drivers/gpu/drm/ast/ast_post.c b/drivers/gpu/drm/ast/ast_post.c index c55067c..561fd7d 100644 --- a/drivers/gpu/drm/ast/ast_post.c +++ b/drivers/gpu/drm/ast/ast_post.c @@ -31,7 +31,7 @@ #include "ast_dram_tables.h" -static void ast_init_dram_2300(struct drm_device *dev); +static void ast_post_chip_2300(struct drm_device *dev); void ast_enable_vga(struct drm_device *dev) { @@ -381,7 +381,7 @@ void ast_post_gpu(struct drm_device *dev) if (ast->config_mode == ast_use_p2a) { if (ast->chip == AST2300 || ast->chip == AST2400) - ast_init_dram_2300(dev); + ast_post_chip_2300(dev); else ast_init_dram_reg(dev); @@ -1589,7 +1589,7 @@ static void ddr2_init(struct ast_private *ast, struct ast2300_dram_param *param) } -static void ast_init_dram_2300(struct drm_device *dev) +static void ast_post_chip_2300(struct drm_device *dev) { struct ast_private *ast = dev->dev_private; struct ast2300_dram_param param;
The function does more than initializing the DRAM and in turns calls other functions to do the actual init. This will keeping things more consistent with the upcoming AST2500 POST code. Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org> --- drivers/gpu/drm/ast/ast_post.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)