diff mbox series

[1/1] package/polkit: fix permissions after version bump to 125

Message ID FB194E54-666A-488A-8C79-6A3CB933D55B@martb.dev
State Accepted
Headers show
Series [1/1] package/polkit: fix permissions after version bump to 125 | expand

Commit Message

Martin Böh Dec. 13, 2024, 5:39 a.m. UTC
From: Martin Böh <contact@martb.dev>

The service failed to start correctly if any custom rules were installed.
This commit aligns the permissions with the upstream meson build step.

Signed-off-by: Martin Böh <contact@martb.dev>
---
 package/polkit/polkit.mk | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Julien Olivain Dec. 14, 2024, 10:08 p.m. UTC | #1
Hi Martin,

On 13/12/2024 06:39, Martin Böh via buildroot wrote:
> From: Martin Böh <contact@martb.dev>
> 
> The service failed to start correctly if any custom rules were
> installed.
> This commit aligns the permissions with the upstream meson build step.
> 
> Signed-off-by: Martin Böh <contact@martb.dev>
> -------------------------
>  package/polkit/polkit.mk | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/package/polkit/polkit.mk b/package/polkit/polkit.mk
> index fb49f6ce2a..6cd2aa6042 100644
> --- a/package/polkit/polkit.mk
> +++ b/package/polkit/polkit.mk
> @@ -56,10 +56,10 @@ define POLKIT_USERS
> endef
> 
> define POLKIT_PERMISSIONS
> - /etc/polkit-1/rules.d d 700 polkitd root - - - - -
> - /usr/share/polkit-1/rules.d d 700 polkitd root - - - - -
> - /usr/bin/pkexec f 4755 root root - - - - -
> - /usr/lib/polkit-1/polkit-agent-helper-1 f 4755 root root - - - - -
> + /etc/polkit-1/rules.d d 750 root polkitd - - - - -
> + /usr/share/polkit-1/rules.d d 750 root polkitd - - - - -

I understand those two directories needs those updates, due to upstream
changes such as:
https://github.com/polkit-org/polkit/commit/b6169f3113b3ce5ed822e66adcc962850c24660a

> + /usr/bin/pkexec f 04755 root root - - - - -
> + /usr/lib/polkit-1/polkit-agent-helper-1 f 04755 root root - - - - -

Why did you updated /usr/bin/pkexec and 
/usr/lib/polkit-1/polkit-agent-helper-1
to replace 4755 by 04755? (there is no justification in the commit log).

> endef
> 
> define POLKIT_INSTALL_INIT_SYSTEMD
> --
> 2.47.1
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot

Best regards,

Julien.
Peter Korsgaard Dec. 28, 2024, 5:42 p.m. UTC | #2
On 12/13/24 06:39, Martin Böh via buildroot wrote:
> From: Martin Böh <contact@martb.dev>
> 
> The service failed to start correctly if any custom rules were installed.
> This commit aligns the permissions with the upstream meson build step.
> 
> Signed-off-by: Martin Böh <contact@martb.dev>

Committed to 2024.11.x, thanks.
diff mbox series

Patch

diff --git a/package/polkit/polkit.mk b/package/polkit/polkit.mk
index fb49f6ce2a..6cd2aa6042 100644
--- a/package/polkit/polkit.mk
+++ b/package/polkit/polkit.mk
@@ -56,10 +56,10 @@  define POLKIT_USERS
 endef
 
 define POLKIT_PERMISSIONS
-	/etc/polkit-1/rules.d d 700 polkitd root - - - - -
-	/usr/share/polkit-1/rules.d d 700 polkitd root - - - - -
-	/usr/bin/pkexec f 4755 root root - - - - -
-	/usr/lib/polkit-1/polkit-agent-helper-1 f 4755 root root - - - - -
+	/etc/polkit-1/rules.d d 750 root polkitd - - - - -
+	/usr/share/polkit-1/rules.d d 750 root polkitd - - - - -
+	/usr/bin/pkexec f 04755 root root - - - - -
+	/usr/lib/polkit-1/polkit-agent-helper-1 f 04755 root root - - - - -
 endef
 
 define POLKIT_INSTALL_INIT_SYSTEMD