@@ -5,6 +5,7 @@ config BR2_PACKAGE_FIO
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C11/stdatomic.h
depends on BR2_TOOLCHAIN_HAS_SYNC_4
depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_5 # nvme_ioctl.h
# fio uses fallocate() which becomes fallocate64() while compiling with
# largefile support, but fallocate64() is not available on nios2
depends on !BR2_nios2
@@ -12,11 +13,12 @@ config BR2_PACKAGE_FIO
fio is an I/O tool meant to be used both for benchmark
and stress/hardware verification.
- http://git.kernel.dk/?p=fio.git;a=summary
+ https://git.kernel.dk/cgit/fio/
-comment "fio needs a toolchain w/ dynamic library, threads, gcc >= 4.9"
+comment "fio needs a toolchain w/ dynamic library, threads, gcc >= 4.9, headers >= 4.5"
depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS || \
- !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
+ !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
+ !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_5
depends on BR2_TOOLCHAIN_HAS_SYNC_4
depends on !BR2_nios2
depends on BR2_USE_MMU
@@ -1,4 +1,8 @@
-# Locally computed
-sha256 49f340ef51dbb7942d598abd2b8ad93ce7934ca709f73ba13519568556f9089f fio-3.34.tar.gz
+# From https://brick.kernel.dk/snaps/MD5SUMS
+md5 2223cf30dc799a838d92193aa5aa41d2 fio-3.38.tar.gz
+# Locally computed after checking gpg signature from
+# https://brick.kernel.dk/snaps/fio-3.38.tar.gz.asc
+# with key C0FC392DCADE26D975FA5E4AF7D358FB2971E0A6
+sha256 a5b63518558004292c7ec60fef90163f59957d7e1dce6f4cb87e9dc75d4dfc48 fio-3.38.tar.gz
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 8a240c1ad13d1fe3e58588643d81d0695899be4a669fe6d8fafa76ca6a89db2c MORAL-LICENSE
@@ -4,8 +4,8 @@
#
################################################################################
-FIO_VERSION = 3.34
-FIO_SITE = http://brick.kernel.dk/snaps
+FIO_VERSION = 3.38
+FIO_SITE = https://brick.kernel.dk/snaps
FIO_LICENSE = GPL-2.0
FIO_LICENSE_FILES = COPYING MORAL-LICENSE
For change log since 3.34, see: https://git.kernel.dk/cgit/fio/log/?h=fio-3.38 While at it, this commit also updates the homepage url in Config.in (which now points to cgit on https) and the _SITE url (which now uses https) to match urls published in [1]. This commit also adds the md5 hash published upstream and a comment about the pgp signature check. Also, fio includes the <linux/nvme_ioctl.h> kernel header. See [2] and [3]. This Kernel header was added in commit [4] and [5], in Kernel v4.5. This commits adds this new kernel header version requirement. [1] https://git.kernel.dk/cgit/fio/tree/README.rst?h=fio-3.38 [2] https://git.kernel.dk/cgit/fio/tree/engines/io_uring.c?h=fio-3.38#n34 [3] https://git.kernel.dk/cgit/fio/tree/engines/nvme.h?h=fio-3.38#n12 [4] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=9d99a8dda154f38307d43d9c9aa504bd3703d596 [5] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=a9cf8284b45110a4d98aea180a89c857e53bf850 Signed-off-by: Julien Olivain <ju.o@free.fr> --- Patch tested in: https://gitlab.com/jolivain/buildroot/-/pipelines/1620835990 --- package/fio/Config.in | 8 +++++--- package/fio/fio.hash | 8 ++++++-- package/fio/fio.mk | 4 ++-- 3 files changed, 13 insertions(+), 7 deletions(-)