@@ -1,3 +1,6 @@
+config BR2_PACKAGE_HOST_QT6BASE_CONCURRENT
+ bool
+
# Select this if you need host qt6 tools that require the Qt::Gui module (e.g.
# Qt Shader Baker(qsb)).
config BR2_PACKAGE_HOST_QT6BASE_GUI
@@ -83,8 +83,8 @@ HOST_QT6BASE_DEPENDENCIES = \
host-libb2 \
host-pcre2 \
host-zlib
+
HOST_QT6BASE_CONF_OPTS = \
- -DFEATURE_concurrent=OFF \
-DFEATURE_xml=ON \
-DFEATURE_dbus=OFF \
-DFEATURE_icu=OFF \
@@ -94,6 +94,12 @@ HOST_QT6BASE_CONF_OPTS = \
-DFEATURE_system_pcre2=ON \
-DFEATURE_system_zlib=ON
+ifeq ($(BR2_PACKAGE_HOST_QT6BASE_CONCURRENT),y)
+HOST_QT6BASE_CONF_OPTS += -DFEATURE_concurrent=ON
+else
+HOST_QT6BASE_CONF_OPTS += -DFEATURE_concurrent=OFF
+endif
+
# We need host-qt6base with Gui support when building host-qt6shadertools,
# otherwise the build is skipped and no qsb host tool is generated.
# qt6shadertools fail to build if qsb is not available.
Needed by new package qt6quick3d. Signed-off-by: Roy Kollen Svendsen <roykollensvendsen@gmail.com> --- package/qt6/qt6base/Config.in.host | 3 +++ package/qt6/qt6base/qt6base.mk | 8 +++++++- 2 files changed, 10 insertions(+), 1 deletion(-)