diff mbox series

boot/ti-k3-r5-loader: add host-gnutls to dependencies

Message ID 20241210-uboot-bump-v1-1-baeb59feef61@ti.com
State Superseded
Headers show
Series boot/ti-k3-r5-loader: add host-gnutls to dependencies | expand

Commit Message

Bryan Brattlof Dec. 10, 2024, 11:32 p.m. UTC
Newer versions of U-Boot may require the GnuTLS library to be installed
on the host machine during the EFI capsule creation phase of the U-Boot
build. Add host-gnutls to the list of dependencies.

Signed-off-by: Bryan Brattlof <bb@ti.com>
---
 boot/ti-k3-r5-loader/ti-k3-r5-loader.mk | 1 +
 1 file changed, 1 insertion(+)


---
base-commit: cf3dd3e365d5287cecf08a1b35394236be297148
change-id: 20241210-uboot-bump-2fa3ef07669f

Best regards,

Comments

Romain Naour Dec. 11, 2024, 9:57 a.m. UTC | #1
Hello Bryan, All,

Le 11/12/2024 à 00:32, Bryan Brattlof via buildroot a écrit :
> Newer versions of U-Boot may require the GnuTLS library to be installed
> on the host machine during the EFI capsule creation phase of the U-Boot
> build. Add host-gnutls to the list of dependencies.

Your reply [1] about mkeficapsule tool used to build tiboot3.bin images was
probably a good info to keep in the commit log.

Indeed, since u-boot 2024.10 the mkeficapsule is now mandatory otherwise binman
fail (tested with the beagleboardai64 defcondif with u-boot 2024.10):

  BINMAN  .binman_stamp
  Image 'capsule-tiboot3' has missing bintools and is non-functional: mkeficapsule

  Image 'capsule-sysfw' has missing bintools and is non-functional: mkeficapsule

  Some images are invalid

I'm not sure we want to keep the ability to disable host-gnutls dependency for
ti-k3-r5-loader since only version up to 2024.10 doesn't need mkeficapsule tool
for TI K3 SoCs.

[1]
https://lore.kernel.org/buildroot/20241024223843.d2hvpqx6zkazukfi@bryanbrattlof.com/

Best regards,
Romain


> 
> Signed-off-by: Bryan Brattlof <bb@ti.com>
> ---
>  boot/ti-k3-r5-loader/ti-k3-r5-loader.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> index e426f039e021d..db5c3cdaf8b65 100644
> --- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> +++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> @@ -46,6 +46,7 @@ TI_K3_R5_LOADER_DEPENDENCIES = \
>  	host-pkgconf \
>  	$(BR2_MAKE_HOST_DEPENDENCY) \
>  	host-arm-gnu-toolchain \
> +	host-gnutls \
>  	host-openssl \
>  	host-python3 \
>  	host-python-jsonschema \
> 
> ---
> base-commit: cf3dd3e365d5287cecf08a1b35394236be297148
> change-id: 20241210-uboot-bump-2fa3ef07669f
> 
> Best regards,
Bryan Brattlof Dec. 13, 2024, 4:07 p.m. UTC | #2
Hi Romain!

On December 11, 2024 thus sayeth Romain Naour via buildroot:
> Hello Bryan, All,
> 
> Le 11/12/2024 à 00:32, Bryan Brattlof via buildroot a écrit :
> > Newer versions of U-Boot may require the GnuTLS library to be installed
> > on the host machine during the EFI capsule creation phase of the U-Boot
> > build. Add host-gnutls to the list of dependencies.
> 
> Your reply [1] about mkeficapsule tool used to build tiboot3.bin images was
> probably a good info to keep in the commit log.
> 

Ah yeah I'll elaborate on that a bit for v2

>
> Indeed, since u-boot 2024.10 the mkeficapsule is now mandatory otherwise binman
> fail (tested with the beagleboardai64 defcondif with u-boot 2024.10):
> 
>   BINMAN  .binman_stamp
>   Image 'capsule-tiboot3' has missing bintools and is non-functional: mkeficapsule
> 
>   Image 'capsule-sysfw' has missing bintools and is non-functional: mkeficapsule
> 
>   Some images are invalid
> 
> I'm not sure we want to keep the ability to disable host-gnutls dependency for
> ti-k3-r5-loader since only version up to 2024.10 doesn't need mkeficapsule tool
> for TI K3 SoCs.
> 

That works with me. gnutls is so small it's really not worth the 
complexity if people explicitly remove EFI capsules on TI chips from 
U-Boot. 

Thanks for the review!

~Bryan
diff mbox series

Patch

diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
index e426f039e021d..db5c3cdaf8b65 100644
--- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
+++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
@@ -46,6 +46,7 @@  TI_K3_R5_LOADER_DEPENDENCIES = \
 	host-pkgconf \
 	$(BR2_MAKE_HOST_DEPENDENCY) \
 	host-arm-gnu-toolchain \
+	host-gnutls \
 	host-openssl \
 	host-python3 \
 	host-python-jsonschema \