@@ -9,9 +9,11 @@ Linking with libatomic is needed on sparc otherwise build fails on:
Fixes:
- http://autobuild.buildroot.org/results/7a9fdb7e323892fb6ed85a2441054303e889c089
+Upstream: not sent (the same kind of patch for ncmpc was
+refused: https://github.com/MusicPlayerDaemon/ncmpc/pull/45)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: not sent (the same kind of patch for ncmpc was
-refused: https://github.com/MusicPlayerDaemon/ncmpc/pull/45)]
+[Andreas: adapt upstream formatting]
+Signed-off-by: Andreas Ziegler <br015@umbiko.net>
---
src/event/meson.build | 4 ++++
1 file changed, 4 insertions(+)
deleted file mode 100644
@@ -1,93 +0,0 @@
-From 1402869715e3efca87942d79c3173a6b21a6925d Mon Sep 17 00:00:00 2001
-From: Rudi Heitbaum <rudi@heitbaum.com>
-Date: Fri, 5 Jul 2024 14:27:45 +0000
-Subject: [PATCH] lib/fmt: support build with libfmt-11.0.0
-
-Upstream libfmt commit fmtlib/fmt@d707292
-now requires the format function to be const.
-
-Adjust the function prototype so it is const and can compile.
-
-Signed-off-by: Rudi Heitbaum <rudi@heitbaum.com>
-
-Context: https://github.com/MusicPlayerDaemon/MPD/issues/2071
-Pull request: https://github.com/MusicPlayerDaemon/MPD/pull/2069
-
-Fixes: http://autobuild.buildroot.net/results/73514ea76a5960f59b4c50e2074571b10e4682d4
-Fixes: http://autobuild.buildroot.net/results/a58ddbdfe35bd19021e65db0b8b8cc4c1c884d51
-
-Rebase for mpd-0.23.15
-
-Upstream: https://github.com/MusicPlayerDaemon/MPD/commit/3648475f871c33daa9e598c102a16e5a1a4d4dfc
-Signed-off-by: Andreas Ziegler <br015@umbiko.net>
----
- src/lib/ffmpeg/LibFmt.hxx | 2 +-
- src/lib/fmt/AudioFormatFormatter.hxx | 4 ++--
- src/lib/fmt/ExceptionFormatter.hxx | 2 +-
- src/lib/fmt/PathFormatter.hxx | 2 +-
- 4 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/lib/ffmpeg/LibFmt.hxx b/src/lib/ffmpeg/LibFmt.hxx
-index aa068711f..dee83ed2d 100644
---- a/src/lib/ffmpeg/LibFmt.hxx
-+++ b/src/lib/ffmpeg/LibFmt.hxx
-@@ -29,7 +29,7 @@
- struct fmt::formatter<AVSampleFormat> : formatter<string_view>
- {
- template<typename FormatContext>
-- auto format(const AVSampleFormat format, FormatContext &ctx) {
-+ auto format(const AVSampleFormat format, FormatContext &ctx) const {
- const char *name = av_get_sample_fmt_name(format);
- if (name == nullptr)
- name = "?";
-diff --git a/src/lib/fmt/AudioFormatFormatter.hxx b/src/lib/fmt/AudioFormatFormatter.hxx
-index e0ffb6216..8da98efd4 100644
---- a/src/lib/fmt/AudioFormatFormatter.hxx
-+++ b/src/lib/fmt/AudioFormatFormatter.hxx
-@@ -39,7 +39,7 @@
- struct fmt::formatter<SampleFormat> : formatter<string_view>
- {
- template<typename FormatContext>
-- auto format(const SampleFormat format, FormatContext &ctx) {
-+ auto format(const SampleFormat format, FormatContext &ctx) const {
- return formatter<string_view>::format(sample_format_to_string(format),
- ctx);
- }
-@@ -49,7 +49,7 @@
- struct fmt::formatter<AudioFormat> : formatter<string_view>
- {
- template<typename FormatContext>
-- auto format(const AudioFormat &af, FormatContext &ctx) {
-+ auto format(const AudioFormat &af, FormatContext &ctx) const {
- return formatter<string_view>::format(ToString(af).c_str(),
- ctx);
- }
-diff --git a/src/lib/fmt/ExceptionFormatter.hxx b/src/lib/fmt/ExceptionFormatter.hxx
-index 3f342df67..f08b3bb22 100644
---- a/src/lib/fmt/ExceptionFormatter.hxx
-+++ b/src/lib/fmt/ExceptionFormatter.hxx
-@@ -38,7 +38,7 @@
- struct fmt::formatter<std::exception_ptr> : formatter<string_view>
- {
- template<typename FormatContext>
-- auto format(std::exception_ptr e, FormatContext &ctx) {
-+ auto format(std::exception_ptr e, FormatContext &ctx) const {
- return formatter<string_view>::format(GetFullMessage(e), ctx);
- }
- };
-diff --git a/src/lib/fmt/PathFormatter.hxx b/src/lib/fmt/PathFormatter.hxx
-index e5ae89dec..add06df81 100644
---- a/src/lib/fmt/PathFormatter.hxx
-+++ b/src/lib/fmt/PathFormatter.hxx
-@@ -29,7 +29,7 @@
- struct fmt::formatter<Path> : formatter<string_view>
- {
- template<typename FormatContext>
-- auto format(Path path, FormatContext &ctx) {
-+ auto format(Path path, FormatContext &ctx) const {
- return formatter<string_view>::format(path.ToUTF8(), ctx);
- }
- };
-2.43.0
-
@@ -1,3 +1,3 @@
# Locally calculated after checking pgp signature
-sha256 550132239ad1acf82ccf8905b56cc13dc2c81a4489b96fba7731b3049907661a mpd-0.23.15.tar.xz
+sha256 9668e36df80de485683c962d02845bf314d8a08e6141af7afeff76401e32b2c1 mpd-0.23.16.tar.xz
sha256 ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6 COPYING
@@ -5,7 +5,7 @@
################################################################################
MPD_VERSION_MAJOR = 0.23
-MPD_VERSION = $(MPD_VERSION_MAJOR).15
+MPD_VERSION = $(MPD_VERSION_MAJOR).16
MPD_SOURCE = mpd-$(MPD_VERSION).tar.xz
MPD_SITE = https://www.musicpd.org/download/mpd/$(MPD_VERSION_MAJOR)
MPD_DEPENDENCIES = host-pkgconf boost fmt
Version 0.23.16 change log: * database - fix integer overflows with 64-bit inode numbers * filter - ffmpeg: fix for filters producing no output * support libfmt 11 * support ICU 76 Adapt 0001-src-event-meson.build-add-atomic-dependency-for-spar.patch to silence check-package warnings Remove 0002-lib-fmt-support-build-with-libfmt-11.0.0.patch, changes were applied upstream $ utils/check-package package/mpd/* 916 lines processed 0 warnings generated $ echo "BR2_PACKAGE_MPD=y" > ~/output/mpd.config $ utils/test-pkg -c ~/output/mpd.config -d ~/output -p mpd bootlin-armv5-uclibc [1/6]: OK bootlin-armv7-glibc [2/6]: OK bootlin-armv7m-uclibc [3/6]: SKIPPED bootlin-x86-64-musl [4/6]: OK br-arm-full-static [5/6]: OK arm-aarch64 [6/6]: OK 6 builds, 1 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed Signed-off-by: Andreas Ziegler <br015@umbiko.net> --- ...build-add-atomic-dependency-for-spar.patch | 6 +- ...fmt-support-build-with-libfmt-11.0.0.patch | 93 ------------------- package/mpd/mpd.hash | 2 +- package/mpd/mpd.mk | 2 +- 4 files changed, 6 insertions(+), 97 deletions(-) delete mode 100644 package/mpd/0002-lib-fmt-support-build-with-libfmt-11.0.0.patch