@@ -12,7 +12,7 @@ ELFUTILS_LICENSE = GPL-2.0+ or LGPL-3.0+ (library)
ELFUTILS_LICENSE_FILES = COPYING COPYING-GPLV2 COPYING-LGPLV3
ELFUTILS_CPE_ID_VALID = YES
ELFUTILS_DEPENDENCIES = host-pkgconf zlib $(TARGET_NLS_DEPENDENCIES)
-HOST_ELFUTILS_DEPENDENCIES = host-pkgconf host-zlib host-bzip2 host-xz
+HOST_ELFUTILS_DEPENDENCIES = host-pkgconf host-zlib host-bzip2 host-xz host-zstd
# We patch configure.ac
ELFUTILS_AUTORECONF = YES
@@ -26,7 +26,7 @@ ELFUTILS_CONF_OPTS += \
HOST_ELFUTILS_CONF_OPTS = \
--with-bzlib \
--with-lzma \
- --without-zstd \
+ --with-zstd \
--disable-demangler \
--disable-progs
Buildroot fails to build Linux kernel configurations where BTF support is enabled together with zstd compression of debugging information. The reason is in host-elfutils zstd support being explicitly disabled. So enable zstd support in host-elfutils by default to fix such builds. Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com> --- v1 -> v2: rebase and update commit message I already tried to send this patch back in August. But it looks like it might have slipped through cracks. So I rebased and re-tested for v2. package/elfutils/elfutils.mk | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)