diff mbox series

[v2,2/2] package/gnutls: fix configure options

Message ID 20241107134342.4306-2-tianyuanhao3@163.com
State Accepted
Headers show
Series [v2,1/2] package/gnutls: bump to version 3.8.8 | expand

Commit Message

TIAN Yuanhao Nov. 7, 2024, 1:43 p.m. UTC
Two configure option names have been changed since version 3.7.5 [1]:

> Old: --without-libbrotli --without-libzstd (also --with-*)
> New: --without-brotli --without-zstd (also --with-*)

Fixes:

  configure: WARNING: unrecognized options: [...] --without-libbrotli, --without-libzstd

[1]: https://gitlab.com/gnutls/gnutls/-/commit/6b794e49d1a14e43f9e08023f958364712c3c89a

Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
Cc: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
 package/gnutls/gnutls.mk | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

Comments

Arnout Vandecappelle Dec. 4, 2024, 9:51 p.m. UTC | #1
On 07/11/2024 14:43, TIAN Yuanhao wrote:
> Two configure option names have been changed since version 3.7.5 [1]:
> 
>> Old: --without-libbrotli --without-libzstd (also --with-*)
>> New: --without-brotli --without-zstd (also --with-*)
> 
> Fixes:
> 
>    configure: WARNING: unrecognized options: [...] --without-libbrotli, --without-libzstd
> 
> [1]: https://gitlab.com/gnutls/gnutls/-/commit/6b794e49d1a14e43f9e08023f958364712c3c89a
> 
> Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
> Cc: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

  Since this is a fix, I applied to master, thanks.

  Patch 1/2 is for next, not master. I didn't apply that one yet.

  Regards,
  Arnout

> ---
>   package/gnutls/gnutls.mk | 12 ++++++------
>   1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
> index 67b3c16b94..a977093bd5 100644
> --- a/package/gnutls/gnutls.mk
> +++ b/package/gnutls/gnutls.mk
> @@ -62,11 +62,11 @@ HOST_GNUTLS_CONF_OPTS = \
>   	--without-tpm \
>   	--without-tpm2 \
>   	--disable-openssl-compatibility \
> -	--without-libbrotli \
> +	--without-brotli \
>   	--without-idn \
>   	--without-p11-kit \
>   	--without-zlib \
> -	--without-libzstd
> +	--without-zstd
>   
>   ifeq ($(BR2_PACKAGE_GNUTLS_OPENSSL),y)
>   GNUTLS_LICENSE += , GPL-3.0+ (gnutls-openssl library)
> @@ -77,10 +77,10 @@ GNUTLS_CONF_OPTS += --disable-openssl-compatibility
>   endif
>   
>   ifeq ($(BR2_PACKAGE_BROTLI),y)
> -GNUTLS_CONF_OPTS += --with-libbrotli
> +GNUTLS_CONF_OPTS += --with-brotli
>   GNUTLS_DEPENDENCIES += brotli
>   else
> -GNUTLS_CONF_OPTS += --without-libbrotli
> +GNUTLS_CONF_OPTS += --without-brotli
>   endif
>   
>   ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
> @@ -110,10 +110,10 @@ GNUTLS_CONF_OPTS += --without-zlib
>   endif
>   
>   ifeq ($(BR2_PACKAGE_ZSTD),y)
> -GNUTLS_CONF_OPTS += --with-libzstd
> +GNUTLS_CONF_OPTS += --with-zstd
>   GNUTLS_DEPENDENCIES += zstd
>   else
> -GNUTLS_CONF_OPTS += --without-libzstd
> +GNUTLS_CONF_OPTS += --without-zstd
>   endif
>   
>   # Provide a default CA cert location
TIAN Yuanhao Dec. 5, 2024, 2:19 a.m. UTC | #2
At 2024-12-05 05:51:38, "Arnout Vandecappelle" <arnout@mind.be> wrote:
>
>On 07/11/2024 14:43, TIAN Yuanhao wrote:
>> Two configure option names have been changed since version 3.7.5 [1]:
>> 
>>> Old: --without-libbrotli --without-libzstd (also --with-*)
>>> New: --without-brotli --without-zstd (also --with-*)
>> 
>> Fixes:
>> 
>>    configure: WARNING: unrecognized options: [...] --without-libbrotli, --without-libzstd
>> 
>> [1]: https://gitlab.com/gnutls/gnutls/-/commit/6b794e49d1a14e43f9e08023f958364712c3c89a
>> 
>> Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
>> Cc: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
>
>  Since this is a fix, I applied to master, thanks.
>
>  Patch 1/2 is for next, not master. I didn't apply that one yet.

This patch must be applied after gnutls 3.8.8, otherwise another patch is required,
see http://patchwork.ozlabs.org/project/buildroot/patch/20241009113410.5077-1-tianyuanhao3@163.com/

So I suggest applying it in the next branch.

Regards,
Yuanhao

>
>  Regards,
>  Arnout
>
Lance Fredrickson Dec. 6, 2024, 2:31 p.m. UTC | #3
In 2024.11-rc3 I am now getting this error that was not present in 
2024.11-rc2.

In file included from dlwrap/brotlienc.c:12:
dlwrap/brotlienc.h:11:10: fatal error: brotli/encode.h: No such file or 
directory
    11 | #include <brotli/encode.h>
       |          ^~~~~~~~~~~~~~~~~
compilation terminated.
In file included from dlwrap/brotlidec.c:12:
dlwrap/brotlidec.h:11:10: fatal error: brotli/decode.h: No such file or 
directory
    11 | #include <brotli/decode.h>
       |          ^~~~~~~~~~~~~~~~~
compilation terminated.

Looks from discussion that a different patch is needed or patch 2/2 
needs reverted since 1/2 is slated for next.

Lance


On 12/4/2024 7:19 PM, TIAN Yuanhao wrote:
> At 2024-12-05 05:51:38, "Arnout Vandecappelle" <arnout@mind.be> wrote:
>> On 07/11/2024 14:43, TIAN Yuanhao wrote:
>>> Two configure option names have been changed since version 3.7.5 [1]:
>>>
>>>> Old: --without-libbrotli --without-libzstd (also --with-*)
>>>> New: --without-brotli --without-zstd (also --with-*)
>>> Fixes:
>>>
>>>     configure: WARNING: unrecognized options: [...] --without-libbrotli, --without-libzstd
>>>
>>> [1]: https://gitlab.com/gnutls/gnutls/-/commit/6b794e49d1a14e43f9e08023f958364712c3c89a
>>>
>>> Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
>>> Cc: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
>>   Since this is a fix, I applied to master, thanks.
>>
>>   Patch 1/2 is for next, not master. I didn't apply that one yet.
> This patch must be applied after gnutls 3.8.8, otherwise another patch is required,
> see http://patchwork.ozlabs.org/project/buildroot/patch/20241009113410.5077-1-tianyuanhao3@163.com/
>
> So I suggest applying it in the next branch.
>
> Regards,
> Yuanhao
>
>>   Regards,
>>   Arnout
>>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Dec. 6, 2024, 11:22 p.m. UTC | #4
>>>>> "Lance" == Lance Fredrickson <lancethepants@gmail.com> writes:

 > In 2024.11-rc3 I am now getting this error that was not present in
 > 2024.11-rc2.

 > In file included from dlwrap/brotlienc.c:12:
 > dlwrap/brotlienc.h:11:10: fatal error: brotli/encode.h: No such file
 > or directory
 >    11 | #include <brotli/encode.h>
 >       |          ^~~~~~~~~~~~~~~~~
 > compilation terminated.
 > In file included from dlwrap/brotlidec.c:12:
 > dlwrap/brotlidec.h:11:10: fatal error: brotli/decode.h: No such file
 > or directory
 >    11 | #include <brotli/decode.h>
 >       |          ^~~~~~~~~~~~~~~~~
 > compilation terminated.

 > Looks from discussion that a different patch is needed or patch 2/2
 > needs reverted since 1/2 is slated for next.

I have applied the bump to 3.8.8, which fixes the build here. Can you
try current master as well?
Lance Fredrickson Dec. 8, 2024, 3:06 a.m. UTC | #5
Compiles good now.

thanks!

On 12/6/2024 4:22 PM, Peter Korsgaard wrote:
>>>>>> "Lance" == Lance Fredrickson <lancethepants@gmail.com> writes:
>   > In 2024.11-rc3 I am now getting this error that was not present in
>   > 2024.11-rc2.
>
>   > In file included from dlwrap/brotlienc.c:12:
>   > dlwrap/brotlienc.h:11:10: fatal error: brotli/encode.h: No such file
>   > or directory
>   >    11 | #include <brotli/encode.h>
>   >       |          ^~~~~~~~~~~~~~~~~
>   > compilation terminated.
>   > In file included from dlwrap/brotlidec.c:12:
>   > dlwrap/brotlidec.h:11:10: fatal error: brotli/decode.h: No such file
>   > or directory
>   >    11 | #include <brotli/decode.h>
>   >       |          ^~~~~~~~~~~~~~~~~
>   > compilation terminated.
>
>   > Looks from discussion that a different patch is needed or patch 2/2
>   > needs reverted since 1/2 is slated for next.
>
> I have applied the bump to 3.8.8, which fixes the build here. Can you
> try current master as well?
>
Peter Korsgaard Dec. 8, 2024, 2:50 p.m. UTC | #6
>>>>> "Arnout" == Arnout Vandecappelle via buildroot <buildroot@buildroot.org> writes:

 > On 07/11/2024 14:43, TIAN Yuanhao wrote:
 >> Two configure option names have been changed since version 3.7.5 [1]:
 >> 
 >>> Old: --without-libbrotli --without-libzstd (also --with-*)
 >>> New: --without-brotli --without-zstd (also --with-*)
 >> Fixes:
 >> configure: WARNING: unrecognized options: [...]
 >> --without-libbrotli, --without-libzstd
 >> [1]:
 >> https://gitlab.com/gnutls/gnutls/-/commit/6b794e49d1a14e43f9e08023f958364712c3c89a
 >> Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
 >> Cc: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 >  Since this is a fix, I applied to master, thanks.

 >  Patch 1/2 is for next, not master. I didn't apply that one yet.

Committed to 2024.02.x and 2024.08.x, thanks.
diff mbox series

Patch

diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 67b3c16b94..a977093bd5 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -62,11 +62,11 @@  HOST_GNUTLS_CONF_OPTS = \
 	--without-tpm \
 	--without-tpm2 \
 	--disable-openssl-compatibility \
-	--without-libbrotli \
+	--without-brotli \
 	--without-idn \
 	--without-p11-kit \
 	--without-zlib \
-	--without-libzstd
+	--without-zstd
 
 ifeq ($(BR2_PACKAGE_GNUTLS_OPENSSL),y)
 GNUTLS_LICENSE += , GPL-3.0+ (gnutls-openssl library)
@@ -77,10 +77,10 @@  GNUTLS_CONF_OPTS += --disable-openssl-compatibility
 endif
 
 ifeq ($(BR2_PACKAGE_BROTLI),y)
-GNUTLS_CONF_OPTS += --with-libbrotli
+GNUTLS_CONF_OPTS += --with-brotli
 GNUTLS_DEPENDENCIES += brotli
 else
-GNUTLS_CONF_OPTS += --without-libbrotli
+GNUTLS_CONF_OPTS += --without-brotli
 endif
 
 ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
@@ -110,10 +110,10 @@  GNUTLS_CONF_OPTS += --without-zlib
 endif
 
 ifeq ($(BR2_PACKAGE_ZSTD),y)
-GNUTLS_CONF_OPTS += --with-libzstd
+GNUTLS_CONF_OPTS += --with-zstd
 GNUTLS_DEPENDENCIES += zstd
 else
-GNUTLS_CONF_OPTS += --without-libzstd
+GNUTLS_CONF_OPTS += --without-zstd
 endif
 
 # Provide a default CA cert location