deleted file mode 100644
@@ -1,46 +0,0 @@
-From c265971648f82464a76f797c4c20a09def078be9 Mon Sep 17 00:00:00 2001
-From: Andi Kleen <ak@linux.intel.com>
-Date: Thu, 16 May 2024 09:03:24 -0700
-Subject: [PATCH] Don't fail build when set_mempolicy_home_node syscall is
- unknown
-
-Instead just warn at build and return ENOSYS. This fixes build
-on architectures like arm without kernel headers installed.
-
-Fixes #219
-
-Upstream: https://github.com/numactl/numactl/commit/87342c3b9a42aadbe1398ca8233d13ab524aa64f
-Signed-off-by: Andi Kleen <ak@linux.intel.com>
----
- syscall.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/syscall.c b/syscall.c
-index 63b3e53..392f736 100644
---- a/syscall.c
-+++ b/syscall.c
-@@ -144,7 +144,7 @@
- #if defined(__x86_64__) || defined(__aarch64__)
- #define __NR_set_mempolicy_home_node 450
- #else
--#error "Add syscalls for your architecture or update kernel headers"
-+#warning "Add syscalls for your architecture or update kernel headers"
- #endif
-
- #endif
-@@ -261,7 +261,12 @@ long WEAK move_pages(int pid, unsigned long count,
-
- int WEAK set_mempolicy_home_node(void *start, unsigned long len, int home_node, int flags)
- {
-+#ifndef __NR_set_mempolicy_home_node
-+ errno = ENOSYS;
-+ return -1;
-+#else
- return syscall(__NR_set_mempolicy_home_node, start, len, home_node, flags);
-+#endif
- }
-
- /* SLES8 glibc doesn't define those */
-2.46.2
-
@@ -1,4 +1,4 @@
# Locally calculated
-sha256 b4fc0956317680579992d7815bc43d0538960dc73aa1dd8ca7e3806e30bc1274 numactl-2.0.18.tar.gz
+sha256 f2672a0381cb59196e9c246bf8bcc43d5568bc457700a697f1a1df762b9af884 numactl-2.0.19.tar.gz
sha256 ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6 LICENSE.GPL2
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 LICENSE.LGPL2.1
@@ -4,7 +4,7 @@
#
################################################################################
-NUMACTL_VERSION = 2.0.18
+NUMACTL_VERSION = 2.0.19
NUMACTL_SITE = \
https://github.com/numactl/numactl/releases/download/v$(NUMACTL_VERSION)
NUMACTL_LICENSE = LGPL-2.1 (libnuma), GPL-2.0 (programs)
For change logs since 2.0.18, see: https://github.com/numactl/numactl/releases/tag/v2.0.19 This commit also removes the package patch, which is included in this version. Signed-off-by: Julien Olivain <ju.o@free.fr> --- Patch tested in: https://gitlab.com/jolivain/buildroot/-/jobs/8279029791 https://gitlab.com/jolivain/buildroot/-/pipelines/1528845024 --- ...-when-set_mempolicy_home_node-syscal.patch | 46 ------------------- package/numactl/numactl.hash | 2 +- package/numactl/numactl.mk | 2 +- 3 files changed, 2 insertions(+), 48 deletions(-) delete mode 100644 package/numactl/0001-Don-t-fail-build-when-set_mempolicy_home_node-syscal.patch