diff mbox series

package/nfs-utils: bump version to 2.8.1

Message ID 20241104202319.2193487-1-giulio.benetti@benettiengineering.com
State New
Headers show
Series package/nfs-utils: bump version to 2.8.1 | expand

Commit Message

Giulio Benetti Nov. 4, 2024, 8:23 p.m. UTC
* disable junction and nfsdctl by default
* drop 2 local patches that have been committed.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 ...-reexport-.c-Re-add-missing-includes.patch | 44 -------------------
 ...d_sqlite.c-Add-missing-sys-syscall.h.patch | 31 -------------
 package/nfs-utils/nfs-utils.hash              |  4 +-
 package/nfs-utils/nfs-utils.mk                |  6 ++-
 4 files changed, 7 insertions(+), 78 deletions(-)
 delete mode 100644 package/nfs-utils/0001-reexport-fsidd-reexport-.c-Re-add-missing-includes.patch
 delete mode 100644 package/nfs-utils/0002-support-backend_sqlite.c-Add-missing-sys-syscall.h.patch

Comments

Petr Vorel Nov. 4, 2024, 9:16 p.m. UTC | #1
Hi Giulio,

Thanks for the update!

> * disable junction and nfsdctl by default
...
>  NFS_UTILS_CONF_OPTS = \
>  	--enable-tirpc \
>  	--enable-ipv6 \
> +	--disable-junction \
> +	--disable-nfsdctl \
>  	--without-tcp-wrappers \
>  	--with-statedir=/run/nfs \
>  	--with-rpcgen=$(HOST_DIR)/bin/rpcgen
> @@ -30,6 +32,8 @@ HOST_NFS_UTILS_CONF_OPTS = \
>  	--disable-gss \
>  	--disable-uuid \
>  	--disable-ipv6 \
> +	--disable-junction \
> +	--disable-nfsdctl \
>  	--without-tcp-wrappers \
>  	--with-statedir=/run/nfs \
>  	--disable-caps \

What was the reason to disable them? Shouldn't be at least nfsdctl enabled?

man nfsdctl(8) "control program for the Linux kernel NFS server" [1]
That sounds useful.

man nfsref(8) "manage NFS referrals"
       ...
       A junction is a file system object on an NFS server that, when an
       NFS client encounters it, triggers a referral.  Similar to a
       symlink, a junction contains one or more target locations that
       the server sends to clients in the form of an NFSv4 referral.

I'm not sure how much useful this is, but it's enabled by default. Also Debian
explicitly enables it. Do we have a good reason to disable it?

> * drop 2 local patches that have been committed.

Reviewed-by: Petr Vorel <petr.vorel@gmail.com>

Kind regards,
Petr

[1] https://manpages.debian.org/testing/nfs-kernel-server/nfsdctl.8.en.html
[2] https://man7.org/linux/man-pages/man8/nfsref.8.html
[3] https://salsa.debian.org/kernel-team/nfs-utils/-/blob/master/debian/rules?ref_type=heads
Giulio Benetti Nov. 4, 2024, 9:40 p.m. UTC | #2
Hi Petr,

On 11/4/24 22:16, Petr Vorel wrote:
> Hi Giulio,
> 
> Thanks for the update!
> 
>> * disable junction and nfsdctl by default
> ...
>>   NFS_UTILS_CONF_OPTS = \
>>   	--enable-tirpc \
>>   	--enable-ipv6 \
>> +	--disable-junction \
>> +	--disable-nfsdctl \
>>   	--without-tcp-wrappers \
>>   	--with-statedir=/run/nfs \
>>   	--with-rpcgen=$(HOST_DIR)/bin/rpcgen
>> @@ -30,6 +32,8 @@ HOST_NFS_UTILS_CONF_OPTS = \
>>   	--disable-gss \
>>   	--disable-uuid \
>>   	--disable-ipv6 \
>> +	--disable-junction \
>> +	--disable-nfsdctl \
>>   	--without-tcp-wrappers \
>>   	--with-statedir=/run/nfs \
>>   	--disable-caps \
> 
> What was the reason to disable them? Shouldn't be at least nfsdctl enabled?

nfsdctl has been added with nfs-utils commit 
8c32613d5311930c17c056d93996bcd8e00e0fa4

so between version 2.7.1 and 2.8.1 and with this bump I've tried to keep
things as they were.

> 
> man nfsdctl(8) "control program for the Linux kernel NFS server" [1]
> That sounds useful.

Yes it is. But I think it deserves a separate patch since it's not about
bumping the version. Feel free to provide one for it.

> 
> man nfsref(8) "manage NFS referrals"
>         ...
>         A junction is a file system object on an NFS server that, when an
>         NFS client encounters it, triggers a referral.  Similar to a
>         symlink, a junction contains one or more target locations that
>         the server sends to clients in the form of an NFSv4 referral.
> 
> I'm not sure how much useful this is, but it's enabled by default. Also Debian
> explicitly enables it. Do we have a good reason to disable it?

To keep it enabled we need libxml2 dependency, so I've preferred to keep
it disabled as pointed by Thomas on patch to bump to version 2.7.1

This can be enabled as an option too, so here again you can send a patch.

Kind regards
diff mbox series

Patch

diff --git a/package/nfs-utils/0001-reexport-fsidd-reexport-.c-Re-add-missing-includes.patch b/package/nfs-utils/0001-reexport-fsidd-reexport-.c-Re-add-missing-includes.patch
deleted file mode 100644
index 4f79af450e..0000000000
--- a/package/nfs-utils/0001-reexport-fsidd-reexport-.c-Re-add-missing-includes.patch
+++ /dev/null
@@ -1,44 +0,0 @@ 
-From 4710e469cd0f512ac5e2c3c4335d8e21b97f21b0 Mon Sep 17 00:00:00 2001
-From: Petr Vorel <pvorel@suse.cz>
-Date: Tue, 5 Dec 2023 20:40:36 +0100
-Subject: [PATCH] reexport/{fsidd,reexport}.c: Re-add missing includes
-
-Older uClibc-ng requires <unistd.h> for close(2), unlink(2) and write(2),
-<sys/un.h> for struct sockaddr_un.
-
-Fixes: 1a4edb2a ("reexport/fsidd.c: Remove unused headers")
-Fixes: bdc79f02 ("support/reexport.c: Remove unused headers")
-Signed-off-by: Petr Vorel <pvorel@suse.cz>
-Upstream: https://lore.kernel.org/linux-nfs/20231205223543.31443-1-pvorel@suse.cz/
----
- support/reexport/fsidd.c    | 2 ++
- support/reexport/reexport.c | 1 +
- 2 files changed, 3 insertions(+)
-
-diff --git a/support/reexport/fsidd.c b/support/reexport/fsidd.c
-index 3e62b3fc..814fb48e 100644
---- a/support/reexport/fsidd.c
-+++ b/support/reexport/fsidd.c
-@@ -7,6 +7,8 @@
- #include <dlfcn.h>
- #endif
- #include <event2/event.h>
-+#include <sys/un.h>
-+#include <unistd.h>
-
- #include "conffile.h"
- #include "reexport_backend.h"
-diff --git a/support/reexport/reexport.c b/support/reexport/reexport.c
-index 78516586..1900b336 100644
---- a/support/reexport/reexport.c
-+++ b/support/reexport/reexport.c
-@@ -7,6 +7,7 @@
- #endif
- #include <sys/types.h>
- #include <sys/vfs.h>
-+#include <unistd.h>
- #include <errno.h>
-
- #include "nfsd_path.h"
---
-2.43.0
diff --git a/package/nfs-utils/0002-support-backend_sqlite.c-Add-missing-sys-syscall.h.patch b/package/nfs-utils/0002-support-backend_sqlite.c-Add-missing-sys-syscall.h.patch
deleted file mode 100644
index 88e1a9068d..0000000000
--- a/package/nfs-utils/0002-support-backend_sqlite.c-Add-missing-sys-syscall.h.patch
+++ /dev/null
@@ -1,31 +0,0 @@ 
-From aee92881ba80cf2ae7381d19f09e7fbeda57974c Mon Sep 17 00:00:00 2001
-From: Petr Vorel <petr.vorel@gmail.com>
-Date: Tue, 5 Dec 2023 23:20:33 +0100
-Subject: [PATCH] support/backend_sqlite.c: Add missing <sys/syscall.h>
-
-This fixes build on systems which actually needs getrandom()
-(to get SYS_getrandom).
-
-Fixes: f92fd6ca ("support/backend_sqlite.c: Add getrandom() fallback")
-Fixes: http://autobuild.buildroot.net/results/c5fde6099a8b228a8bdc3154d1e47dfa192e94ed/
-Reported-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
-Signed-off-by: Petr Vorel <pvorel@suse.cz>
-Upstream: https://lore.kernel.org/linux-nfs/20231205223543.31443-2-pvorel@suse.cz/
----
- support/reexport/backend_sqlite.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/support/reexport/backend_sqlite.c b/support/reexport/backend_sqlite.c
-index 0eb5ea37..54dfe447 100644
---- a/support/reexport/backend_sqlite.c
-+++ b/support/reexport/backend_sqlite.c
-@@ -7,6 +7,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <sys/syscall.h>
- #include <unistd.h>
-
- #ifdef HAVE_GETRANDOM
---
-2.43.0
diff --git a/package/nfs-utils/nfs-utils.hash b/package/nfs-utils/nfs-utils.hash
index 9d74991df1..b4ecbd0aec 100644
--- a/package/nfs-utils/nfs-utils.hash
+++ b/package/nfs-utils/nfs-utils.hash
@@ -1,4 +1,4 @@ 
-# From https://www.kernel.org/pub/linux/utils/nfs-utils/2.6.4/sha256sums.asc
-sha256  01b3b0fb9c7d0bbabf5114c736542030748c788ec2fd9734744201e9b0a1119d  nfs-utils-2.6.4.tar.xz
+# From https://www.kernel.org/pub/linux/utils/nfs-utils/2.8.1/sha256sums.asc
+sha256  a0be95b08396908048583fcf6b34a7c1ab49d53e8a12eb28673ccfd2eff0c505  nfs-utils-2.8.1.tar.xz
 # Locally computed
 sha256  576540abf5e95029ad4ad90e32071385a5e95b2c30708c706116f3eb87b9a3de  COPYING
diff --git a/package/nfs-utils/nfs-utils.mk b/package/nfs-utils/nfs-utils.mk
index b757e3e51d..d79760ab00 100644
--- a/package/nfs-utils/nfs-utils.mk
+++ b/package/nfs-utils/nfs-utils.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-NFS_UTILS_VERSION = 2.6.4
+NFS_UTILS_VERSION = 2.8.1
 NFS_UTILS_SOURCE = nfs-utils-$(NFS_UTILS_VERSION).tar.xz
 NFS_UTILS_SITE = https://www.kernel.org/pub/linux/utils/nfs-utils/$(NFS_UTILS_VERSION)
 NFS_UTILS_LICENSE = GPL-2.0+
@@ -17,6 +17,8 @@  NFS_UTILS_CONF_ENV = knfsd_cv_bsd_signals=no
 NFS_UTILS_CONF_OPTS = \
 	--enable-tirpc \
 	--enable-ipv6 \
+	--disable-junction \
+	--disable-nfsdctl \
 	--without-tcp-wrappers \
 	--with-statedir=/run/nfs \
 	--with-rpcgen=$(HOST_DIR)/bin/rpcgen
@@ -30,6 +32,8 @@  HOST_NFS_UTILS_CONF_OPTS = \
 	--disable-gss \
 	--disable-uuid \
 	--disable-ipv6 \
+	--disable-junction \
+	--disable-nfsdctl \
 	--without-tcp-wrappers \
 	--with-statedir=/run/nfs \
 	--disable-caps \