@@ -3309,6 +3309,7 @@ N: Vladimir Oltean <olteanv@gmail.com>
F: package/qoriq-ddr-phy-binary/
F: package/qoriq-mc-binary/
F: package/qoriq-mc-utils/
+F: package/qoriq-restool/
N: Volkov Viacheslav <sv99@inbox.ru>
F: package/v4l2grab/
@@ -598,6 +598,7 @@ endmenu
source "package/pru-software-support/Config.in"
source "package/pulseview/Config.in"
source "package/qoriq-cadence-dp-firmware/Config.in"
+ source "package/qoriq-restool/Config.in"
source "package/raspi-gpio/Config.in"
source "package/rdma-core/Config.in"
source "package/read-edid/Config.in"
new file mode 100644
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_QORIQ_RESTOOL
+ bool "qoriq-restool"
+ help
+ The DPAA2 architecture in Layerscape SoCs consists of
+ networking resources that can be assembled into various
+ nuggets of functionality, called "objects" (DPMAC, DPNI,
+ DPDMUX, DPSW etc), by the Management Complex (MC) firmware.
+
+ The MC firmware reads a file called Data Path Layout (DPL)
+ which describes the set of networking objects it should
+ create statically, at boot time.
+
+ The restool program is able to talk to the Management Complex
+ at runtime and permits the dynamic reconfiguration of
+ networking objects, as well as saving the current configuration
+ into a new DPL file. Without the restool program, the only
+ possible networking configuration is that specified in the
+ boot-time DPL file.
+
+ https://github.com/nxp-qoriq/restool
+ https://www.nxp.com/webapp/Download?colCode=DPAA2UM # sign in required
new file mode 100644
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 0cfced32caa615266ff633946d40a36660c856d7eb057b81de392570e136c5e5 qoriq-restool-lf-6.6.36-2.1.0.tar.gz
+sha256 68f4b15ecc085729419bc60ca6eeadca5af0237bbfec791e8a79da9c943d42e9 LICENSE
new file mode 100644
@@ -0,0 +1,24 @@
+###############################################################################
+#
+# qoriq-restool
+#
+################################################################################
+
+QORIQ_RESTOOL_VERSION = lf-6.6.36-2.1.0
+QORIQ_RESTOOL_SITE = $(call github,nxp-qoriq,restool,$(QORIQ_RESTOOL_VERSION))
+QORIQ_RESTOOL_LICENSE = GPL2.0
+QORIQ_RESTOOL_LICENSE_FILES = COPYING
+
+QORIQ_RESTOOL_MAKE_OPTS = \
+ CC="$(TARGET_CC)" \
+ CROSS_COMPILE="$(TARGET_CROSS)"
+
+define QORIQ_RESTOOL_BUILD_CMDS
+ cd $(@D) && $(TARGET_MAKE_ENV) $(MAKE) $(QORIQ_RESTOOL_MAKE_OPTS)
+endef
+
+define QORIQ_RESTOOL_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) prefix=/usr install
+endef
+
+$(eval $(generic-package))
Introduce a package for the restool program, which permits the user to modify the network configuration of the DPAA2 subsystem and create one that is adequate to their use case. Signed-off-by: Vladimir Oltean <olteanv@gmail.com> --- DEVELOPERS | 1 + package/Config.in | 1 + package/qoriq-restool/Config.in | 21 +++++++++++++++++++++ package/qoriq-restool/qoriq-restool.hash | 3 +++ package/qoriq-restool/qoriq-restool.mk | 24 ++++++++++++++++++++++++ 5 files changed, 50 insertions(+) create mode 100644 package/qoriq-restool/Config.in create mode 100644 package/qoriq-restool/qoriq-restool.hash create mode 100644 package/qoriq-restool/qoriq-restool.mk