diff mbox series

[1/1] package/python-pillow: fix webp DependencyException

Message ID 20241031221535.338325-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/python-pillow: fix webp DependencyException | expand

Commit Message

James Hilliard Oct. 31, 2024, 10:15 p.m. UTC
As of baa3db0c34e826cc1c6469fd8ecbfbc5c2ef2e2c webp mux/demux are no
longer optional for webp support in python-pillow.

Fixes:
DependencyException:
The headers or library files could not be found for webp,
which was requested by the option flag --enable-webp

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-pillow/python-pillow.mk | 9 ++-------
 1 file changed, 2 insertions(+), 7 deletions(-)

Comments

Arnout Vandecappelle Nov. 12, 2024, 7:55 p.m. UTC | #1
On 31/10/2024 23:15, James Hilliard wrote:
> As of baa3db0c34e826cc1c6469fd8ecbfbc5c2ef2e2c webp mux/demux are no
> longer optional for webp support in python-pillow.
> 
> Fixes:
> DependencyException:
> The headers or library files could not be found for webp,
> which was requested by the option flag --enable-webp

  I added:

Fixes: baa3db0c34e826cc1c6469fd8ecbfbc5c2ef2e2c

  I don't think Peter uses this information at the moment but it could be useful.

  Applied to master, thanks.


> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>   package/python-pillow/python-pillow.mk | 9 ++-------
>   1 file changed, 2 insertions(+), 7 deletions(-)
> 
> diff --git a/package/python-pillow/python-pillow.mk b/package/python-pillow/python-pillow.mk
> index e87c817c68..ed2668f03c 100644
> --- a/package/python-pillow/python-pillow.mk
> +++ b/package/python-pillow/python-pillow.mk
> @@ -58,16 +58,11 @@ else
>   PYTHON_PILLOW_BUILD_OPTS += -Ctiff=disable
>   endif
>   
> -ifeq ($(BR2_PACKAGE_WEBP),y)
> +ifeq ($(BR2_PACKAGE_WEBP)$(BR2_PACKAGE_WEBP_DEMUX)$(BR2_PACKAGE_WEBP_MUX),yyy)

  It would also be possible to add to Config.in:

	select BR2_PACKAGE_WEBP_DEMUX if BR2_PACKAGE_WEBP
	select BR2_PACKAGE_WEBP_MUX if BR2_PACKAGE_WEBP

  We do that for a few other packages. But either way works.

  Regards,
  Arnout

>   PYTHON_PILLOW_DEPENDENCIES += webp
>   PYTHON_PILLOW_BUILD_OPTS += -Cwebp=enable
> -ifeq ($(BR2_PACKAGE_WEBP_DEMUX)$(BR2_PACKAGE_WEBP_MUX),yy)
> -PYTHON_PILLOW_BUILD_OPTS += -Cwebpmux=enable
>   else
> -PYTHON_PILLOW_BUILD_OPTS += -Cwebpmux=disable
> -endif
> -else
> -PYTHON_PILLOW_BUILD_OPTS += -Cwebp=disable -Cwebpmux=disable
> +PYTHON_PILLOW_BUILD_OPTS += -Cwebp=disable
>   endif
>   
>   $(eval $(python-package))
Peter Korsgaard Nov. 26, 2024, 1:17 p.m. UTC | #2
>>>>> "Arnout" == Arnout Vandecappelle via buildroot <buildroot@buildroot.org> writes:

 > On 31/10/2024 23:15, James Hilliard wrote:
 >> As of baa3db0c34e826cc1c6469fd8ecbfbc5c2ef2e2c webp mux/demux are no
 >> longer optional for webp support in python-pillow.
 >> Fixes:
 >> DependencyException:
 >> The headers or library files could not be found for webp,
 >> which was requested by the option flag --enable-webp

 >  I added:

 > Fixes: baa3db0c34e826cc1c6469fd8ecbfbc5c2ef2e2c

 >  I don't think Peter uses this information at the moment but it could be useful.

I do, it is indeed handy when we clearly mark when an issue was
introduced.
diff mbox series

Patch

diff --git a/package/python-pillow/python-pillow.mk b/package/python-pillow/python-pillow.mk
index e87c817c68..ed2668f03c 100644
--- a/package/python-pillow/python-pillow.mk
+++ b/package/python-pillow/python-pillow.mk
@@ -58,16 +58,11 @@  else
 PYTHON_PILLOW_BUILD_OPTS += -Ctiff=disable
 endif
 
-ifeq ($(BR2_PACKAGE_WEBP),y)
+ifeq ($(BR2_PACKAGE_WEBP)$(BR2_PACKAGE_WEBP_DEMUX)$(BR2_PACKAGE_WEBP_MUX),yyy)
 PYTHON_PILLOW_DEPENDENCIES += webp
 PYTHON_PILLOW_BUILD_OPTS += -Cwebp=enable
-ifeq ($(BR2_PACKAGE_WEBP_DEMUX)$(BR2_PACKAGE_WEBP_MUX),yy)
-PYTHON_PILLOW_BUILD_OPTS += -Cwebpmux=enable
 else
-PYTHON_PILLOW_BUILD_OPTS += -Cwebpmux=disable
-endif
-else
-PYTHON_PILLOW_BUILD_OPTS += -Cwebp=disable -Cwebpmux=disable
+PYTHON_PILLOW_BUILD_OPTS += -Cwebp=disable
 endif
 
 $(eval $(python-package))