@@ -3,12 +3,10 @@ config BR2_PACKAGE_XWAYLAND
depends on BR2_USE_MMU # fork()
depends on !BR2_STATIC_LIBS # wayland
depends on BR2_TOOLCHAIN_HAS_THREADS # wayland
- # We need a SHA1 implementation. If either openssl or
- # libgcrypt are already part of the build, we'll use one of
- # them, otherwise, use the small libsha1 library.
- depends on BR2_TOOLCHAIN_HAS_SYNC_4 # xlib_libxshmfence
- select BR2_PACKAGE_LIBDRM
- select BR2_PACKAGE_LIBSHA1 if (!BR2_PACKAGE_OPENSSL && !BR2_PACKAGE_LIBGCRYPT)
+ # We need a SHA1 implementation. If either openssl, libgcrypt, nettle or
+ # libsha1 are already part of the build, we'll use one of them,
+ # otherwise, use the small libmd library.
+ select BR2_PACKAGE_LIBMD if (!BR2_PACKAGE_OPENSSL && !BR2_PACKAGE_LIBGCRYPT && !BR2_PACKAGE_NETTLE && !BR2_PACKAGE_LIBSHA1)
select BR2_PACKAGE_PIXMAN
select BR2_PACKAGE_WAYLAND
select BR2_PACKAGE_WAYLAND_PROTOCOLS
@@ -16,7 +14,6 @@ config BR2_PACKAGE_XWAYLAND
select BR2_PACKAGE_XLIB_LIBXFONT2
select BR2_PACKAGE_XLIB_LIBXKBFILE
select BR2_PACKAGE_XLIB_LIBXRANDR
- select BR2_PACKAGE_XLIB_LIBXSHMFENCE
select BR2_PACKAGE_XLIB_XTRANS
select BR2_PACKAGE_XORGPROTO
help
@@ -26,5 +23,4 @@ config BR2_PACKAGE_XWAYLAND
comment "xwayland needs a toolchain w/ threads, dynamic library"
depends on BR2_USE_MMU
- depends on BR2_TOOLCHAIN_HAS_SYNC_4
depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
@@ -1,6 +1,8 @@
-# From https://lists.x.org/archives/xorg-announce/2024-January/003443.html
-sha256 a99e159b6d0d33098b3b6ab22a88bfcece23c8b9d0ca72c535c55dcb0681b46b xwayland-23.2.4.tar.xz
-sha512 ac3ff208cbef5bbe4637c335cfda226489c93b0a3768f2f4fb0201c588485ede38262fbce77ef1425b3d2a0be61b6580df53341c7b95e6072c8b6371ad29d187 xwayland-23.2.4.tar.xz
+# Verified from https://xorg.freedesktop.org/archive/individual/xserver/xwayland-24.1.3.tar.xz.sig
+# with key 67DC86F2623FC5FD4BB5225D14706DBE1E4B4540
+# From https://lists.x.org/archives/xorg-announce/2024-October/003532.html
+sha256 dcdb57a66cc9b124c8f936760592628ac4e744a7d7b3179aa86189ad7ea4cb10 xwayland-24.1.3.tar.xz
+sha512 7e0e11b07408f41a81bafa7bc519d02ed9bdc36e11be16abe255a7d779d04824af23d79323f1602119b046c545cdd43ea91b93e23feb0ffe411aa6989b462c1d xwayland-24.1.3.tar.xz
# Locally calculated
sha256 4cc0447a22635c7b2f1a93fec4aa94f1970fadeb72a063de006b51cf4963a06f COPYING
@@ -4,7 +4,7 @@
#
################################################################################
-XWAYLAND_VERSION = 23.2.4
+XWAYLAND_VERSION = 24.1.3
XWAYLAND_SOURCE = xwayland-$(XWAYLAND_VERSION).tar.xz
XWAYLAND_SITE = https://xorg.freedesktop.org/archive/individual/xserver
XWAYLAND_LICENSE = MIT
@@ -12,7 +12,6 @@ XWAYLAND_LICENSE_FILES = COPYING
XWAYLAND_CPE_ID_VENDOR = x.org
XWAYLAND_INSTALL_STAGING = YES
XWAYLAND_DEPENDENCIES = \
- libdrm \
pixman \
wayland \
wayland-protocols \
@@ -20,22 +19,26 @@ XWAYLAND_DEPENDENCIES = \
xlib_libXfont2 \
xlib_libxkbfile \
xlib_libXrandr \
- xlib_libxshmfence \
xlib_xtrans \
xorgproto
XWAYLAND_CONF_OPTS = \
- -Ddri3=true \
- -Dxwayland_eglstream=false \
+ -Dxwayland_ei=false \
-Dxvfb=false \
-Ddefault_font_path=/usr/share/fonts/X11/ \
-Ddtrace=false \
-Ddocs=false
+ifeq ($(BR2_PACKAGE_LIBDRM)$(BR2_PACKAGE_XLIB_LIBXSHMFENCE),yy)
+XWAYLAND_CONF_OPTS += -Ddri3=true
+XWAYLAND_DEPENDENCIES += libdrm xlib_libxshmfence
ifeq ($(BR2_PACKAGE_LIBEPOXY),y)
XWAYLAND_CONF_OPTS += -Dglamor=true
XWAYLAND_DEPENDENCIES += libepoxy
else
XWAYLAND_CONF_OPTS += -Dglamor=false
+endif # BR2_PACKAGE_LIBEPOXY
+else
+XWAYLAND_CONF_OPTS += -Ddri3=false
endif
ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
@@ -76,9 +79,15 @@ XWAYLAND_DEPENDENCIES += openssl
else ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
XWAYLAND_CONF_OPTS += -Dsha1=libgcrypt
XWAYLAND_DEPENDENCIES += libgcrypt
-else
+else ifeq ($(BR2_PACKAGE_NETTLE),y)
+XWAYLAND_CONF_OPTS += -Dsha1=libnettle
+XWAYLAND_DEPENDENCIES += nettle
+else ifeq ($(BR2_PACKAGE_LIBSHA1),y)
XWAYLAND_CONF_OPTS += -Dsha1=libsha1
XWAYLAND_DEPENDENCIES += libsha1
+else
+XWAYLAND_CONF_OPTS += -Dsha1=libmd
+XWAYLAND_DEPENDENCIES += libmd
endif
ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
Additionally, make libdrm an optional dependency. Also, xlib_libxshmfence is not a required dependency. Release notes: https://lists.x.org/archives/xorg-announce/2024-October/003532.html Signed-off-by: Raphael Pavlidis <raphael.pavlidis@gmail.com> --- package/x11r7/xwayland/Config.in | 12 ++++-------- package/x11r7/xwayland/xwayland.hash | 8 +++++--- package/x11r7/xwayland/xwayland.mk | 21 +++++++++++++++------ 3 files changed, 24 insertions(+), 17 deletions(-)