@@ -12,20 +12,22 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
[Rebased on 20221215-105525-0-g1afa26c5]
Signed-off-by: Fiona Klute <fiona.klute+wiwa@gmx.de>
+[Rebased on cd6896c]
+Signed-off-by: Athaariq Ardhiansyah <foss@athaariq.my.id>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index dc78cfe..c9d4910 100755
+index cd6896c..076ae43 100755
--- a/Makefile
+++ b/Makefile
-@@ -1,7 +1,7 @@
- PKG_VER=$(shell grep rpiboot debian/changelog | head -n1 | sed 's/.*(\(.*\)).*/\1/g')
- GIT_VER=$(shell git rev-parse HEAD 2>/dev/null | cut -c1-8 || echo "")
- rpiboot: main.c msd/bootcode.h msd/start.h msd/bootcode4.h msd/start4.h
-- $(CC) -Wall -Wextra -g -o $@ $< `pkg-config --cflags --libs libusb-1.0` -DGIT_VER="\"$(GIT_VER)\"" -DPKG_VER="\"$(PKG_VER)\""
-+ $(CC) -Wall -Wextra -g $(CFLAGS) -o $@ $< `pkg-config --cflags --libs libusb-1.0` -DGIT_VER="\"$(GIT_VER)\"" -DPKG_VER="\"$(PKG_VER)\"" $(LDFLAGS)
+@@ -3,7 +3,7 @@ GIT_VER=$(shell git rev-parse HEAD 2>/dev/null | cut -c1-8 || echo "")
+ INSTALL_PREFIX?=/usr
+
+ rpiboot: main.c bootfiles.c msd/bootcode.h msd/start.h msd/bootcode4.h msd/start4.h
+- $(CC) -Wall -Wextra -g -o $@ main.c bootfiles.c `pkg-config --cflags --libs libusb-1.0` -DGIT_VER="\"$(GIT_VER)\"" -DPKG_VER="\"$(PKG_VER)\"" -DINSTALL_PREFIX=\"$(INSTALL_PREFIX)\"
++ $(CC) -Wall -Wextra -g $(CFLAGS) -o $@ main.c bootfiles.c `pkg-config --cflags --libs libusb-1.0` -DGIT_VER="\"$(GIT_VER)\"" -DPKG_VER="\"$(PKG_VER)\"" -DINSTALL_PREFIX=\"$(INSTALL_PREFIX)\" $(LDFLAGS)
%.h: %.bin ./bin2c
./bin2c $< $@
@@ -1,5 +1,5 @@
# Locally calculated
-sha256 2f02dbe9a88e9dfad5f05e513e1f30afd47b1575820f7c3b09665dfefc45bbaa raspberrypi-usbboot-20221215-105525.tar.gz
+sha256 fe8d2e1ef6da5355779c12a9371d3d4d4fe627b817ba949050e27bf2f525f5a3 raspberrypi-usbboot-cd6896cbafabad02fef44c815579a91dccd8e04e.tar.gz
# License files
sha256 b40930bbcf80744c86c46a12bc9da056641d722716c378f5659b9e555ef833e1 LICENSE
@@ -4,7 +4,7 @@
#
################################################################################
-RASPBERRYPI_USBBOOT_VERSION = 20221215-105525
+RASPBERRYPI_USBBOOT_VERSION = cd6896cbafabad02fef44c815579a91dccd8e04e
RASPBERRYPI_USBBOOT_SITE = \
$(call github,raspberrypi,usbboot,$(RASPBERRYPI_USBBOOT_VERSION))
RASPBERRYPI_USBBOOT_LICENSE = Apache-2.0
This commit explicitly mentioned for latest EEPROM firmware version (1.20240605) support. Even though the current DTB firmware version is 1.20240529, there is no known issue for earlier DTB version according to its issue tracker and my last personal experience. Signed-off-by: Athaariq Ardhiansyah <foss@athaariq.my.id> --- Changes v1 -> v2: - Fix missing description due to terminal issue - Use the latest commit instead of the latest tag Changes v2 -> v3: - Update the commit title - Add more explanation on commit description Changes v4 -> v5: - Re-bump from 4a3d311 to cd6896c - Fixed my shameful mistake on the patch, sorry Fiona and other contributors :( --- ...1-Makefile-allow-passing-CFLAGS-LDFLAGS.patch | 16 +++++++++------- .../raspberrypi-usbboot/raspberrypi-usbboot.hash | 2 +- .../raspberrypi-usbboot/raspberrypi-usbboot.mk | 2 +- 3 files changed, 11 insertions(+), 9 deletions(-)