mbox series

[0/3] hw/mips/jazz: Rework the NIC init code

Message ID 20230825175123.624114-1-thuth@redhat.com
Headers show
Series hw/mips/jazz: Rework the NIC init code | expand

Message

Thomas Huth Aug. 25, 2023, 5:51 p.m. UTC
The NIC init code of the jazz machines is rather cumbersome, with
a for-loop around it that is always left after the first iteration.
This patch series reworks this a little bit to make the code more
readable and shorter.

Thomas Huth (3):
  hw/mips/jazz: Remove the big_endian variable
  hw/mips/jazz: Move the NIC init code into a separate function
  hw/mips/jazz: Simplify the NIC setup code

 hw/mips/jazz.c | 89 +++++++++++++++++++++++---------------------------
 1 file changed, 40 insertions(+), 49 deletions(-)

Comments

Michael Tokarev Sept. 1, 2023, 10:15 a.m. UTC | #1
25.08.2023 20:51, Thomas Huth wrote:
> The NIC init code of the jazz machines is rather cumbersome, with
> a for-loop around it that is always left after the first iteration.
> This patch series reworks this a little bit to make the code more
> readable and shorter.
> 
> Thomas Huth (3):
>    hw/mips/jazz: Remove the big_endian variable
>    hw/mips/jazz: Move the NIC init code into a separate function
>    hw/mips/jazz: Simplify the NIC setup code

Thomas, after comments for "hw/mips/jazz: Remove the big_endian variable",
will you respin?

Thanks!

/mjt
Thomas Huth Sept. 7, 2023, 11:37 a.m. UTC | #2
On 01/09/2023 12.15, Michael Tokarev wrote:
> 25.08.2023 20:51, Thomas Huth wrote:
>> The NIC init code of the jazz machines is rather cumbersome, with
>> a for-loop around it that is always left after the first iteration.
>> This patch series reworks this a little bit to make the code more
>> readable and shorter.
>>
>> Thomas Huth (3):
>>    hw/mips/jazz: Remove the big_endian variable
>>    hw/mips/jazz: Move the NIC init code into a separate function
>>    hw/mips/jazz: Simplify the NIC setup code
> 
> Thomas, after comments for "hw/mips/jazz: Remove the big_endian variable",
> will you respin?

I've now sent a patch to clean up that ugliness with TARGET_BIG_ENDIAN first:

https://lore.kernel.org/qemu-devel/20230907113500.185276-1-thuth@redhat.com/

Once that has been accepted, I'll respin the other patches.

  Thomas