diff mbox series

[1/3] dtimg/am57xx_evm_defconfig: Rename dtimg to adtimg

Message ID 20191224165108.2836-2-erosca@de.adit-jv.com
State Accepted
Commit b84acf10565af1578e68c533a36e629fe8b8e84a
Delegated to: Tom Rini
Headers show
Series cmd: dtimg: Rename to adtimg and refactor usage style | expand

Commit Message

Eugeniu Rosca Dec. 24, 2019, 4:51 p.m. UTC
Rename the existing 'dtimg' command to 'adtimg', in order to:
 - Suggest the Android origins and scope
 - Be consistent with the upcoming 'abootimg' command (naming
   suggested by Simon [*])

The change in _not_ backward compatible, but its benefits outweigh its
downsides, given that we don't expect active users of 'dtimg' today.

Perform the rename in several steps:
 1. Rename *.c file and Kconfig symbol. This should allow
    'git log --follow' to properly track the history of 'adtimg.c'
 2. 's/dtimg/adtimg/g' in the internal namespace of 'adtimg.c'

ELF comparison [**] before and after shows no functional change.

[*] https://patchwork.ozlabs.org/patch/1182212/#2291600
[**] diff -u <(objdump -d cmd/dtimg.o) <(objdump -d cmd/adtimg.o)

Cc: Tom Rini <trini@konsulko.com>
Cc: Sam Protsenko <semen.protsenko@linaro.org>
Cc: Simon Glass <sjg@chromium.org>
Signed-off-by: Eugeniu Rosca <erosca@de.adit-jv.com>
---
 cmd/Kconfig                         | 4 ++--
 cmd/Makefile                        | 2 +-
 cmd/{dtimg.c => adtimg.c}           | 0
 common/Makefile                     | 2 +-
 configs/am57xx_evm_defconfig        | 2 +-
 configs/am57xx_hs_evm_defconfig     | 2 +-
 configs/am57xx_hs_evm_usb_defconfig | 2 +-
 7 files changed, 7 insertions(+), 7 deletions(-)
 rename cmd/{dtimg.c => adtimg.c} (100%)

Comments

Simon Glass Jan. 7, 2020, 4:49 p.m. UTC | #1
On Tue, 24 Dec 2019 at 09:51, Eugeniu Rosca <roscaeugeniu@gmail.com> wrote:
>
> Rename the existing 'dtimg' command to 'adtimg', in order to:
>  - Suggest the Android origins and scope
>  - Be consistent with the upcoming 'abootimg' command (naming
>    suggested by Simon [*])
>
> The change in _not_ backward compatible, but its benefits outweigh its
> downsides, given that we don't expect active users of 'dtimg' today.
>
> Perform the rename in several steps:
>  1. Rename *.c file and Kconfig symbol. This should allow
>     'git log --follow' to properly track the history of 'adtimg.c'
>  2. 's/dtimg/adtimg/g' in the internal namespace of 'adtimg.c'
>
> ELF comparison [**] before and after shows no functional change.
>
> [*] https://patchwork.ozlabs.org/patch/1182212/#2291600
> [**] diff -u <(objdump -d cmd/dtimg.o) <(objdump -d cmd/adtimg.o)
>
> Cc: Tom Rini <trini@konsulko.com>
> Cc: Sam Protsenko <semen.protsenko@linaro.org>
> Cc: Simon Glass <sjg@chromium.org>
> Signed-off-by: Eugeniu Rosca <erosca@de.adit-jv.com>
> ---
>  cmd/Kconfig                         | 4 ++--
>  cmd/Makefile                        | 2 +-
>  cmd/{dtimg.c => adtimg.c}           | 0
>  common/Makefile                     | 2 +-
>  configs/am57xx_evm_defconfig        | 2 +-
>  configs/am57xx_hs_evm_defconfig     | 2 +-
>  configs/am57xx_hs_evm_usb_defconfig | 2 +-
>  7 files changed, 7 insertions(+), 7 deletions(-)
>  rename cmd/{dtimg.c => adtimg.c} (100%)
>

Reviewed-by: Simon Glass<sjg@chromium.org>
Eugeniu Rosca Jan. 7, 2020, 5:13 p.m. UTC | #2
Hi Simon,

On Tue, Jan 07, 2020 at 09:49:45AM -0700, Simon Glass wrote:
> On Tue, 24 Dec 2019 at 09:51, Eugeniu Rosca <roscaeugeniu@gmail.com> wrote:
> >
> > Rename the existing 'dtimg' command to 'adtimg', in order to:
> >  - Suggest the Android origins and scope
> >  - Be consistent with the upcoming 'abootimg' command (naming
> >    suggested by Simon [*])
> >
> > The change in _not_ backward compatible, but its benefits outweigh its
> > downsides, given that we don't expect active users of 'dtimg' today.
> >
> > Perform the rename in several steps:
> >  1. Rename *.c file and Kconfig symbol. This should allow
> >     'git log --follow' to properly track the history of 'adtimg.c'
> >  2. 's/dtimg/adtimg/g' in the internal namespace of 'adtimg.c'
> >
> > ELF comparison [**] before and after shows no functional change.
> >
> > [*] https://patchwork.ozlabs.org/patch/1182212/#2291600
> > [**] diff -u <(objdump -d cmd/dtimg.o) <(objdump -d cmd/adtimg.o)
> >
> > Cc: Tom Rini <trini@konsulko.com>
> > Cc: Sam Protsenko <semen.protsenko@linaro.org>
> > Cc: Simon Glass <sjg@chromium.org>
> > Signed-off-by: Eugeniu Rosca <erosca@de.adit-jv.com>
> > ---
> >  cmd/Kconfig                         | 4 ++--
> >  cmd/Makefile                        | 2 +-
> >  cmd/{dtimg.c => adtimg.c}           | 0
> >  common/Makefile                     | 2 +-
> >  configs/am57xx_evm_defconfig        | 2 +-
> >  configs/am57xx_hs_evm_defconfig     | 2 +-
> >  configs/am57xx_hs_evm_usb_defconfig | 2 +-
> >  7 files changed, 7 insertions(+), 7 deletions(-)
> >  rename cmd/{dtimg.c => adtimg.c} (100%)
> >
> 
> Reviewed-by: Simon Glass<sjg@chromium.org>

Happy new year and thank you very much for the review!
Do you see any blocking points in the other patches from this series?
 - https://patchwork.ozlabs.org/patch/1215258/
 - https://patchwork.ozlabs.org/patch/1215259/

If not, would you kindly provide your Reviewed-by signature?
This would unblock Sam with the recent 'abootimg' series:
 - https://patchwork.ozlabs.org/cover/1215282/

This would also unblock me with some upcoming adtimg patches.
Thanks in advance for your feedback!
Tom Rini Jan. 10, 2020, 9:50 p.m. UTC | #3
On Tue, Dec 24, 2019 at 05:51:06PM +0100, Eugeniu Rosca wrote:

> Rename the existing 'dtimg' command to 'adtimg', in order to:
>  - Suggest the Android origins and scope
>  - Be consistent with the upcoming 'abootimg' command (naming
>    suggested by Simon [*])
> 
> The change in _not_ backward compatible, but its benefits outweigh its
> downsides, given that we don't expect active users of 'dtimg' today.
> 
> Perform the rename in several steps:
>  1. Rename *.c file and Kconfig symbol. This should allow
>     'git log --follow' to properly track the history of 'adtimg.c'
>  2. 's/dtimg/adtimg/g' in the internal namespace of 'adtimg.c'
> 
> ELF comparison [**] before and after shows no functional change.
> 
> [*] https://patchwork.ozlabs.org/patch/1182212/#2291600
> [**] diff -u <(objdump -d cmd/dtimg.o) <(objdump -d cmd/adtimg.o)
> 
> Cc: Tom Rini <trini@konsulko.com>
> Signed-off-by: Eugeniu Rosca <erosca@de.adit-jv.com>
> Reviewed-by: Simon Glass<sjg@chromium.org>
> Reviewed-by: Sam Protsenko <semen.protsenko@linaro.org>

Applied to u-boot/master, thanks!
diff mbox series

Patch

diff --git a/cmd/Kconfig b/cmd/Kconfig
index 1e4cf146c509..f63adbdc3a31 100644
--- a/cmd/Kconfig
+++ b/cmd/Kconfig
@@ -348,8 +348,8 @@  config CMD_BOOTMENU
 	help
 	  Add an ANSI terminal boot menu command.
 
-config CMD_DTIMG
-	bool "dtimg"
+config CMD_ADTIMG
+	bool "adtimg"
 	help
 	  Android DTB/DTBO image manipulation commands. Read dtb/dtbo files from
 	  image into RAM, dump image structure information, etc. Those dtb/dtbo
diff --git a/cmd/Makefile b/cmd/Makefile
index 3ac710454652..c17ee20b25c6 100644
--- a/cmd/Makefile
+++ b/cmd/Makefile
@@ -47,7 +47,7 @@  obj-$(CONFIG_CMD_SOUND) += sound.o
 ifdef CONFIG_POST
 obj-$(CONFIG_CMD_DIAG) += diag.o
 endif
-obj-$(CONFIG_CMD_DTIMG) += dtimg.o
+obj-$(CONFIG_CMD_ADTIMG) += adtimg.o
 obj-$(CONFIG_CMD_ECHO) += echo.o
 obj-$(CONFIG_ENV_IS_IN_EEPROM) += eeprom.o
 obj-$(CONFIG_CMD_EEPROM) += eeprom.o
diff --git a/cmd/dtimg.c b/cmd/adtimg.c
similarity index 100%
rename from cmd/dtimg.c
rename to cmd/adtimg.c
diff --git a/common/Makefile b/common/Makefile
index 302d8beaf356..029cc0f2ce6b 100644
--- a/common/Makefile
+++ b/common/Makefile
@@ -117,7 +117,7 @@  obj-$(CONFIG_IO_TRACE) += iotrace.o
 obj-y += memsize.o
 obj-y += stdio.o
 
-obj-$(CONFIG_CMD_DTIMG) += image-android-dt.o
+obj-$(CONFIG_CMD_ADTIMG) += image-android-dt.o
 
 ifdef CONFIG_CMD_EEPROM_LAYOUT
 obj-y += eeprom/eeprom_field.o eeprom/eeprom_layout.o
diff --git a/configs/am57xx_evm_defconfig b/configs/am57xx_evm_defconfig
index ae183e9b562c..0c6a2e9193b9 100644
--- a/configs/am57xx_evm_defconfig
+++ b/configs/am57xx_evm_defconfig
@@ -29,7 +29,7 @@  CONFIG_SPL_OS_BOOT=y
 CONFIG_SPL_SPI_LOAD=y
 CONFIG_SYS_SPI_U_BOOT_OFFS=0x40000
 CONFIG_SPL_YMODEM_SUPPORT=y
-CONFIG_CMD_DTIMG=y
+CONFIG_CMD_ADTIMG=y
 CONFIG_CMD_SPL=y
 CONFIG_CMD_BCB=y
 # CONFIG_CMD_FLASH is not set
diff --git a/configs/am57xx_hs_evm_defconfig b/configs/am57xx_hs_evm_defconfig
index 800ec6c70b92..3c57dfb031a9 100644
--- a/configs/am57xx_hs_evm_defconfig
+++ b/configs/am57xx_hs_evm_defconfig
@@ -32,7 +32,7 @@  CONFIG_SPL_DMA_SUPPORT=y
 # CONFIG_SPL_NAND_SUPPORT is not set
 CONFIG_SPL_SPI_LOAD=y
 CONFIG_SYS_SPI_U_BOOT_OFFS=0x40000
-CONFIG_CMD_DTIMG=y
+CONFIG_CMD_ADTIMG=y
 CONFIG_CMD_BCB=y
 # CONFIG_CMD_FLASH is not set
 # CONFIG_CMD_SETEXPR is not set
diff --git a/configs/am57xx_hs_evm_usb_defconfig b/configs/am57xx_hs_evm_usb_defconfig
index f2cbf2fe2ba1..87f391c2b029 100644
--- a/configs/am57xx_hs_evm_usb_defconfig
+++ b/configs/am57xx_hs_evm_usb_defconfig
@@ -37,7 +37,7 @@  CONFIG_SYS_SPI_U_BOOT_OFFS=0x40000
 CONFIG_SPL_USB_GADGET=y
 CONFIG_SPL_DFU=y
 CONFIG_SPL_YMODEM_SUPPORT=y
-CONFIG_CMD_DTIMG=y
+CONFIG_CMD_ADTIMG=y
 CONFIG_CMD_BCB=y
 # CONFIG_CMD_FLASH is not set
 # CONFIG_CMD_SETEXPR is not set