diff mbox

[U-Boot,v2,6/8] nios2: define _end in link script

Message ID 1441369343-4638-7-git-send-email-thomas@wytron.com.tw
State Superseded
Delegated to: Thomas Chou
Headers show

Commit Message

Thomas Chou Sept. 4, 2015, 12:22 p.m. UTC
Since commit 44c6e6591cb451ae606f8bde71dd5fb7b4002544
"rename _end to __bss_end__" , the _end was removed.
But we need it now for separated device tree control,
ie, CONFIG_OF_SEPARATE .

The _end is used by fdtdec_setup() to find the blob.

Signed-off-by: Thomas Chou <thomas@wytron.com.tw>
---
 arch/nios2/cpu/u-boot.lds | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Marek Vasut Sept. 4, 2015, 2:01 p.m. UTC | #1
On Friday, September 04, 2015 at 02:22:21 PM, Thomas Chou wrote:
> Since commit 44c6e6591cb451ae606f8bde71dd5fb7b4002544
> "rename _end to __bss_end__" , the _end was removed.
> But we need it now for separated device tree control,
> ie, CONFIG_OF_SEPARATE .
> 
> The _end is used by fdtdec_setup() to find the blob.
> 
> Signed-off-by: Thomas Chou <thomas@wytron.com.tw>
> ---
>  arch/nios2/cpu/u-boot.lds | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/arch/nios2/cpu/u-boot.lds b/arch/nios2/cpu/u-boot.lds
> index 951785c..535a974 100644
> --- a/arch/nios2/cpu/u-boot.lds
> +++ b/arch/nios2/cpu/u-boot.lds
> @@ -66,6 +66,11 @@ SECTIONS
>  	_edata = .;
>  	PROVIDE (edata = .);
> 
> +	/* _end - This is end of u-boot.bin image.
> +	 * dtb will be appended here to make u-boot-dtb.bin
> +         */
> +	_end = .;

Same comment about the comment as in the previous patch, but otherwise:

Acked-by: Marek Vasut <marex@denx.de>

>  	/* UNINIT DATA - Small uninitialized data is first so it's
>  	 * adjacent to sdata and can be referenced via gp. The normal
>  	 * bss follows. We keep it adjacent to simplify init code.

Best regards,
Marek Vasut
Simon Glass Sept. 4, 2015, 2:09 p.m. UTC | #2
Hi Thomas,

On 4 September 2015 at 06:22, Thomas Chou <thomas@wytron.com.tw> wrote:
> Since commit 44c6e6591cb451ae606f8bde71dd5fb7b4002544
> "rename _end to __bss_end__" , the _end was removed.
> But we need it now for separated device tree control,
> ie, CONFIG_OF_SEPARATE .
>
> The _end is used by fdtdec_setup() to find the blob.
>
> Signed-off-by: Thomas Chou <thomas@wytron.com.tw>
> ---
>  arch/nios2/cpu/u-boot.lds | 5 +++++
>  1 file changed, 5 insertions(+)

Reviewed-by: Simon Glass <sjg@chromium.org>

>
> diff --git a/arch/nios2/cpu/u-boot.lds b/arch/nios2/cpu/u-boot.lds
> index 951785c..535a974 100644
> --- a/arch/nios2/cpu/u-boot.lds
> +++ b/arch/nios2/cpu/u-boot.lds
> @@ -66,6 +66,11 @@ SECTIONS
>         _edata = .;
>         PROVIDE (edata = .);
>
> +       /* _end - This is end of u-boot.bin image.

comment style:

/*
 * _end -

> +        * dtb will be appended here to make u-boot-dtb.bin
> +         */
> +       _end = .;
> +
>         /* UNINIT DATA - Small uninitialized data is first so it's
>          * adjacent to sdata and can be referenced via gp. The normal
>          * bss follows. We keep it adjacent to simplify init code.
> --
> 2.1.4
>

Regards,
Simon
diff mbox

Patch

diff --git a/arch/nios2/cpu/u-boot.lds b/arch/nios2/cpu/u-boot.lds
index 951785c..535a974 100644
--- a/arch/nios2/cpu/u-boot.lds
+++ b/arch/nios2/cpu/u-boot.lds
@@ -66,6 +66,11 @@  SECTIONS
 	_edata = .;
 	PROVIDE (edata = .);
 
+	/* _end - This is end of u-boot.bin image.
+	 * dtb will be appended here to make u-boot-dtb.bin
+         */
+	_end = .;
+
 	/* UNINIT DATA - Small uninitialized data is first so it's
 	 * adjacent to sdata and can be referenced via gp. The normal
 	 * bss follows. We keep it adjacent to simplify init code.