Message ID | 20210924185506.2542588-10-crosa@redhat.com |
---|---|
State | New |
Headers | show |
Series | Acceptance Tests: use Avocado 91.0 features and other improvements | expand |
On Fri, Sep 24, 2021 at 3:58 PM Cleber Rosa <crosa@redhat.com> wrote: > > While it's a good practice to have reusable base classes, in this > specific case there's no other user of the BootXenBase class. > > By unifying the class used in this test, we can improve readability > and have the opportunity to add some future improvements in a clearer > fashion. > > Signed-off-by: Cleber Rosa <crosa@redhat.com> > --- > tests/acceptance/boot_xen.py | 5 +---- > 1 file changed, 1 insertion(+), 4 deletions(-) > Reviewed-by: Willian Rampazzo <willianr@redhat.com>
diff --git a/tests/acceptance/boot_xen.py b/tests/acceptance/boot_xen.py index b5860b7d88..4c14f9e2e7 100644 --- a/tests/acceptance/boot_xen.py +++ b/tests/acceptance/boot_xen.py @@ -18,7 +18,7 @@ from boot_linux_console import LinuxKernelTest -class BootXenBase(LinuxKernelTest): +class BootXen(LinuxKernelTest): """ Boots a Xen hypervisor with a Linux DomU kernel. """ @@ -60,9 +60,6 @@ def launch_xen(self, xen_path): console_pattern = 'VFS: Cannot open root device' wait_for_console_pattern(self, console_pattern, "Panic on CPU 0:") - -class BootXen(BootXenBase): - def test_arm64_xen_411_and_dom0(self): """ :avocado: tags=arch:aarch64
While it's a good practice to have reusable base classes, in this specific case there's no other user of the BootXenBase class. By unifying the class used in this test, we can improve readability and have the opportunity to add some future improvements in a clearer fashion. Signed-off-by: Cleber Rosa <crosa@redhat.com> --- tests/acceptance/boot_xen.py | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-)