Message ID | 20210203172357.1422425-3-crosa@redhat.com |
---|---|
State | New |
Headers | show |
Series | Acceptance Test: introduce base class for Linux based tests | expand |
On 03/02/2021 18.23, Cleber Rosa wrote: > There's no downloading happening on that method, so let's call it > "prepare" instead. While at it, and because of it, the current > "prepare_boot" and "prepare_cloudinit" are also renamed. > > The reasoning here is that "prepare_" methods will just work on the > images, while "set_up_" will make them effective to the VM that will > be launched. Inspiration comes from the "virtiofs_submounts.py" > tests, which this expects to converge more into. > > Signed-off-by: Cleber Rosa <crosa@redhat.com> > --- > tests/acceptance/boot_linux.py | 12 ++++++------ > 1 file changed, 6 insertions(+), 6 deletions(-) Reviewed-by: Thomas Huth <thuth@redhat.com>
Cleber Rosa <crosa@redhat.com> writes: > There's no downloading happening on that method, so let's call it > "prepare" instead. While at it, and because of it, the current > "prepare_boot" and "prepare_cloudinit" are also renamed. > > The reasoning here is that "prepare_" methods will just work on the > images, while "set_up_" will make them effective to the VM that will > be launched. Inspiration comes from the "virtiofs_submounts.py" > tests, which this expects to converge more into. > > Signed-off-by: Cleber Rosa <crosa@redhat.com> Reviewed-by: Alex Bennée <alex.bennee@linaro.org>
On Wed, Feb 03, 2021 at 12:23:37PM -0500, Cleber Rosa wrote: > There's no downloading happening on that method, so let's call it > "prepare" instead. While at it, and because of it, the current > "prepare_boot" and "prepare_cloudinit" are also renamed. > > The reasoning here is that "prepare_" methods will just work on the > images, while "set_up_" will make them effective to the VM that will > be launched. Inspiration comes from the "virtiofs_submounts.py" > tests, which this expects to converge more into. > > Signed-off-by: Cleber Rosa <crosa@redhat.com> > --- > tests/acceptance/boot_linux.py | 12 ++++++------ > 1 file changed, 6 insertions(+), 6 deletions(-) > > diff --git a/tests/acceptance/boot_linux.py b/tests/acceptance/boot_linux.py > index 2ac3e57587..bcd923bb4a 100644 > --- a/tests/acceptance/boot_linux.py > +++ b/tests/acceptance/boot_linux.py > @@ -57,7 +57,7 @@ class BootLinuxBase(Test): > self.cancel('Failed to download/prepare boot image') > return boot.path > > - def download_cloudinit(self, ssh_pubkey=None): > + def prepare_cloudinit(self, ssh_pubkey=None): > self.log.info('Preparing cloudinit image') > try: > cloudinit_iso = os.path.join(self.workdir, 'cloudinit.iso') > @@ -85,15 +85,15 @@ class BootLinux(BootLinuxBase): > super(BootLinux, self).setUp() > self.vm.add_args('-smp', '2') > self.vm.add_args('-m', '1024') > - self.prepare_boot() > - self.prepare_cloudinit(ssh_pubkey) > + self.set_up_boot() > + self.set_up_cloudinit(ssh_pubkey) > > - def prepare_boot(self): > + def set_up_boot(self): > path = self.download_boot() > self.vm.add_args('-drive', 'file=%s' % path) > > - def prepare_cloudinit(self, ssh_pubkey=None): > - cloudinit_iso = self.download_cloudinit(ssh_pubkey) > + def set_up_cloudinit(self, ssh_pubkey=None): > + cloudinit_iso = self.prepare_cloudinit(ssh_pubkey) > self.vm.add_args('-drive', 'file=%s,format=raw' % cloudinit_iso) > > def launch_and_wait(self): > -- > 2.25.4 > Reviewed-by: Beraldo Leal <bleal@redhat.com>
diff --git a/tests/acceptance/boot_linux.py b/tests/acceptance/boot_linux.py index 2ac3e57587..bcd923bb4a 100644 --- a/tests/acceptance/boot_linux.py +++ b/tests/acceptance/boot_linux.py @@ -57,7 +57,7 @@ class BootLinuxBase(Test): self.cancel('Failed to download/prepare boot image') return boot.path - def download_cloudinit(self, ssh_pubkey=None): + def prepare_cloudinit(self, ssh_pubkey=None): self.log.info('Preparing cloudinit image') try: cloudinit_iso = os.path.join(self.workdir, 'cloudinit.iso') @@ -85,15 +85,15 @@ class BootLinux(BootLinuxBase): super(BootLinux, self).setUp() self.vm.add_args('-smp', '2') self.vm.add_args('-m', '1024') - self.prepare_boot() - self.prepare_cloudinit(ssh_pubkey) + self.set_up_boot() + self.set_up_cloudinit(ssh_pubkey) - def prepare_boot(self): + def set_up_boot(self): path = self.download_boot() self.vm.add_args('-drive', 'file=%s' % path) - def prepare_cloudinit(self, ssh_pubkey=None): - cloudinit_iso = self.download_cloudinit(ssh_pubkey) + def set_up_cloudinit(self, ssh_pubkey=None): + cloudinit_iso = self.prepare_cloudinit(ssh_pubkey) self.vm.add_args('-drive', 'file=%s,format=raw' % cloudinit_iso) def launch_and_wait(self):
There's no downloading happening on that method, so let's call it "prepare" instead. While at it, and because of it, the current "prepare_boot" and "prepare_cloudinit" are also renamed. The reasoning here is that "prepare_" methods will just work on the images, while "set_up_" will make them effective to the VM that will be launched. Inspiration comes from the "virtiofs_submounts.py" tests, which this expects to converge more into. Signed-off-by: Cleber Rosa <crosa@redhat.com> --- tests/acceptance/boot_linux.py | 12 ++++++------ 1 file changed, 6 insertions(+), 6 deletions(-)