diff mbox series

[OpenWrt-Devel,1/2] fix make kernel_menuconfig

Message ID mailman.15111.1565142502.19300.openwrt-devel@lists.openwrt.org
State Changes Requested
Delegated to: Petr Štetiar
Headers show
Series [OpenWrt-Devel,1/2] fix make kernel_menuconfig | expand

Commit Message

hurrhnn--- via openwrt-devel Aug. 7, 2019, 1:48 a.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
Hello!

This is part 1 of a patch to fix issue 2423 in Flyspray,
kernel_menuconfig not working. This is not an upstream bug, it is due
to the toolchain missing ncurses. make menuconfig relies on the
/system's/ installation of ncurses, but make kernel_menuconfig invokes
the /toolchain's/ ncurses. ncurses is missing, consequently the
kconfig script can't be linked against it.

This fixes pkg-config in the toolchain. Previously, pkg-config would
expand an environment variable $STAGING_PREFIX, which is not defined,
consequently the attempts variable assignmetn would cause pkg-config
to fail with an error. Right now, anything relying on pkg-config works
only because of sensible defaults and good fortune.

Signed-off-by: Thomas Albers <thomas.gameiro@gmail.com>

--define-variable=exec_prefix=${STAGING_DIR_HOST}
--define-variable=bindir=${STAGING_DIR_HOST}/bin $@

Comments

Petr Štetiar Aug. 7, 2019, 5:59 a.m. UTC | #1
Thomas Albers via openwrt-devel <openwrt-devel@lists.openwrt.org> [2019-08-06 20:48:07]:

Hi,

> The sender domain has a DMARC Reject/Quarantine policy which disallows
> sending mailing list messages using the original "From" header.
> 
> To mitigate this problem, the original message has been wrapped
> automatically by the mailing list software.

FYI patchwork has issue parsing this wrapped emails so this patch wouldn't
apply. Also patch 2/2 didn't hit the mailing list and patchwork as well.

> Date: Tue, 6 Aug 2019 20:48:07 -0500
> From: Thomas Albers <thomas.gameiro@googlemail.com>
> To: openwrt-devel@lists.openwrt.org
> Subject: [PATCH 1/2] fix make kernel_menuconfig
> Message-ID: <CALYGOBU51HmRrwJGmYUxhcYJCg8OOSEUOo+7=T-nuJLk9XnSmQ@mail.gmail.com>
> 
> This fixes pkg-config in the toolchain.

maybe, but it's probably breaking other stuff as well.

>  Previously, pkg-config would expand an environment variable
>  $STAGING_PREFIX, which is not defined,

It is defined:

 include/host-build.mk:  $(1) : export STAGING_PREFIX=$$(HOST_BUILD_PREFIX)
 include/package.mk:  $(1) : export STAGING_PREFIX=$$(STAGING_DIR)/usr

and as you can see the values are different for host/target.

> Right now, anything relying on pkg-config works only because of sensible
> defaults and good fortune.

I don't think so, you probably need to dig into it once more and find out the
real reason for the failure and fix it at the proper place.

-- ynezz
diff mbox series

Patch

diff --git a/tools/pkg-config/files/pkg-config
b/tools/pkg-config/files/pkg-config
index 82cc74ffcb..b36a8c62f5 100755
--- a/tools/pkg-config/files/pkg-config
+++ b/tools/pkg-config/files/pkg-config
@@ -1,3 +1,3 @@ 
 #!/bin/sh

-pkg-config.real --define-variable=prefix=${STAGING_PREFIX}
--define-variable=exec_prefix=${STAGING_PREFIX}
--define-variable=bindir=${STAGING_PREFIX}/bin $@
+pkg-config.real --define-variable=prefix=${STAGING_DIR_HOST}