diff mbox series

[4/5] qoriq: m300: Fix device names, to factory naming.

Message ID mailman.133963.1728987224.1280.openwrt-devel@lists.openwrt.org
State New
Headers show
Series None | expand

Commit Message

Evan Jobling Oct. 15, 2024, 10:13 a.m. UTC
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
Initial port naming does not match factory.
This required changes to preinit.

Initial dsa port names match upstream documentation
sw0p<port> for consistency.
The choice was arbitrary given it is unknown
what factory used.
The only conflicts are p0 and p1 which were
previously named sweth3 / sweth4, but all
ports of the switch were relabelled in
device tree.

What was previously eth3 and eth4 are renamed
conduit1 and conduit0.
This matches upstream terminology but are an
arbitrary choice given it is unknown what
factory used.

Switch ports sweth3-sweth7 are renamed
eth3-eth7 per factory by using new preinit
label pass.

Device image compat update as breaking changes to
interface naming.

Signed-off-by: Evan Jobling <evan.jobling@mslsc.com.au>
---
 .../qoriq/base-files/etc/board.d/02_network      | 16 +++++++++++++---
 .../base-files/etc/board.d/05_compat-version     |  2 +-
 .../boot/dts/fsl/watchguard-firebox-m300.dts     | 10 +++++-----
 target/linux/qoriq/image/generic.mk              |  4 ++--
 4 files changed, 21 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/target/linux/qoriq/base-files/etc/board.d/02_network b/target/linux/qoriq/base-files/etc/board.d/02_network
index 12adca2a8d..b1f3b2c0ee 100644
--- a/target/linux/qoriq/base-files/etc/board.d/02_network
+++ b/target/linux/qoriq/base-files/etc/board.d/02_network
@@ -19,9 +19,19 @@  watchguard,firebox-m300)
 	ucidef_set_interfaces_lan_wan "eth1" "eth0"
 	wg_set_opt_interface "eth2" "2"
 
-	for sweth in $(find /sys/class/net/ -name 'sweth*' -print); do
-		device="$(basename "$sweth")"
-		wg_set_opt_interface "$device" "${device#sweth}"
+        ucidef_set_network_device_path "conduit0" "platform/ffe000000.soc/ffe400000.fman/ffe4e6000.ethernet"
+        ucidef_set_network_device_path "conduit1" "platform/ffe000000.soc/ffe400000.fman/ffe4e4000.ethernet"
+
+        ucidef_set_network_device_label "sw0p0" "eth3"
+        ucidef_set_network_device_label "sw0p1" "eth4"
+        ucidef_set_network_device_label "sw0p2" "eth5"
+        ucidef_set_network_device_label "sw0p3" "eth5"
+        ucidef_set_network_device_label "sw0p4" "eth7"
+
+
+	for eth in $(find /sys/class/net/ -name 'eth[3-7]' -print); do
+		device="$(basename "$eth")"
+		wg_set_opt_interface "$device" "${device#eth}"
 	done
 
 	;;
diff --git a/target/linux/qoriq/base-files/etc/board.d/05_compat-version b/target/linux/qoriq/base-files/etc/board.d/05_compat-version
index 2036fbcc95..fc9885054a 100644
--- a/target/linux/qoriq/base-files/etc/board.d/05_compat-version
+++ b/target/linux/qoriq/base-files/etc/board.d/05_compat-version
@@ -7,7 +7,7 @@  board_config_update
 
 case "$(board_name)" in
 	watchguard,firebox-m300)
-		ucidef_set_compat_version "1.1"
+		ucidef_set_compat_version "1.2"
 		;;
 esac
 
diff --git a/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts b/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts
index 6628e0eb23..2ab84d0303 100644
--- a/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts
+++ b/target/linux/qoriq/files/arch/powerpc/boot/dts/fsl/watchguard-firebox-m300.dts
@@ -271,7 +271,7 @@ 
 
 			port@0 {
 				reg = <0>;
-				label = "sweth3";
+				label = "sw0p0";
 				phy-handle = <&switch0phy0>;
 
 				nvmem-cells = <&macaddr_cfg_186c 0>;
@@ -280,7 +280,7 @@ 
 
 			port@1 {
 				reg = <1>;
-				label = "sweth4";
+				label = "sw0p1";
 				phy-handle = <&switch0phy1>;
 
 				nvmem-cells = <&macaddr_cfg_1880 0>;
@@ -289,7 +289,7 @@ 
 
 			port@2 {
 				reg = <2>;
-				label = "sweth5";
+				label = "sw0p2";
 				phy-handle = <&switch0phy2>;
 
 				nvmem-cells = <&macaddr_cfg_1894 0>;
@@ -298,7 +298,7 @@ 
 
 			port@3 {
 				reg = <3>;
-				label = "sweth6";
+				label = "sw0p3";
 				phy-handle = <&switch0phy3>;
 
 				nvmem-cells = <&macaddr_cfg_18a8 0>;
@@ -307,7 +307,7 @@ 
 
 			port@4 {
 				reg = <4>;
-				label = "sweth7";
+				label = "sw0p4";
 				phy-handle = <&switch0phy4>;
 
 				nvmem-cells = <&macaddr_cfg_18bc 0>;
diff --git a/target/linux/qoriq/image/generic.mk b/target/linux/qoriq/image/generic.mk
index d2b60d2296..951afe49ff 100644
--- a/target/linux/qoriq/image/generic.mk
+++ b/target/linux/qoriq/image/generic.mk
@@ -2,8 +2,8 @@  define Device/watchguard_firebox-m300
   DEVICE_VENDOR := WatchGuard
   DEVICE_MODEL := Firebox M300
   DEVICE_COMPAT_MESSAGE := \
-	Kernel switched to FIT uImage. Update U-Boot environment.
-  DEVICE_COMPAT_VERSION := 1.1
+	Device port names (sweth3-sweth7) changed to factory names (eth3-eth7). Conduit ports renamed. Clear or update your config.	
+  DEVICE_COMPAT_VERSION := 1.2
   DEVICE_DTS_DIR := $(DTS_DIR)/fsl
   DEVICE_PACKAGES := \
 	kmod-gpio-button-hotplug kmod-hwmon-w83793 kmod-leds-gpio kmod-ptp-qoriq \