diff mbox series

ramips: fix image recipe for ASUS RT-N56U

Message ID TYCP286MB08952FAACDFA234C5E052131BCD82@TYCP286MB0895.JPNP286.PROD.OUTLOOK.COM
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series ramips: fix image recipe for ASUS RT-N56U | expand

Commit Message

Shiji Yang July 6, 2024, 10:27 a.m. UTC
From: Shiji Yang <yangshiji66@qq.com>

The OpenWrt image metadata includes checksum validation. Therefore,
it must be generated at the end.

Fixes: https://github.com/openwrt/openwrt/issues/9045
Fixes: https://github.com/openwrt/openwrt/issues/13674
Signed-off-by: Shiji Yang <yangshiji66@qq.com>
---
 target/linux/ramips/image/rt3883.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 0430099296..1728f84444 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -8,7 +8,8 @@  endef
 define Device/asus_rt-n56u
   SOC := rt3662
   IMAGE_SIZE := 7872k
-  IMAGE/sysupgrade.bin += | mkrtn56uimg -s
+  IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | check-size | \
+	mkrtn56uimg -s | append-metadata
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := RT-N56U
   DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2