diff mbox

[OpenWrt-Devel,RESEND] package/binutils: actually support the target toolchain

Message ID E1Y8XHD-0001nx-Dq@stardust.g4.wien.funkfeuer.at
State Accepted
Headers show

Commit Message

Harald Geyer Jan. 6, 2015, 4:46 p.m. UTC
This fixes a bug, where ld on ARM EABI platforms expects OABI code.

Signed-off-by: Harald Geyer <harald@ccbib.org>
---
Resending as I didn't get many comments the first time.
This has been tested by me on mxs and by nwf on kirkwood.

 package/devel/binutils/Makefile |    2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)
diff mbox

Patch

diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index cf77690..c5a0717 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -69,6 +69,8 @@  endef
 TARGET_CFLAGS += $(FPIC) -Wno-unused-value
 
 CONFIGURE_ARGS += \
+	--host=$(REAL_GNU_TARGET_NAME) \
+	--target=$(REAL_GNU_TARGET_NAME) \
 	--enable-shared \
 	--enable-install-libiberty \
 	--enable-install-libbfd