diff mbox

[OpenWrt-Devel,packages] kernel: kmod-w1 - missing netlink support

Message ID CADPUUGFiAfQvmH799LDWvHtgK0c5xqKbTMbNJYrReT5q4FcE9g@mail.gmail.com
State Changes Requested
Headers show

Commit Message

Daniel Wiegert Jan. 1, 2015, 11:39 p.m. UTC
- updated kernel options to include netlink support. Without netlink
support kmod-w1 wont work with owfs / owserver with --w1 flag (
kernel-managed bus masters ) kmod-w1 should really have netlink support!
I've sent this patch one year ago - patchwork.openwrt.org/patch/4679/ still
waiting for it.

Comments

Hartmut Knaack Jan. 2, 2015, 8:22 p.m. UTC | #1
Hi Daniel,
your patch does not comply to the required format. Please read through
https://dev.openwrt.org/wiki/SubmittingPatches (especially section 10)
and http://kerneltrap.org/Linux/Email_Clients_and_Patches before submitting
again.
Thanks,

Hartmut

Daniel Wiegert schrieb am 02.01.2015 um 00:39:
> - updated kernel options to include netlink support. Without netlink support kmod-w1 wont work with owfs / owserver with --w1 flag ( kernel-managed bus masters ) kmod-w1 should really have netlink support!
> I've sent this patch one year ago - patchwork.openwrt.org/patch/4679/ <http://patchwork.openwrt.org/patch/4679/> still waiting for it.
> 
> diff --git a/package/kernel/linux/
> modules/w1.mk <http://w1.mk> b/package/kernel/linux/modules/w1.mk <http://w1.mk>
> index c2fc649..dba1fed 100644
> --- a/package/kernel/linux/modules/w1.mk <http://w1.mk>
> +++ b/package/kernel/linux/modules/w1.mk <http://w1.mk>
> @@ -1,5 +1,5 @@
> #
> -# Copyright (C) 2008-2010 OpenWrt.org
> +# Copyright (C) 2008-2013 OpenWrt.org
> #
> # This is free software, licensed under the GNU General Public License v2.
> # See /LICENSE for more information.
> @@ -12,8 +12,13 @@ W1_SLAVES_DIR:=$(LINUX_DIR)/drivers/w1/slaves
> define KernelPackage/w1
> SUBMENU:=$(W1_MENU)
> TITLE:=Dallas's 1-wire support
> - KCONFIG:=CONFIG_W1
> - FILES:=$(LINUX_DIR)/drivers/w1/wire.ko
> + KCONFIG:= \
> + CONFIG_W1 \
> + CONFIG_W1_CON=y \
> + CONFIG_CONNECTOR
> + FILES:= \
> + $(LINUX_DIR)/drivers/w1/wire.ko \
> + $(LINUX_DIR)/drivers/connector/cn.ko
> endef
> 
> define KernelPackage/w1/description
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
diff mbox

Patch

diff --git a/package/kernel/linux/
modules/w1.mk b/package/kernel/linux/modules/w1.mk
index c2fc649..dba1fed 100644
--- a/package/kernel/linux/modules/w1.mk
+++ b/package/kernel/linux/modules/w1.mk
@@ -1,5 +1,5 @@ 
#
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,8 +12,13 @@  W1_SLAVES_DIR:=$(LINUX_DIR)/drivers/w1/slaves
define KernelPackage/w1
SUBMENU:=$(W1_MENU)
TITLE:=Dallas's 1-wire support
- KCONFIG:=CONFIG_W1
- FILES:=$(LINUX_DIR)/drivers/w1/wire.ko
+ KCONFIG:= \
+ CONFIG_W1 \
+ CONFIG_W1_CON=y \
+ CONFIG_CONNECTOR
+ FILES:= \
+ $(LINUX_DIR)/drivers/w1/wire.ko \
+ $(LINUX_DIR)/drivers/connector/cn.ko
endef

define KernelPackage/w1/description