diff mbox

[OpenWrt-Devel] sound: cleanup by removing unsupported Kernel cases

Message ID 55519F0A.7060908@web.de
State Accepted
Headers show

Commit Message

Dirk Neukirchen May 12, 2015, 6:34 a.m. UTC
Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
---
 package/kernel/linux/modules/sound.mk | 10 ----------
 1 file changed, 10 deletions(-)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 54bc30a..3cf9834 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -32,21 +32,11 @@  SOUNDCORE_FILES ?= \
 	$(LINUX_DIR)/sound/core/oss/snd-pcm-oss.ko \
 	$(LINUX_DIR)/sound/core/snd-compress.ko
 
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
 SOUNDCORE_LOAD += \
 	$(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
 
 SOUNDCORE_FILES += \
 	$(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
-endif
-
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.14.0)),1)
-SOUNDCORE_LOAD += \
-	snd-page-alloc
-
-SOUNDCORE_FILES += \
-	$(LINUX_DIR)/sound/core/snd-page-alloc.ko
-endif
 
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)