diff mbox

[OpenWrt-Devel] kernel: add rtl8723au driver (staging)

Message ID 5520F097.3030602@web.de
State Rejected
Headers show

Commit Message

Dirk Neukirchen April 5, 2015, 8:21 a.m. UTC
- move config symbol to separate package (Why was it there in the first place?)
- 8723au might be used in some USB sticks or on some sunxi boards

compile tested only

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
---
 package/kernel/linux/modules/wireless.mk | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)

Comments

Dirk Neukirchen April 6, 2015, 9:38 a.m. UTC | #1
On 05.04.2015 10:21, Dirk Neukirchen wrote:
> - move config symbol to separate package (Why was it there in the first place?)
> - 8723au might be used in some USB sticks or on some sunxi boards
> 
> compile tested only
> 
> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
> ---
>  package/kernel/linux/modules/wireless.mk | 22 +++++++++++++++++++++-
>  1 file changed, 21 insertions(+), 1 deletion(-)
> 
> diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
> index 8989d79..7ba7b28 100644
> --- a/package/kernel/linux/modules/wireless.mk
> +++ b/package/kernel/linux/modules/wireless.mk
> @@ -114,7 +114,6 @@ define KernelPackage/net-rtl8188eu
>    KCONFIG:=\
>  	CONFIG_STAGING=y \
>  	CONFIG_R8188EU \
> -	CONFIG_R8723AU \
>  	CONFIG_88EU_AP_MODE=y \
>  	CONFIG_88EU_P2P=n
>    FILES:=$(LINUX_DIR)/drivers/staging/rtl8188eu/r8188eu.ko
> @@ -127,6 +126,27 @@ endef
>  
>  $(eval $(call KernelPackage,net-rtl8188eu))
>  
> +
> +define KernelPackage/net-rtl8723au
> +  SUBMENU:=$(WIRELESS_MENU)
> +  TITLE:=RTL8723AU support (staging)
> +  DEPENDS:=@!LINUX_3_10 @USB_SUPPORT +@DRIVER_WEXT_SUPPORT +r8188eu-firmware +kmod-usb-core
> +  KCONFIG:=\
> +        CONFIG_STAGING=y \
> +        CONFIG_R8723AU \
> +        CONFIG_8723AU_AP_MODE=y \
> +        CONFIG_8723AU_BT_COEXIST=y
> +  FILES:=$(LINUX_DIR)/drivers/staging/rtl8723au/r8723au.ko
> +  AUTOLOAD:=$(call AutoProbe,r8723au)
> +endef
> +
> +define KernelPackage/net-rtl8723au/description
> + Kernel modules for RealTek RTL8723AU support
> +endef
> +
> +$(eval $(call KernelPackage,net-rtl8723au))
> +
> +
>  define KernelPackage/net-rtl8192su
>    SUBMENU:=$(WIRELESS_MENU)
>    TITLE:=RTL8192SU support (staging)
> 

Since this was rejected - should I resend something ? 
Like removing the CONFIG_R8723AU symbol ?
Or just write tickets in the future regarding kernel config symbols issues ?
Is there other "secret" work somewhere in some queue that deletes all staging drivers or moves them to backports/compat-wireless ?
John Crispin April 6, 2015, 9:43 a.m. UTC | #2
On 06/04/2015 11:38, Dirk Neukirchen wrote:
> On 05.04.2015 10:21, Dirk Neukirchen wrote:
>> - move config symbol to separate package (Why was it there in the first place?)
>> - 8723au might be used in some USB sticks or on some sunxi boards
>>
>> compile tested only
>>
>> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
>> ---
>>  package/kernel/linux/modules/wireless.mk | 22 +++++++++++++++++++++-
>>  1 file changed, 21 insertions(+), 1 deletion(-)
>>
>> diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
>> index 8989d79..7ba7b28 100644
>> --- a/package/kernel/linux/modules/wireless.mk
>> +++ b/package/kernel/linux/modules/wireless.mk
>> @@ -114,7 +114,6 @@ define KernelPackage/net-rtl8188eu
>>    KCONFIG:=\
>>  	CONFIG_STAGING=y \
>>  	CONFIG_R8188EU \
>> -	CONFIG_R8723AU \
>>  	CONFIG_88EU_AP_MODE=y \
>>  	CONFIG_88EU_P2P=n
>>    FILES:=$(LINUX_DIR)/drivers/staging/rtl8188eu/r8188eu.ko
>> @@ -127,6 +126,27 @@ endef
>>  
>>  $(eval $(call KernelPackage,net-rtl8188eu))
>>  
>> +
>> +define KernelPackage/net-rtl8723au
>> +  SUBMENU:=$(WIRELESS_MENU)
>> +  TITLE:=RTL8723AU support (staging)
>> +  DEPENDS:=@!LINUX_3_10 @USB_SUPPORT +@DRIVER_WEXT_SUPPORT +r8188eu-firmware +kmod-usb-core
>> +  KCONFIG:=\
>> +        CONFIG_STAGING=y \
>> +        CONFIG_R8723AU \
>> +        CONFIG_8723AU_AP_MODE=y \
>> +        CONFIG_8723AU_BT_COEXIST=y
>> +  FILES:=$(LINUX_DIR)/drivers/staging/rtl8723au/r8723au.ko
>> +  AUTOLOAD:=$(call AutoProbe,r8723au)
>> +endef
>> +
>> +define KernelPackage/net-rtl8723au/description
>> + Kernel modules for RealTek RTL8723AU support
>> +endef
>> +
>> +$(eval $(call KernelPackage,net-rtl8723au))
>> +
>> +
>>  define KernelPackage/net-rtl8192su
>>    SUBMENU:=$(WIRELESS_MENU)
>>    TITLE:=RTL8192SU support (staging)
>>
> 
> Since this was rejected - should I resend something ? 
yes
> Like removing the CONFIG_R8723AU symbol ?
yes
> Or just write tickets in the future regarding kernel config symbols issues ?
up to you
> Is there other "secret" work somewhere in some queue that deletes all staging drivers or moves them to backports/compat-wireless ?
yes, in the cave where the wizard lives ;)

i was already informed of the *big* problem because 1 patch was
incorrectly marked as rejected, don't take it personal ;)

in general all wireless drivers should be manged via compat wireless. i
was looking at wireless.mk and am considering to move all of them to
mac80211. to me the file seems wrong, even if i merged one of the
entries myself at some point.
John Crispin April 6, 2015, 1:06 p.m. UTC | #3
On 06/04/2015 11:38, Dirk Neukirchen wrote:
> On 05.04.2015 10:21, Dirk Neukirchen wrote:
>> - move config symbol to separate package (Why was it there in the first place?)
>> - 8723au might be used in some USB sticks or on some sunxi boards
>>
>> compile tested only
>>
>> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
>> ---
>>  package/kernel/linux/modules/wireless.mk | 22 +++++++++++++++++++++-
>>  1 file changed, 21 insertions(+), 1 deletion(-)
>>
>> diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
>> index 8989d79..7ba7b28 100644
>> --- a/package/kernel/linux/modules/wireless.mk
>> +++ b/package/kernel/linux/modules/wireless.mk
>> @@ -114,7 +114,6 @@ define KernelPackage/net-rtl8188eu
>>    KCONFIG:=\
>>  	CONFIG_STAGING=y \
>>  	CONFIG_R8188EU \
>> -	CONFIG_R8723AU \
>>  	CONFIG_88EU_AP_MODE=y \
>>  	CONFIG_88EU_P2P=n
>>    FILES:=$(LINUX_DIR)/drivers/staging/rtl8188eu/r8188eu.ko
>> @@ -127,6 +126,27 @@ endef
>>  
>>  $(eval $(call KernelPackage,net-rtl8188eu))
>>  
>> +
>> +define KernelPackage/net-rtl8723au
>> +  SUBMENU:=$(WIRELESS_MENU)
>> +  TITLE:=RTL8723AU support (staging)
>> +  DEPENDS:=@!LINUX_3_10 @USB_SUPPORT +@DRIVER_WEXT_SUPPORT +r8188eu-firmware +kmod-usb-core
>> +  KCONFIG:=\
>> +        CONFIG_STAGING=y \
>> +        CONFIG_R8723AU \
>> +        CONFIG_8723AU_AP_MODE=y \
>> +        CONFIG_8723AU_BT_COEXIST=y
>> +  FILES:=$(LINUX_DIR)/drivers/staging/rtl8723au/r8723au.ko
>> +  AUTOLOAD:=$(call AutoProbe,r8723au)
>> +endef
>> +
>> +define KernelPackage/net-rtl8723au/description
>> + Kernel modules for RealTek RTL8723AU support
>> +endef
>> +
>> +$(eval $(call KernelPackage,net-rtl8723au))
>> +
>> +
>>  define KernelPackage/net-rtl8192su
>>    SUBMENU:=$(WIRELESS_MENU)
>>    TITLE:=RTL8192SU support (staging)
>>
> 
> Since this was rejected - should I resend something ? 
> Like removing the CONFIG_R8723AU symbol ?
> Or just write tickets in the future regarding kernel config symbols issues ?
> Is there other "secret" work somewhere in some queue that deletes all staging drivers or moves them to backports/compat-wireless ?

to shed some more light on this, wireless.mk should only have pre
cfg80211 and staging drivers in it. i will have a go at the patches
tomorrow, unless someone beats me to it, which is unlikley. which stick
with RTL8723AU do you use for testing ?

	John
Dirk Neukirchen April 6, 2015, 1:52 p.m. UTC | #4
On 06.04.2015 15:06, John Crispin wrote:
> 
> 
> On 06/04/2015 11:38, Dirk Neukirchen wrote:
>> On 05.04.2015 10:21, Dirk Neukirchen wrote:
>>> - move config symbol to separate package (Why was it there in the first place?)
>>> - 8723au might be used in some USB sticks or on some sunxi boards
>>>
>>> compile tested only
>>>
>>> Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
>>> ---
 which stick
> with RTL8723AU do you use for testing ?
> 
> 	John
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
> 

see initial commit - I didnt have a stick
I had an issue with config symbols and just saw that symbol appearing in the
wrong section. I googled a little bit and saw only some references from a Lenovo tablet
and sunxi wiki entries.

Because sunxi is a valid OpenWrt target I thought adding a module
makes sense in this case.

https://github.com/lwfinger/rtl8723au_bt mentions dongles with 8723AU

Maybe the easter bunny had sth. to do with hiding this hardware sticks :)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
index 8989d79..7ba7b28 100644
--- a/package/kernel/linux/modules/wireless.mk
+++ b/package/kernel/linux/modules/wireless.mk
@@ -114,7 +114,6 @@  define KernelPackage/net-rtl8188eu
   KCONFIG:=\
 	CONFIG_STAGING=y \
 	CONFIG_R8188EU \
-	CONFIG_R8723AU \
 	CONFIG_88EU_AP_MODE=y \
 	CONFIG_88EU_P2P=n
   FILES:=$(LINUX_DIR)/drivers/staging/rtl8188eu/r8188eu.ko
@@ -127,6 +126,27 @@  endef
 
 $(eval $(call KernelPackage,net-rtl8188eu))
 
+
+define KernelPackage/net-rtl8723au
+  SUBMENU:=$(WIRELESS_MENU)
+  TITLE:=RTL8723AU support (staging)
+  DEPENDS:=@!LINUX_3_10 @USB_SUPPORT +@DRIVER_WEXT_SUPPORT +r8188eu-firmware +kmod-usb-core
+  KCONFIG:=\
+        CONFIG_STAGING=y \
+        CONFIG_R8723AU \
+        CONFIG_8723AU_AP_MODE=y \
+        CONFIG_8723AU_BT_COEXIST=y
+  FILES:=$(LINUX_DIR)/drivers/staging/rtl8723au/r8723au.ko
+  AUTOLOAD:=$(call AutoProbe,r8723au)
+endef
+
+define KernelPackage/net-rtl8723au/description
+ Kernel modules for RealTek RTL8723AU support
+endef
+
+$(eval $(call KernelPackage,net-rtl8723au))
+
+
 define KernelPackage/net-rtl8192su
   SUBMENU:=$(WIRELESS_MENU)
   TITLE:=RTL8192SU support (staging)