diff mbox

[OpenWrt-Devel] kernel: add uinput module

Message ID 551D0786.5030407@web.de
State Accepted
Headers show

Commit Message

Dirk Neukirchen April 2, 2015, 9:10 a.m. UTC
This module is needed for bluetooth audio playback
with pulseaudio 6 and bluez5.

a working guide can be found in the wiki:
http://wiki.openwrt.org/wiki/bluetooth.audio
(additional packages/modifications are required
and submitted to github feeds)

tested with:
Android mobile (Sony Xperia M) as audio source
TI omap BeagleBoard as audio sink

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
---
 package/kernel/linux/modules/input.mk | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index b44136b..86ff33c 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -205,3 +205,21 @@  define KernelPackage/keyboard-imx/description
 endef
 
 $(eval $(call KernelPackage,keyboard-imx))
+
+
+define KernelPackage/input-uinput
+  SUBMENU:=$(INPUT_MODULES_MENU)
+  TITLE:=user input module
+  DEPENDS:=+kmod-input-core
+  KCONFIG:= \
+	CONFIG_INPUT_MISC=y \
+	CONFIG_INPUT_UINPUT
+  FILES:=$(LINUX_DIR)/drivers/input/misc/uinput.ko
+  AUTOLOAD:=$(call AutoProbe,uinput)
+endef
+
+define KernelPackage/input-uinput/description
+  user input modules needed for bluez
+endef
+
+$(eval $(call KernelPackage,input-uinput))