diff mbox series

[01/14] kernel: modules: enable UART variant of Broadcom bluetooth

Message ID 20241029161046.110403-2-tmn505@terefe.re
State New
Headers show
Series Add support for NVIDIA Jetson TX1 DevKit | expand

Commit Message

Tomasz Maciej Nowak Oct. 29, 2024, 3:46 p.m. UTC
From: Tomasz Maciej Nowak <tmn505@gmail.com>

Bunch of SBC integrate SDIO Broadcom BT+WiFi module, but while WiFi uses
SDIO lines, the BT part usually is connected to UART lines, instead of
SDIO, like most would asume, so package module responsible for it to
unlock this feature. Caveat is, this driver needs firmware which isn't
contained in linux-firmware repo, so one needs to find it.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
---
 package/kernel/linux/modules/other.mk | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index bbebcf37ec1a..cadabb8ea31f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -33,6 +33,7 @@  define KernelPackage/bluetooth
   DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +kmod-crypto-cmac +kmod-regmap-core +kmod-crypto-ecdh
   KCONFIG:= \
 	CONFIG_BT \
+	CONFIG_BT_BCM \
 	CONFIG_BT_BREDR=y \
 	CONFIG_BT_DEBUGFS=n \
 	CONFIG_BT_LE=y \
@@ -43,10 +44,11 @@  define KernelPackage/bluetooth
 	CONFIG_BT_HCIBTUSB_MTK=y \
 	CONFIG_BT_HCIBTUSB_RTL=y \
 	CONFIG_BT_HCIUART \
-	CONFIG_BT_HCIUART_BCM=n \
+	CONFIG_BT_HCIUART_BCM=y \
 	CONFIG_BT_HCIUART_INTEL=n \
 	CONFIG_BT_HCIUART_H4 \
 	CONFIG_BT_HCIUART_NOKIA=n \
+	CONFIG_BT_HCIUART_SERDEV=y \
 	CONFIG_BT_HIDP
   $(call AddDepends/rfkill)
   FILES:= \
@@ -55,11 +57,12 @@  define KernelPackage/bluetooth
 	$(LINUX_DIR)/net/bluetooth/bnep/bnep.ko \
 	$(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
 	$(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
+	$(if $(CONFIG_SERIAL_DEV_BUS),$(LINUX_DIR)/drivers/bluetooth/btbcm.ko) \
 	$(LINUX_DIR)/drivers/bluetooth/btusb.ko \
 	$(LINUX_DIR)/drivers/bluetooth/btintel.ko \
 	$(LINUX_DIR)/drivers/bluetooth/btrtl.ko \
 	$(LINUX_DIR)/drivers/bluetooth/btmtk.ko
-  AUTOLOAD:=$(call AutoProbe,bluetooth rfcomm bnep hidp hci_uart btusb)
+  AUTOLOAD:=$(call AutoProbe,bluetooth rfcomm bnep hidp hci_uart btbcm btusb)
 endef
 
 define KernelPackage/bluetooth/description