diff mbox series

[2/3] ltq-adsl-app: align config more closely to VDSL variants

Message ID 20241019174041.1281093-3-jan@3e8.eu
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series None | expand

Commit Message

Jan Hoffmann Oct. 19, 2024, 5:38 p.m. UTC
This is a preparation for adding support for dsl_cpe_pipe.sh with a
similar set of commands compared to the VDSL variant.

The configuration is simplified by using the "--enable-model" option.
Other options are chosen to match the VDSL variant, while also making
sure that previously enabled options stay like that. However, ReTx
options stay disabled, because of incompatibility with the ubus code.

Signed-off-by: Jan Hoffmann <jan@3e8.eu>
---
 package/network/config/ltq-adsl-app/Makefile | 28 +++++++-------------
 1 file changed, 9 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/package/network/config/ltq-adsl-app/Makefile b/package/network/config/ltq-adsl-app/Makefile
index 472e3c0ed9c6..94e2e9d0d77d 100644
--- a/package/network/config/ltq-adsl-app/Makefile
+++ b/package/network/config/ltq-adsl-app/Makefile
@@ -10,7 +10,7 @@  include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=dsl_cpe_control_danube
 PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
 PKG_SOURCE_URL:=@OPENWRT
@@ -54,25 +54,15 @@  CONFIGURE_ARGS += \
 	--with-channels-per-line="$(LTQ_DSL_CHANNELS_PER_LINE)" \
 	--enable-danube \
 	--enable-driver-include="-I$(STAGING_DIR)/usr/include/adsl/" \
-	--enable-debug-prints \
 	--enable-add-appl-cflags="-DMAX_CLI_PIPES=2" \
-	--enable-cli-support \
-	--enable-cmv-scripts \
-	--enable-debug-tool-interface \
-	--enable-adsl-led \
-	--enable-dsl-ceoc \
-	--enable-script-notification \
-	--enable-dsl-pm \
-	--enable-dsl-pm-total \
-	--enable-dsl-pm-history \
-	--enable-dsl-pm-showtime \
-	--enable-dsl-pm-channel-counters \
-	--enable-dsl-pm-datapath-counters \
-	--enable-dsl-pm-line-counters \
-	--enable-dsl-pm-channel-thresholds \
-	--enable-dsl-pm-datapath-thresholds \
-	--enable-dsl-pm-line-thresholds \
-	--enable-dsl-pm-optional-parameters
+	--enable-model=full \
+	--disable-dsl-pm-retx-counters \
+	--disable-dsl-pm-retx-thresholds \
+	--disable-soap-support \
+	--disable-dti \
+	--disable-adsl-mib-support \
+	--disable-adsl-trace \
+	--enable-adsl-led
 
 TARGET_CFLAGS += -I$(LINUX_DIR)/include