diff mbox series

kernel: module: usb: remove deprecated Kconfig option CONFIG_XHCI_HCD_DEBUGGING

Message ID 20240726080730.1175612-1-fe@dev.tdt.de
State Superseded
Headers show
Series kernel: module: usb: remove deprecated Kconfig option CONFIG_XHCI_HCD_DEBUGGING | expand

Commit Message

Florian Eckert July 26, 2024, 8:07 a.m. UTC
The kconfig option 'CONFIG_XHCI_HCD_DEBUGGING' was removed with commit:

https://github.com/torvalds/linux/commit/b2497509df002e9a09c8550cd0ecd2f77c9640d8

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
---
 ...option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch | 36 +++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch

Comments

Hauke Mehrtens July 30, 2024, 10:26 p.m. UTC | #1
On 7/26/24 10:07, Florian Eckert wrote:
> The kconfig option 'CONFIG_XHCI_HCD_DEBUGGING' was removed with commit:
> 
> https://github.com/torvalds/linux/commit/b2497509df002e9a09c8550cd0ecd2f77c9640d8
> 
> Signed-off-by: Florian Eckert <fe@dev.tdt.de>
> ---
>   ...option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch | 36 +++++++++++++++++++
>   1 file changed, 36 insertions(+)
>   create mode 100644 patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch
> 
> diff --git a/patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch b/patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch
> new file mode 100644
> index 0000000000..0f54807fec
> --- /dev/null
> +++ b/patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch
> @@ -0,0 +1,36 @@
> +From: Florian Eckert <fe@dev.tdt.de>
> +Date: Wed, 17 Jul 2024 11:42:58 +0200
> +Subject: [PATCH] kernel: modules: usb: remove deprecated Kconfig option
> + CONFIG_USB_XHCI_HCD_DEBUGGING
> +
> +Redmine-patch-id: 8668
> +The Kconfig option 'CONFIG_USB_XHCI_HCD_DEBUGGING' has been removed with the
> +following commit upstream in the Linux kernel.
> +
> +https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=b2497509df002e9a09c8550cd0ecd2f77c9640d8
> +
> +This Kconfig option is therefore no longer valid for the kernel version
> +6.6 and should musst be removed.
> +
> +Signed-off-by: Florian Eckert <fe@dev.tdt.de>
> +---
> + package/kernel/linux/modules/usb.mk | 4 +---
> + 1 file changed, 1 insertion(+), 3 deletions(-)
> +
> +diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
> +index 12725f10ee25d9ba83e67763f0c41a338aac5542..b0037378342149275571d3e836c44a439a145bc5 100644
> +--- a/package/kernel/linux/modules/usb.mk
> ++++ b/package/kernel/linux/modules/usb.mk
> +@@ -1846,9 +1846,7 @@ $(eval $(call KernelPackage,usb-roles))
> +
> + define KernelPackage/usb-xhci-hcd
> +   TITLE:=xHCI HCD (USB 3.0) support
> +-  KCONFIG:= \
> +-	  CONFIG_USB_XHCI_HCD \
> +-	  CONFIG_USB_XHCI_HCD_DEBUGGING=n
> ++  KCONFIG:= CONFIG_USB_XHCI_HCD
> +   HIDDEN:=1
> +   FILES:=$(LINUX_DIR)/drivers/usb/host/xhci-hcd.ko
> +   AUTOLOAD:=$(call AutoLoad,54,xhci-hcd,1)
> +--
> +
Hi Florian,

This patch looks strange. This looks like a patch for your internal 
build system. ;-)

Hauke
Florian Eckert July 31, 2024, 6:34 a.m. UTC | #2
Hello Hauke

>> --- /dev/null
>> +++ 
>> b/patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch
>> @@ -0,0 +1,36 @@
>> +From: Florian Eckert <fe@dev.tdt.de>
>> +Date: Wed, 17 Jul 2024 11:42:58 +0200
>> +Subject: [PATCH] kernel: modules: usb: remove deprecated Kconfig 
>> option
>> + CONFIG_USB_XHCI_HCD_DEBUGGING
>> +
>> +Redmine-patch-id: 8668
>> +The Kconfig option 'CONFIG_USB_XHCI_HCD_DEBUGGING' has been removed 
>> with the
>> +following commit upstream in the Linux kernel.
>> +
>> +https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=b2497509df002e9a09c8550cd0ecd2f77c9640d8
>> +
>> +This Kconfig option is therefore no longer valid for the kernel 
>> version
>> +6.6 and should musst be removed.
>> +
>> +Signed-off-by: Florian Eckert <fe@dev.tdt.de>
>> +---
>> + package/kernel/linux/modules/usb.mk | 4 +---
>> + 1 file changed, 1 insertion(+), 3 deletions(-)
>> +
>> +diff --git a/package/kernel/linux/modules/usb.mk 
>> b/package/kernel/linux/modules/usb.mk
>> +index 
>> 12725f10ee25d9ba83e67763f0c41a338aac5542..b0037378342149275571d3e836c44a439a145bc5 
>> 100644
>> +--- a/package/kernel/linux/modules/usb.mk
>> ++++ b/package/kernel/linux/modules/usb.mk
>> +@@ -1846,9 +1846,7 @@ $(eval $(call KernelPackage,usb-roles))
>> +
>> + define KernelPackage/usb-xhci-hcd
>> +   TITLE:=xHCI HCD (USB 3.0) support
>> +-  KCONFIG:= \
>> +-	  CONFIG_USB_XHCI_HCD \
>> +-	  CONFIG_USB_XHCI_HCD_DEBUGGING=n
>> ++  KCONFIG:= CONFIG_USB_XHCI_HCD
>> +   HIDDEN:=1
>> +   FILES:=$(LINUX_DIR)/drivers/usb/host/xhci-hcd.ko
>> +   AUTOLOAD:=$(call AutoLoad,54,xhci-hcd,1)
>> +--
>> +
> Hi Florian,
> 
> This patch looks strange. This looks like a patch for your internal
> build system. ;-)

You're absolutely right! It must be the heat!
I've already sent a new one.

Thanks

Florian
diff mbox series

Patch

diff --git a/patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch b/patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch
new file mode 100644
index 0000000000..0f54807fec
--- /dev/null
+++ b/patches/openwrt/30066-kernel-modules-usb-remove-deprecated-Kconfig-option-CONFIG_USB_XHCI_HCD_DEBUGGING.patch
@@ -0,0 +1,36 @@ 
+From: Florian Eckert <fe@dev.tdt.de>
+Date: Wed, 17 Jul 2024 11:42:58 +0200
+Subject: [PATCH] kernel: modules: usb: remove deprecated Kconfig option
+ CONFIG_USB_XHCI_HCD_DEBUGGING
+
+Redmine-patch-id: 8668
+The Kconfig option 'CONFIG_USB_XHCI_HCD_DEBUGGING' has been removed with the
+following commit upstream in the Linux kernel.
+
+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=b2497509df002e9a09c8550cd0ecd2f77c9640d8
+
+This Kconfig option is therefore no longer valid for the kernel version
+6.6 and should musst be removed.
+
+Signed-off-by: Florian Eckert <fe@dev.tdt.de>
+---
+ package/kernel/linux/modules/usb.mk | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
+index 12725f10ee25d9ba83e67763f0c41a338aac5542..b0037378342149275571d3e836c44a439a145bc5 100644
+--- a/package/kernel/linux/modules/usb.mk
++++ b/package/kernel/linux/modules/usb.mk
+@@ -1846,9 +1846,7 @@ $(eval $(call KernelPackage,usb-roles))
+ 
+ define KernelPackage/usb-xhci-hcd
+   TITLE:=xHCI HCD (USB 3.0) support
+-  KCONFIG:= \
+-	  CONFIG_USB_XHCI_HCD \
+-	  CONFIG_USB_XHCI_HCD_DEBUGGING=n
++  KCONFIG:= CONFIG_USB_XHCI_HCD
+   HIDDEN:=1
+   FILES:=$(LINUX_DIR)/drivers/usb/host/xhci-hcd.ko
+   AUTOLOAD:=$(call AutoLoad,54,xhci-hcd,1)
+-- 
+