diff mbox series

[2/5] ltq-vdsl-vr11-app: fix error handling during disconnection

Message ID 20240712144801.1192493-3-jan@3e8.eu
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series ltq-vdsl-*-app: improve shutdown handling | expand

Commit Message

Jan Hoffmann July 12, 2024, 1:49 p.m. UTC
Use the correct return value in error message.

Fixes: 6e4c9738bed0 ("ltq-vdsl-vr11-app: add version 4.23.1 for vr11 targets")
Signed-off-by: Jan Hoffmann <jan@3e8.eu>
---
 package/network/config/ltq-vdsl-vr11-app/Makefile               | 2 +-
 .../network/config/ltq-vdsl-vr11-app/patches/200-autoboot.patch | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/network/config/ltq-vdsl-vr11-app/Makefile b/package/network/config/ltq-vdsl-vr11-app/Makefile
index bcbf41e65a15..4e26ee459a1e 100644
--- a/package/network/config/ltq-vdsl-vr11-app/Makefile
+++ b/package/network/config/ltq-vdsl-vr11-app/Makefile
@@ -9,7 +9,7 @@  include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-vr11-app
 PKG_VERSION:=4.23.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_BASE_NAME:=dsl_cpe_control
 
 UGW_VERSION=8.5.2.10
diff --git a/package/network/config/ltq-vdsl-vr11-app/patches/200-autoboot.patch b/package/network/config/ltq-vdsl-vr11-app/patches/200-autoboot.patch
index c3e9b9662048..3397c7f024e3 100644
--- a/package/network/config/ltq-vdsl-vr11-app/patches/200-autoboot.patch
+++ b/package/network/config/ltq-vdsl-vr11-app/patches/200-autoboot.patch
@@ -51,7 +51,7 @@  start it again later, short of unloading and reloading the module.
 +      {
 +         DSL_CCA_DEBUG(DSL_CCA_DBG_ERR, (DSL_CPE_PREFIX
 +            "Autoboot configuration for device (%d) failed!, nRet = %d!"
-+            DSL_CPE_CRLF, nDevice, sAutobootCtl.accessCtl.nReturn));
++            DSL_CPE_CRLF, nDevice, sAutobootCfg.accessCtl.nReturn));
 +      }
 +
        memset(&sAutobootCtl, 0, sizeof(DSL_AutobootControl_t));