diff mbox series

kirkwood: Add Marvell RTC to two devices

Message ID 20240601-kirkwood-dns320l-rtc-v1-1-6e3e925ea917@linaro.org
State Accepted, archived
Delegated to: Linus Walleij
Headers show
Series kirkwood: Add Marvell RTC to two devices | expand

Commit Message

Linus Walleij June 1, 2024, 8:34 p.m. UTC
The recently added D-Link DNS-320L and the Zyxel NSA310S
is missing an RTC module so let's give them the default
Marvell RTC at least.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 target/linux/kirkwood/image/Makefile | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)


---
base-commit: 37ff0ea7269271feffaa5bd3042a551b1d735c57
change-id: 20240601-kirkwood-dns320l-rtc-fba7532f1a21

Best regards,

Comments

Robert Marko June 7, 2024, 10:08 a.m. UTC | #1
On Sat, 1 Jun 2024 at 22:34, Linus Walleij <linus.walleij@linaro.org> wrote:
>
> The recently added D-Link DNS-320L and the Zyxel NSA310S
> is missing an RTC module so let's give them the default
> Marvell RTC at least.
>
> Signed-off-by: Linus Walleij <linus.walleij@linaro.org>

Reviewed-by: Robert Marko <robimarko@gmail.com>

Regards,
Robert
> ---
>  target/linux/kirkwood/image/Makefile | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
> index 48de5bee2b84..2bd2f6415987 100644
> --- a/target/linux/kirkwood/image/Makefile
> +++ b/target/linux/kirkwood/image/Makefile
> @@ -186,7 +186,7 @@ define Device/dlink_dns320l
>    DEVICE_VENDOR := D-Link
>    DEVICE_MODEL := DNS-320L
>    DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 kmod-gpio-button-hotplug \
> -       kmod-usb-storage kmod-usb-ledtrig-usbport dns320l-mcu
> +       kmod-usb-storage kmod-usb-ledtrig-usbport dns320l-mcu kmod-rtc-mv
>  endef
>  TARGET_DEVICES += dlink_dns320l
>
> @@ -386,7 +386,8 @@ TARGET_DEVICES += zyxel_nsa310b
>  define Device/zyxel_nsa310s
>    DEVICE_VENDOR := ZyXEL
>    DEVICE_MODEL := NSA310S
> -  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 kmod-gpio-button-hotplug
> +  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 \
> +       kmod-gpio-button-hotplug kmod-rtc-mv
>  endef
>  TARGET_DEVICES += zyxel_nsa310s
>
>
> ---
> base-commit: 37ff0ea7269271feffaa5bd3042a551b1d735c57
> change-id: 20240601-kirkwood-dns320l-rtc-fba7532f1a21
>
> Best regards,
> --
> Linus Walleij <linus.walleij@linaro.org>
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 48de5bee2b84..2bd2f6415987 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -186,7 +186,7 @@  define Device/dlink_dns320l
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DNS-320L
   DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 kmod-gpio-button-hotplug \
-	kmod-usb-storage kmod-usb-ledtrig-usbport dns320l-mcu
+	kmod-usb-storage kmod-usb-ledtrig-usbport dns320l-mcu kmod-rtc-mv
 endef
 TARGET_DEVICES += dlink_dns320l
 
@@ -386,7 +386,8 @@  TARGET_DEVICES += zyxel_nsa310b
 define Device/zyxel_nsa310s
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NSA310S
-  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 kmod-gpio-button-hotplug
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-fs-ext4 \
+	kmod-gpio-button-hotplug kmod-rtc-mv
 endef
 TARGET_DEVICES += zyxel_nsa310s