diff mbox series

tools: meson: bump to 1.0.0

Message ID 20230217091810.1381853-1-koen.vandeputte@citymesh.com
State New
Headers show
Series tools: meson: bump to 1.0.0 | expand

Commit Message

Koen Vandeputte Feb. 17, 2023, 9:18 a.m. UTC
Drop upstreamed patch.

Tested by compiling the complete gstreamer package which heavily
depends on this one.

Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
---

This patch is a requirement to build gstreamer 1.22.0 for which a PR is ready to submit in package feed

 tools/meson/Makefile               |  4 ++--
 tools/meson/patches/010-wsl2.patch | 21 ---------------------
 2 files changed, 2 insertions(+), 23 deletions(-)
 delete mode 100644 tools/meson/patches/010-wsl2.patch

Comments

Andre Heider Feb. 17, 2023, 10:08 a.m. UTC | #1
On 17/02/2023 10:18, Koen Vandeputte wrote:
> Drop upstreamed patch.
> 
> Tested by compiling the complete gstreamer package which heavily
> depends on this one.
> 
> Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>

Not possible unfortunately, see 
https://github.com/openwrt/openwrt/pull/10543

We tried a few times to get meson to not drop support for older python 
versions, but here we are...

Cheers,
Andre
Rosen Penev Feb. 24, 2023, 2:41 a.m. UTC | #2
On Fri, Feb 17, 2023 at 2:13 AM Andre Heider <a.heider@gmail.com> wrote:
>
> On 17/02/2023 10:18, Koen Vandeputte wrote:
> > Drop upstreamed patch.
> >
> > Tested by compiling the complete gstreamer package which heavily
> > depends on this one.
> >
> > Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
>
> Not possible unfortunately, see
> https://github.com/openwrt/openwrt/pull/10543
>
> We tried a few times to get meson to not drop support for older python
> versions, but here we are...
Wow this went to my spam. Hilarious.

Ubuntu 18.04 is the earliest distribution supported to compile
OpenWrt. It's interesting that it's not compatible with ccache and
nobody has bothered to fix that. Anyway,

18.04 has python 3.7 and 3.8, making this update possible. IIRC
prereq-build.mk needs to be updated to make either 3.7 or 3.8 the new
minimum.
>
> Cheers,
> Andre
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Andre Heider Feb. 24, 2023, 4:48 a.m. UTC | #3
On 24/02/2023 03:41, Rosen Penev wrote:
> On Fri, Feb 17, 2023 at 2:13 AM Andre Heider <a.heider@gmail.com> wrote:
>>
>> On 17/02/2023 10:18, Koen Vandeputte wrote:
>>> Drop upstreamed patch.
>>>
>>> Tested by compiling the complete gstreamer package which heavily
>>> depends on this one.
>>>
>>> Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
>>
>> Not possible unfortunately, see
>> https://github.com/openwrt/openwrt/pull/10543
>>
>> We tried a few times to get meson to not drop support for older python
>> versions, but here we are...
> Wow this went to my spam. Hilarious.
> 
> Ubuntu 18.04 is the earliest distribution supported to compile
> OpenWrt. It's interesting that it's not compatible with ccache and
> nobody has bothered to fix that. Anyway,
> 
> 18.04 has python 3.7 and 3.8, making this update possible. IIRC
> prereq-build.mk needs to be updated to make either 3.7 or 3.8 the new
> minimum.

It looks like not per default though?
https://packages.ubuntu.com/bionic/python3

There's no python3 listed in backports, but apparently in "updates"? No 
idea how it works there, but on debian you need to explicitly choose a 
bpo package to get it installed, it won't land automatically.

Anyway, for all I care we can drop support for 3.6, I just have no idea 
if buildbot runs on at least 3.7? Last I heard it didn't, but that's 
been a while.

In any case something like 7379f8b "build: prereq: drop support for 
Python 3.5" for 3.6 should go in first.

Cheers,
Andre
diff mbox series

Patch

diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index d53ed897a3..75fae42b37 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -1,11 +1,11 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=meson
-PKG_VERSION:=0.61.5
+PKG_VERSION:=1.0.0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/mesonbuild/meson/releases/download/$(PKG_VERSION)
-PKG_HASH:=5e9a0d65c1a51936362b9686d1c5e9e184a6fd245d57e7269750ce50c20f5d9a
+PKG_HASH:=aa50a4ba4557c25e7d48446abfde857957dcdf58385fffbe670ba0e8efacce05
 
 PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
 PKG_LICENSE:=Apache-2.0
diff --git a/tools/meson/patches/010-wsl2.patch b/tools/meson/patches/010-wsl2.patch
deleted file mode 100644
index 4ab799d699..0000000000
--- a/tools/meson/patches/010-wsl2.patch
+++ /dev/null
@@ -1,21 +0,0 @@ 
-From 7d1ef4343ed5b2b7ab51469177a42c32c47f0528 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Tue, 6 Sep 2022 01:36:17 -0700
-Subject: [PATCH] minstall: handle extra error for selinuxenabled
-
-Microsoft's WSL2 uses a Plan 9 filesystem, which returns IOError when file is missing.
----
- mesonbuild/minstall.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/mesonbuild/minstall.py
-+++ b/mesonbuild/minstall.py
-@@ -229,7 +229,7 @@ def restore_selinux_contexts() -> None:
-     '''
-     try:
-         subprocess.check_call(['selinuxenabled'])
--    except (FileNotFoundError, NotADirectoryError, PermissionError, subprocess.CalledProcessError):
-+    except (FileNotFoundError, NotADirectoryError, OSError, PermissionError, subprocess.CalledProcessError):
-         # If we don't have selinux or selinuxenabled returned 1, failure
-         # is ignored quietly.
-         return