diff mbox series

realtek: don't relocate kernel on HPE 1920 series

Message ID 20230105213624.2296881-1-jan@3e8.eu
State Accepted
Delegated to: Sander Vanheule
Headers show
Series realtek: don't relocate kernel on HPE 1920 series | expand

Commit Message

Jan Hoffmann Jan. 5, 2023, 9:36 p.m. UTC
This is no longer needed now that the kernel is built with a load
address that matches the one hard-coded in the bootloader.

Signed-off-by: Jan Hoffmann <jan@3e8.eu>
---
 target/linux/realtek/image/Makefile  | 14 --------------
 target/linux/realtek/image/common.mk |  2 --
 2 files changed, 16 deletions(-)

Comments

Sander Vanheule Jan. 7, 2023, 10:23 a.m. UTC | #1
On Thu, 2023-01-05 at 22:36 +0100, Jan Hoffmann wrote:
> This is no longer needed now that the kernel is built with a load
> address that matches the one hard-coded in the bootloader.
> 
> Signed-off-by: Jan Hoffmann <jan@3e8.eu>
> ---

Thanks for keeping things up to date! Merged to master.

Best,
Sander
diff mbox series

Patch

diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 82390212e62d..3dfbcf67c166 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -71,20 +71,6 @@  define Build/h3c-vfs
 	mv $@.new $@
 endef
 
-define Build/relocate-kernel
-	rm -rf $@.relocate
-	$(CP) ../../generic/image/relocate $@.relocate
-	$(MAKE) -j1 -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) LZMA_TEXT_START=0x82000000 \
-		CROSS_COMPILE=$(TARGET_CROSS)
-	( \
-		dd if=$@.relocate/loader.bin bs=32 conv=sync && \
-		perl -e '@s = stat("$@"); print pack("N", @s[7])' && \
-		cat "$@" \
-	) > "$@.new"
-	mv "$@.new" "$@"
-	rm -rf $@.relocate
-endef
-
 define Device/Default
   PROFILES = Default
   KERNEL := \
diff --git a/target/linux/realtek/image/common.mk b/target/linux/realtek/image/common.mk
index 8f536bf15f58..214683f8e959 100644
--- a/target/linux/realtek/image/common.mk
+++ b/target/linux/realtek/image/common.mk
@@ -34,14 +34,12 @@  define Device/hpe_1920
   KERNEL := \
 	kernel-bin | \
 	append-dtb | \
-	relocate-kernel | \
 	7z | \
 	h3c-image | \
 	h3c-vfs
   KERNEL_INITRAMFS := \
 	kernel-bin | \
 	append-dtb | \
-	relocate-kernel | \
 	7z | \
 	h3c-image
   IMAGE/sysupgrade.bin := \