diff mbox series

[1/3] ramips: hlk-7621a-evb: remove WiFi support

Message ID 20220413120554.9355-1-reinhard@m4x.de
State New
Headers show
Series [1/3] ramips: hlk-7621a-evb: remove WiFi support | expand

Commit Message

Reinhard Max April 13, 2022, 12:05 p.m. UTC
The HiLink HLK-7621A evaluation board[1] contains no on-board WiFi
hardware and its Mini PCIe slot can be used for arbitrary extension
cards. So it makes no sense for a default build to assume that any
particular type of WiFi chip is present.

[1] http://hlktech.net/index.php?id=436

Signed-off-by: Reinhard Max <reinhard@m4x.de>
---
 target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts | 8 --------
 target/linux/ramips/image/mt7621.mk                     | 2 +-
 2 files changed, 1 insertion(+), 9 deletions(-)

Comments

Reinhard Max April 13, 2022, 1:27 p.m. UTC | #1
Hi,

I forgot to mention that these three patches are meant to go into 21.03 
as well, to complete support for this board.

cu
Reinhard
Reinhard Max April 13, 2022, 1:32 p.m. UTC | #2
Am 13.04.2022 15:27, schrieb Reinhard Max:

> I forgot to mention that these three patches are meant to go into
> 21.03 as well, to complete support for this board.

22.03, of course. Sorry for the noise.

But support for this board should also easily be backportable to 21.02, 
if the policy allows such backports at all.

cu
Reinhard
Hauke Mehrtens April 17, 2022, 1:36 p.m. UTC | #3
On 4/13/22 14:05, Reinhard Max wrote:
> The HiLink HLK-7621A evaluation board[1] contains no on-board WiFi
> hardware and its Mini PCIe slot can be used for arbitrary extension
> cards. So it makes no sense for a default build to assume that any
> particular type of WiFi chip is present.
> 
> [1] http://hlktech.net/index.php?id=436
> 
> Signed-off-by: Reinhard Max <reinhard@m4x.de>
> ---
>   target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts | 8 --------
>   target/linux/ramips/image/mt7621.mk                     | 2 +-
>   2 files changed, 1 insertion(+), 9 deletions(-)
> 
> diff --git a/target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts b/target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts
> index 9776f43e02..b96436e03d 100644
> --- a/target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts
> +++ b/target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts
> @@ -94,14 +94,6 @@
>   	status = "okay";
>   };
>   
> -&pcie2 {
> -	wifi@0,0 {
> -		compatible = "mediatek,mt76";
> -		reg = <0x0000 0 0 0 0>;
> -		mediatek,mtd-eeprom = <&factory 0x8000>;

Is there a Mediatek eeprom at this location?

If there is normally real eeprom data then we should probably us it if 
someone put the correct card in.

Hauke
Reinhard Max April 20, 2022, 4:57 p.m. UTC | #4
Am 17.04.2022 15:36, schrieb Hauke Mehrtens:

> Is there a Mediatek eeprom at this location?

I would guess so, by comparing the content with a device that does have 
on-board WiFi.

> If there is normally real eeprom data then we should probably us it if
> someone put the correct card in.

Please correct me if I am wrong, but I think a removable mPCIe card is 
always required to have its own EEPROM, which should be more accurate 
for that particular card than anything that happens to be on the flash 
of the SoC module it happens to get connected to.

I don't know what information is exactly contained in that (emulated) 
EEPROM, but I would expect stuff that depends on the circuitry around 
the WiFi chip, such as antenna configuration, LED existance and 
polarity, but it might even contain HF calibration data that is specific 
to a particular copy of the chip.

I guess that this EEPROM data is only there by accident, because some 
SDK or BSP from MediaTek happens to have it there by default, configured 
for some common WiFi chip, and the module manufacturer did not bother to 
disable it, although it is not really needed.


cu
Reinhard
diff mbox series

Patch

diff --git a/target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts b/target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts
index 9776f43e02..b96436e03d 100644
--- a/target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts
+++ b/target/linux/ramips/dts/mt7621_hilink_hlk-7621a-evb.dts
@@ -94,14 +94,6 @@ 
 	status = "okay";
 };
 
-&pcie2 {
-	wifi@0,0 {
-		compatible = "mediatek,mt76";
-		reg = <0x0000 0 0 0 0>;
-		mediatek,mtd-eeprom = <&factory 0x8000>;
-	};
-};
-
 &state_default {
 	gpio {
 		groups = "wdt";
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index cd28e36917..b90851c323 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -680,7 +680,7 @@  define Device/hilink_hlk-7621a-evb
   $(Device/uimage-lzma-loader)
   DEVICE_VENDOR := HiLink
   DEVICE_MODEL := HLK-7621A evaluation board
-  DEVICE_PACKAGES += kmod-mt76x2 kmod-usb3
+  DEVICE_PACKAGES += kmod-usb3
   IMAGE_SIZE := 32448k
 endef
 TARGET_DEVICES += hilink_hlk-7621a-evb