diff mbox series

[v2] bcm53xx: complete Asus RT-AC88U support

Message ID 20220331063506.16085-1-arinc.unal@arinc9.com
State Superseded
Headers show
Series [v2] bcm53xx: complete Asus RT-AC88U support | expand

Commit Message

Arınç ÜNAL March 31, 2022, 6:35 a.m. UTC
Add white:lan LED configuration. Remove the BROKEN flag.

Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
---
v2: remove adding rtl8365mb patch as it's already done.

---
 target/linux/bcm53xx/base-files/etc/board.d/01_leds | 3 +++
 target/linux/bcm53xx/image/Makefile                 | 1 -
 2 files changed, 3 insertions(+), 1 deletion(-)

Comments

Arınç ÜNAL April 10, 2022, 9:28 a.m. UTC | #1
Can we get this applied if there're no objections?

Arınç

On 31/03/2022 09:35, Arınç ÜNAL wrote:
> Add white:lan LED configuration. Remove the BROKEN flag.
> 
> Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
> ---
> v2: remove adding rtl8365mb patch as it's already done.
> 
> ---
>   target/linux/bcm53xx/base-files/etc/board.d/01_leds | 3 +++
>   target/linux/bcm53xx/image/Makefile                 | 1 -
>   2 files changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/bcm53xx/base-files/etc/board.d/01_leds b/target/linux/bcm53xx/base-files/etc/board.d/01_leds
> index aba526b9c3..bd24234046 100644
> --- a/target/linux/bcm53xx/base-files/etc/board.d/01_leds
> +++ b/target/linux/bcm53xx/base-files/etc/board.d/01_leds
> @@ -4,6 +4,9 @@
>   board_config_update
>   
>   case "$(board_name)" in
> +asus,rt-ac88u)
> +	ucidef_set_led_netdev "lan" "LAN" "white:lan" "eth1"
> +	;;
>   netgear,r8000)
>   	ucidef_set_led_usbport "usb2" "USB 2.0" "bcm53xx:white:usb2" "usb1-port2" "usb2-port2"
>   	ucidef_set_led_usbport "usb3" "USB 3.0" "bcm53xx:white:usb3" "usb1-port1" "usb2-port1" "usb4-port1"
> diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
> index 3df24013ce..fc85a131cc 100644
> --- a/target/linux/bcm53xx/image/Makefile
> +++ b/target/linux/bcm53xx/image/Makefile
> @@ -172,7 +172,6 @@ define Device/asus_rt-ac88u
>     DEVICE_MODEL := RT-AC88U
>     DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
>     ASUS_PRODUCTID := RT-AC88U
> -  BROKEN := y
>   endef
>   TARGET_DEVICES += asus_rt-ac88u
>
Rafał Miłecki May 3, 2022, 8:24 a.m. UTC | #2
On 31.03.2022 08:35, Arınç ÜNAL wrote:
> Add white:lan LED configuration. Remove the BROKEN flag.
> 
> Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
> ---
> v2: remove adding rtl8365mb patch as it's already done.
> 
> ---
>   target/linux/bcm53xx/base-files/etc/board.d/01_leds | 3 +++
>   target/linux/bcm53xx/image/Makefile                 | 1 -
>   2 files changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/bcm53xx/base-files/etc/board.d/01_leds b/target/linux/bcm53xx/base-files/etc/board.d/01_leds
> index aba526b9c3..bd24234046 100644
> --- a/target/linux/bcm53xx/base-files/etc/board.d/01_leds
> +++ b/target/linux/bcm53xx/base-files/etc/board.d/01_leds
> @@ -4,6 +4,9 @@
>   board_config_update
>   
>   case "$(board_name)" in
> +asus,rt-ac88u)
> +	ucidef_set_led_netdev "lan" "LAN" "white:lan" "eth1"
> +	;;

I believe this router uses
WAN LED for WAN traffic (1 port)
LAN LED for LAN traffic (8 ports)

If you use eth1 interface as LED trigger, won't it make LAN LED react
also to WAN traffic?

My guess: should we assign 8 switch ports as that LED triggers?
Arınç ÜNAL May 3, 2022, 8:56 a.m. UTC | #3
On 03/05/2022 11:24, Rafał Miłecki wrote:
> On 31.03.2022 08:35, Arınç ÜNAL wrote:
>> Add white:lan LED configuration. Remove the BROKEN flag.
>>
>> Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
>> ---
>> v2: remove adding rtl8365mb patch as it's already done.
>>
>> ---
>>   target/linux/bcm53xx/base-files/etc/board.d/01_leds | 3 +++
>>   target/linux/bcm53xx/image/Makefile                 | 1 -
>>   2 files changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/target/linux/bcm53xx/base-files/etc/board.d/01_leds 
>> b/target/linux/bcm53xx/base-files/etc/board.d/01_leds
>> index aba526b9c3..bd24234046 100644
>> --- a/target/linux/bcm53xx/base-files/etc/board.d/01_leds
>> +++ b/target/linux/bcm53xx/base-files/etc/board.d/01_leds
>> @@ -4,6 +4,9 @@
>>   board_config_update
>>   case "$(board_name)" in
>> +asus,rt-ac88u)
>> +    ucidef_set_led_netdev "lan" "LAN" "white:lan" "eth1"
>> +    ;;
> 
> I believe this router uses
> WAN LED for WAN traffic (1 port)
> LAN LED for LAN traffic (8 ports)
> 
> If you use eth1 interface as LED trigger, won't it make LAN LED react
> also to WAN traffic?
> 
> My guess: should we assign 8 switch ports as that LED triggers?

There's red and white LEDs for WAN but the white one is actually not 
wired to any GPIO. Official Asus firmware controls it some other way. So 
we could only use the red one for wan traffic which I don't like. On top 
of that, we'd have to listen a bridge interface (we can't define 
multiple interfaces) in order to cover traffic on all of the lan ports 
of the switch which I also don't like because the configuration can be 
changed by user.

I think we should leave this to the user. You can discard the LED 
configuration and just remove the BROKEN flag.

Arınç
diff mbox series

Patch

diff --git a/target/linux/bcm53xx/base-files/etc/board.d/01_leds b/target/linux/bcm53xx/base-files/etc/board.d/01_leds
index aba526b9c3..bd24234046 100644
--- a/target/linux/bcm53xx/base-files/etc/board.d/01_leds
+++ b/target/linux/bcm53xx/base-files/etc/board.d/01_leds
@@ -4,6 +4,9 @@ 
 board_config_update
 
 case "$(board_name)" in
+asus,rt-ac88u)
+	ucidef_set_led_netdev "lan" "LAN" "white:lan" "eth1"
+	;;
 netgear,r8000)
 	ucidef_set_led_usbport "usb2" "USB 2.0" "bcm53xx:white:usb2" "usb1-port2" "usb2-port2"
 	ucidef_set_led_usbport "usb3" "USB 3.0" "bcm53xx:white:usb3" "usb1-port1" "usb2-port1" "usb4-port1"
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 3df24013ce..fc85a131cc 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -172,7 +172,6 @@  define Device/asus_rt-ac88u
   DEVICE_MODEL := RT-AC88U
   DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
   ASUS_PRODUCTID := RT-AC88U
-  BROKEN := y
 endef
 TARGET_DEVICES += asus_rt-ac88u