diff mbox series

[3/3] netfilter: add kmod-nft-tproxy

Message ID 20220225030955.1981364-3-yszhou4tech@gmail.com
State Accepted
Delegated to: Yousong Zhou
Headers show
Series [1/3] netfilter: separate packages for kmod-ipt-socket and kmod-ipt-tproxy | expand

Commit Message

Yousong Zhou Feb. 25, 2022, 3:09 a.m. UTC
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
 include/netfilter.mk                      |  2 ++
 package/kernel/linux/modules/netfilter.mk | 11 +++++++++++
 2 files changed, 13 insertions(+)
diff mbox series

Patch

diff --git a/include/netfilter.mk b/include/netfilter.mk
index 83455cc378..2ef8f83e4c 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -353,6 +353,8 @@  $(eval $(if $(NF_KMOD),$(call nf_add,NFT_QUEUE,CONFIG_NFT_QUEUE, $(P_XT)nft_queu
 
 $(eval $(if $(NF_KMOD),$(call nf_add,NFT_SOCKET,CONFIG_NFT_SOCKET, $(P_XT)nft_socket),))
 
+$(eval $(if $(NF_KMOD),$(call nf_add,NFT_TPROXY,CONFIG_NFT_TPROXY, $(P_XT)nft_tproxy),))
+
 $(eval $(if $(NF_KMOD),$(call nf_add,NFT_COMPAT,CONFIG_NFT_COMPAT, $(P_XT)nft_compat),))
 
 # userland only
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 7200af769f..1707bf2d9f 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1228,6 +1228,17 @@  endef
 
 $(eval $(call KernelPackage,nft-socket))
 
+define KernelPackage/nft-tproxy
+  SUBMENU:=$(NF_MENU)
+  TITLE:=Netfilter nf_tables tproxy support
+  DEPENDS:=+kmod-nft-core +kmod-nf-tproxy +kmod-nf-conntrack
+  FILES:=$(foreach mod,$(NFT_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
+  AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_TPROXY-m)))
+  KCONFIG:=$(KCONFIG_NFT_TPROXY)
+endef
+
+$(eval $(call KernelPackage,nft-tproxy))
+
 define KernelPackage/nft-compat
   SUBMENU:=$(NF_MENU)
   TITLE:=Netfilter nf_tables compat support