diff mbox series

[3/3] toolchain: glibc: Enable --enable-bind-now

Message ID 20211229174037.1244686-3-hauke@hauke-m.de
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series [1/3] toolchain: glibc: Update to version 2.34 | expand

Commit Message

Hauke Mehrtens Dec. 29, 2021, 5:40 p.m. UTC
Enable --enable-bind-now when CONFIG_PKG_RELRO_FULL is set. This option
is activated by default. This will enable full RELRO protection.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 toolchain/glibc/common.mk | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 16d9241dcae5..c239863a6c0a 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -63,6 +63,7 @@  GLIBC_CONFIGURE:= \
 		--$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
 		  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
 		  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
+		  $(if $(CONFIG_PKG_RELRO_FULL),--enable-bind-now) \
 		--enable-kernel=5.4.0
 
 export libc_cv_ssp=no