diff mbox series

[1/6] toolchain: gdb: Update to version 11.1

Message ID 20211101165422.1598719-2-hauke@hauke-m.de
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series Update some development tools | expand

Commit Message

Hauke Mehrtens Nov. 1, 2021, 4:54 p.m. UTC
The removed patch was already applied upstream.

gdb now mandatory depends on gmp, tell configure where to find it
explicitly. We already build gmp in the tools directory for gcc. Also
make it use mpfr and mpc as we also build both of them.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---

Debian ships a gdb multi arch, we can probably also move gdb to the 
tools directory and build it only once for all targets. This should be 
done in a separate patch.


 toolchain/gdb/Makefile                        |  7 +++++--
 .../patches/100-fix-elf-support-check.patch   | 20 -------------------
 2 files changed, 5 insertions(+), 22 deletions(-)
 delete mode 100644 toolchain/gdb/patches/100-fix-elf-support-check.patch
diff mbox series

Patch

diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index e769a3be3ece..2adb7d165aed 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -7,12 +7,12 @@ 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=10.1
+PKG_VERSION:=11.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=f82f1eceeec14a3afa2de8d9b0d3c91d5a3820e23e0a01bbb70ef9f0276b62c0
+PKG_HASH:=cccfcc407b20d343fb320d4a9a2110776dd3165118ffd41f4b1b162340333f94
 GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
 
 HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
@@ -30,6 +30,9 @@  HOST_CONFIGURE_ARGS = \
 	--build=$(GNU_HOST_NAME) \
 	--host=$(GNU_HOST_NAME) \
 	--target=$(REAL_GNU_TARGET_NAME) \
+	--with-gmp=$(TOPDIR)/staging_dir/host \
+	--with-mpfr=$(TOPDIR)/staging_dir/host \
+	--with-mpc=$(TOPDIR)/staging_dir/host \
 	--disable-werror \
 	--without-uiout \
 	--enable-tui --disable-gdbtk --without-x \
diff --git a/toolchain/gdb/patches/100-fix-elf-support-check.patch b/toolchain/gdb/patches/100-fix-elf-support-check.patch
deleted file mode 100644
index fe612c38db38..000000000000
--- a/toolchain/gdb/patches/100-fix-elf-support-check.patch
+++ /dev/null
@@ -1,20 +0,0 @@ 
---- a/gdb/configure
-+++ b/gdb/configure
-@@ -16818,6 +16818,7 @@ else
-   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h.  */
- #include <stdlib.h>
-+#include <string.h>
-   #include "bfd.h"
-   #include "elf-bfd.h"
- 
---- a/gdb/acinclude.m4
-+++ b/gdb/acinclude.m4
-@@ -362,6 +362,7 @@ AC_DEFUN([GDB_AC_CHECK_BFD], [
-   AC_CACHE_CHECK([$1], [$2],
-   [AC_TRY_LINK(
-   [#include <stdlib.h>
-+  #include <string.h>
-   #include "bfd.h"
-   #include "$4"
-   ],