diff mbox series

[RFT,5/5] realtek: support Trendnet TPE-082WS V1

Message ID 20211005194024.31909-6-fercerpav@gmail.com
State Changes Requested
Delegated to: Petr Štetiar
Headers show
Series realtek: support boards similar to DGS-1210-10 | expand

Commit Message

Paul Fertser Oct. 5, 2021, 7:40 p.m. UTC
According to photos and specs for Trendnet TPE-082WS V1.2R it should be
the same as D-Link DGS-1210-10P R1 but with more powerful PSU (90 W) so
the PoE budget is specified as 75 W.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
---
 .../realtek/base-files/etc/board.d/02_network |  3 +
 .../rtl8380_trendnet_tpe-082ws-v1.dts         | 67 +++++++++++++++++++
 target/linux/realtek/image/Makefile           | 11 +++
 3 files changed, 81 insertions(+)
 create mode 100644 target/linux/realtek/dts-5.10/rtl8380_trendnet_tpe-082ws-v1.dts

Comments

Adrian Schmutzler Oct. 9, 2021, 5:56 p.m. UTC | #1
Hi,

> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of Paul Fertser
> Sent: Dienstag, 5. Oktober 2021 21:40
> To: openwrt-devel@lists.openwrt.org
> Cc: Paul Fertser <fercerpav@gmail.com>
> Subject: [RFT 5/5] realtek: support Trendnet TPE-082WS V1
> 
> According to photos and specs for Trendnet TPE-082WS V1.2R it should be
> the same as D-Link DGS-1210-10P R1 but with more powerful PSU (90 W) so
> the PoE budget is specified as 75 W.

This should be properly sorted in image/Makefile.

Best

Adian

> 
> Signed-off-by: Paul Fertser <fercerpav@gmail.com>
> ---
>  .../realtek/base-files/etc/board.d/02_network |  3 +
>  .../rtl8380_trendnet_tpe-082ws-v1.dts         | 67 +++++++++++++++++++
>  target/linux/realtek/image/Makefile           | 11 +++
>  3 files changed, 81 insertions(+)
>  create mode 100644 target/linux/realtek/dts-5.10/rtl8380_trendnet_tpe-
> 082ws-v1.dts
> 
> diff --git a/target/linux/realtek/base-files/etc/board.d/02_network
> b/target/linux/realtek/base-files/etc/board.d/02_network
> index e7c45de92328..f8e06aea3510 100644
> --- a/target/linux/realtek/base-files/etc/board.d/02_network
> +++ b/target/linux/realtek/base-files/etc/board.d/02_network
> @@ -61,6 +61,9 @@ netgear,gs110tpp-v1)
>  netgear,gs310tp-v1)
>  	ucidef_set_poe 55 "$lan_list"
>  	;;
> +trendnet,tpe-082ws-v1)
> +	ucidef_set_poe 75 "$lan_list"
> +	;;
>  zyxel,gs1900-10hp)
>  	ucidef_set_poe 77 "$lan_list"
>  	;;
> diff --git a/target/linux/realtek/dts-5.10/rtl8380_trendnet_tpe-082ws-v1.dts
> b/target/linux/realtek/dts-5.10/rtl8380_trendnet_tpe-082ws-v1.dts
> new file mode 100644
> index 000000000000..9b61da7ffccf
> --- /dev/null
> +++ b/target/linux/realtek/dts-5.10/rtl8380_trendnet_tpe-082ws-v1.dts
> @@ -0,0 +1,67 @@
> +// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
> +
> +#include "rtl8380_d-link_dgs-1210-10.dtsi"
> +
> +/ {
> +	compatible = "trendnet,tpe-082ws-v1", "realtek,rtl838x-soc";
> +	model = "Trendnet TPE-082WS V1";
> +
> +	memory@0 {
> +		device_type = "memory";
> +		reg = <0x0 0x10000000>;
> +	};
> +};
> +
> +&spi0 {
> +	status = "okay";
> +
> +	flash@0 {
> +		compatible = "jedec,spi-nor";
> +		reg = <0>;
> +		spi-max-frequency = <50000000>;
> +
> +		partitions {
> +			compatible = "fixed-partitions";
> +			#address-cells = <1>;
> +			#size-cells = <1>;
> +
> +			partition@0 {
> +				label = "u-boot";
> +				reg = <0x00000000 0x0080000>;
> +				read-only;
> +			};
> +
> +			partition@80000 {
> +				label = "u-boot-env";
> +				reg = <0x00080000 0x0040000>;
> +				read-only;
> +			};
> +
> +			partition@c0000 {
> +				label = "u-boot-env2";
> +				reg = <0x000c0000 0x0040000>;
> +			};
> +
> +			partition@100000 {
> +				label = "firmware";
> +				compatible = "denx,uimage";
> +				reg = <0x00100000 0x0e80000>;
> +			};
> +
> +			partition@f80000 {
> +				label = "kernel2";
> +				reg = <0x00f80000 0x0180000>;
> +			};
> +
> +			partition@1100000 {
> +				label = "rootfs2";
> +				reg = <0x01100000 0x0d00000>;
> +			};
> +
> +			partition@1e00000 {
> +				label = "jffs2";
> +				reg = <0x01e00000 0x0200000>;
> +			};
> +		};
> +	};
> +};
> diff --git a/target/linux/realtek/image/Makefile
> b/target/linux/realtek/image/Makefile
> index c7238494606e..94f4d91a089a 100644
> --- a/target/linux/realtek/image/Makefile
> +++ b/target/linux/realtek/image/Makefile
> @@ -80,6 +80,17 @@ define Device/d-link_dgs-1210-10p-r1  endef
> TARGET_DEVICES += d-link_dgs-1210-10p-r1
> 
> +define Device/trendnet_tpe-082ws-v1
> +  SOC := rtl8380
> +  IMAGE_SIZE := 14848k
> +  DEVICE_VENDOR := Trendnet
> +  DEVICE_MODEL := TPE-082WS
> +  DEVICE_VARIANT := V1
> +  # TODO
> +  # DEVICE_PACKAGES += realtek-poe
> +endef
> +TARGET_DEVICES += trendnet_tpe-082ws-v1
> +
>  define Device/d-link_dgs-1210-16
>    $(Device/d-link_dgs-1210)
>    DEVICE_MODEL := DGS-1210-16
> --
> 2.17.1
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/realtek/base-files/etc/board.d/02_network b/target/linux/realtek/base-files/etc/board.d/02_network
index e7c45de92328..f8e06aea3510 100644
--- a/target/linux/realtek/base-files/etc/board.d/02_network
+++ b/target/linux/realtek/base-files/etc/board.d/02_network
@@ -61,6 +61,9 @@  netgear,gs110tpp-v1)
 netgear,gs310tp-v1)
 	ucidef_set_poe 55 "$lan_list"
 	;;
+trendnet,tpe-082ws-v1)
+	ucidef_set_poe 75 "$lan_list"
+	;;
 zyxel,gs1900-10hp)
 	ucidef_set_poe 77 "$lan_list"
 	;;
diff --git a/target/linux/realtek/dts-5.10/rtl8380_trendnet_tpe-082ws-v1.dts b/target/linux/realtek/dts-5.10/rtl8380_trendnet_tpe-082ws-v1.dts
new file mode 100644
index 000000000000..9b61da7ffccf
--- /dev/null
+++ b/target/linux/realtek/dts-5.10/rtl8380_trendnet_tpe-082ws-v1.dts
@@ -0,0 +1,67 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "rtl8380_d-link_dgs-1210-10.dtsi"
+
+/ {
+	compatible = "trendnet,tpe-082ws-v1", "realtek,rtl838x-soc";
+	model = "Trendnet TPE-082WS V1";
+
+	memory@0 {
+		device_type = "memory";
+		reg = <0x0 0x10000000>;
+	};
+};
+
+&spi0 {
+	status = "okay";
+
+	flash@0 {
+		compatible = "jedec,spi-nor";
+		reg = <0>;
+		spi-max-frequency = <50000000>;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = <1>;
+			#size-cells = <1>;
+
+			partition@0 {
+				label = "u-boot";
+				reg = <0x00000000 0x0080000>;
+				read-only;
+			};
+
+			partition@80000 {
+				label = "u-boot-env";
+				reg = <0x00080000 0x0040000>;
+				read-only;
+			};
+
+			partition@c0000 {
+				label = "u-boot-env2";
+				reg = <0x000c0000 0x0040000>;
+			};
+
+			partition@100000 {
+				label = "firmware";
+				compatible = "denx,uimage";
+				reg = <0x00100000 0x0e80000>;
+			};
+
+			partition@f80000 {
+				label = "kernel2";
+				reg = <0x00f80000 0x0180000>;
+			};
+
+			partition@1100000 {
+				label = "rootfs2";
+				reg = <0x01100000 0x0d00000>;
+			};
+
+			partition@1e00000 {
+				label = "jffs2";
+				reg = <0x01e00000 0x0200000>;
+			};
+		};
+	};
+};
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index c7238494606e..94f4d91a089a 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -80,6 +80,17 @@  define Device/d-link_dgs-1210-10p-r1
 endef
 TARGET_DEVICES += d-link_dgs-1210-10p-r1
 
+define Device/trendnet_tpe-082ws-v1
+  SOC := rtl8380
+  IMAGE_SIZE := 14848k
+  DEVICE_VENDOR := Trendnet
+  DEVICE_MODEL := TPE-082WS
+  DEVICE_VARIANT := V1
+  # TODO
+  # DEVICE_PACKAGES += realtek-poe
+endef
+TARGET_DEVICES += trendnet_tpe-082ws-v1
+
 define Device/d-link_dgs-1210-16
   $(Device/d-link_dgs-1210)
   DEVICE_MODEL := DGS-1210-16